X
點擊此處開啟此網站的行動版。

技術支援討論區

Videos don't always allow "Full Screen".

已張貼

Good afternoon,

Here I am again with a little problem.

Not every website that I visit allows videos to be viewed in full screen mode, why?

I have followed the instructions on "how to" whenever I get this, but when I get all the sites that are listed, there is no "Allow Full Screen" button anywhere that I can see.

Can somebody please suggest another way to allow "Full Screen" please.

The last site that wouldn't was BT.com, all others so far do, YouTube, is fine as are other sites that I visit, mainly forums.

Thank you.

Mike.

Good afternoon, Here I am again with a little problem. Not every website that I visit allows videos to be viewed in full screen mode, why? I have followed the instructions on "how to" whenever I get this, but when I get all the sites that are listed, there is no "Allow Full Screen" button anywhere that I can see. Can somebody please suggest another way to allow "Full Screen" please. The last site that wouldn't was BT.com, all others so far do, YouTube, is fine as are other sites that I visit, mainly forums. Thank you. Mike.

由 MikeM3 於 修改

被選擇的解決方法

I followed the instructions about changing the parameter from "true" to "false" in about:config. Then I tried it again clicking on the little full screen icon in the bar at the bottom of the video. Once again it said full screen is not allowed. I then right clicked on the video and there was a full screen option in the drop down menu. I selected that and the video went to full screen. I tried this a couple of times.....the video I was working with is in this link if you want to play with it yourself. http://www.diamondback.com/front-wheel-quick-release

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.73.2 for Mozilla browsers
  • Shockwave Flash 20.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.3.183

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

更多資訊

cor-el
  • Top 10 Contributor
  • Moderator
17481 個解決方法 157974 個答案

有幫助的回覆

Does this happen when a Shockwave Flash plugin based player is used or the HTML5 media player?

You can check via the right-click context menu of the player area what kind of media player is used. A Flash based player shows a context menu with the Flash version.

It is possible that the video is embedded in an iframe and that the outermost iframe is missing the allowfullscreen=true attribute that Firefox needs for the HTML5 media player.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required) to a specific page where full screen mode isn't working?

Does this happen when a Shockwave Flash plugin based player is used or the HTML5 media player? You can check via the right-click context menu of the player area what kind of media player is used. A Flash based player shows a context menu with the Flash version. It is possible that the video is embedded in an iframe and that the outermost iframe is missing the allowfullscreen=true attribute that Firefox needs for the HTML5 media player. *http://blog.pearce.org.nz/2011/11/firefoxs-html-full-screen-api-enabled.html Can you post a link to a publicly accessible page (i.e. no authentication or signing on required) to a specific page where full screen mode isn't working?
jscher2000
  • Top 10 Contributor
8698 個解決方法 71097 個答案

有幫助的回覆

If the problem is that the framed video isn't enabled for full screen, as a workaround, you can pop the video out in another tab:

First, you need to first set Firefox to always show the built-in right-click context menu even when the site tries to replace it. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste menu and pause while the list is filtered

(3) Double-click the dom.event.contextmenu.enabled preference to flip it from true to false

Now when you right click on a framed HTML5 video, Firefox will show the built-in menu in front or or on top of the site's menu. Use This Frame > Open Frame in New Tab to open the embed in its own tab.

With this setting, Firefox's menu may occasionally block the site's menu. In that case, press and release the Alt key to gain access to the site's menu.

If the problem is that the framed video isn't enabled for full screen, as a workaround, you can pop the video out in another tab: First, you need to first set Firefox to always show the built-in right-click context menu even when the site tries to replace it. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''menu''' and pause while the list is filtered (3) Double-click the '''dom.event.contextmenu.enabled''' preference to flip it from true to false Now when you right click on a framed HTML5 video, Firefox will show the built-in menu in front or or on top of the site's menu. Use This Frame > Open Frame in New Tab to open the embed in its own tab. With this setting, Firefox's menu may occasionally block the site's menu. In that case, press and release the Alt key to gain access to the site's menu.

提出問題者

Thank you both for your replies and suggestions.

I will see which version is playing every time I open a video, the "about:config" thing, can I do it anyway, or only when I get one that won't go full screen?

Thank you once again.

Mike.

Thank you both for your replies and suggestions. I will see which version is playing every time I open a video, the "about:config" thing, can I do it anyway, or only when I get one that won't go full screen? Thank you once again. Mike.
jscher2000
  • Top 10 Contributor
8698 個解決方法 71097 個答案

Hi MikeM3, you only need to change the preference in about:config once. After that, you would only need to go back into about:config if you want to switch it back.

Hi MikeM3, you only need to change the preference in about:config once. After that, you would only need to go back into about:config if you want to switch it back.
jscher2000
  • Top 10 Contributor
8698 個解決方法 71097 個答案

Oh, maybe you meant can you pop any video out into its own tab. If it is embedded using a frame, there will be a "This Frame" item on the right-click context menu. If the video is embedded using some other method then that item will be missing. So, feel free to check for that any time you like.

Oh, maybe you meant can you pop any video out into its own tab. If it is embedded using a frame, there will be a "This Frame" item on the right-click context menu. If the video is embedded using some other method then that item will be missing. So, feel free to check for that any time you like.
Bill00 2 個解決方法 7 個答案

選擇的解決方法

I followed the instructions about changing the parameter from "true" to "false" in about:config. Then I tried it again clicking on the little full screen icon in the bar at the bottom of the video. Once again it said full screen is not allowed. I then right clicked on the video and there was a full screen option in the drop down menu. I selected that and the video went to full screen. I tried this a couple of times.....the video I was working with is in this link if you want to play with it yourself. http://www.diamondback.com/front-wheel-quick-release

I followed the instructions about changing the parameter from "true" to "false" in about:config. Then I tried it again clicking on the little full screen icon in the bar at the bottom of the video. Once again it said full screen is not allowed. I then right clicked on the video and there was a full screen option in the drop down menu. I selected that and the video went to full screen. I tried this a couple of times.....the video I was working with is in this link if you want to play with it yourself. http://www.diamondback.com/front-wheel-quick-release
jscher2000
  • Top 10 Contributor
8698 個解決方法 71097 個答案

Hi Bill00, that's a useful discovery.

The difference is that Firefox does not let a script in the embedded site (YouTube) to go full screen when it is in a frame that was not marked as allowfullscreen. But Firefox lets you go fullscreen since it doesn't need to protect you from yourself.

I wonder if that's a recent change?

Hi Bill00, that's a useful discovery. The difference is that Firefox does not let a script in the embedded site (YouTube) to go full screen when it is in a frame that was not marked as allowfullscreen. But Firefox lets ''you'' go fullscreen since it doesn't need to protect you from yourself. I wonder if that's a recent change?
Bill00 2 個解決方法 7 個答案

I don't know if it is a recent change or not. I have been frustrated by the lack of full screen for videos like a lot of others I'm sure. I was just playing around based on the suggestions in this thread when I stumbled on the right click solution. Sometimes stumbling on something that works is the only way to get a solution to a problem.

Oh and I think sometimes I do need protected from myself.....but that's another story!

I don't know if it is a recent change or not. I have been frustrated by the lack of full screen for videos like a lot of others I'm sure. I was just playing around based on the suggestions in this thread when I stumbled on the right click solution. Sometimes stumbling on something that works is the only way to get a solution to a problem. Oh and I think sometimes I do need protected from myself.....but that's another story!
jhughey 2 個解決方法 15 個答案

It is great to see this problem was solved, however the resolution is scattered over the posts.  :-(

Would one of you please summarize HOW this problem was ultimately fixed, starting with Step 1, Step 2, etc... at the beginning of about:config

My wife is using the CVSLearnNet, and the instructional slideshow popups will neither enlarge enough nor go full screen to see the print without eyestrain. The same problem exists with Internet Explorer. Hopefully this is the same problem.

Thanks!

It is great to see this problem was solved, however the resolution is scattered over the posts. :-( Would one of you please summarize HOW this problem was ultimately fixed, starting with Step 1, Step 2, etc... at the beginning of about:config My wife is using the CVSLearnNet, and the instructional slideshow popups will neither enlarge enough nor go full screen to see the print without eyestrain. The same problem exists with Internet Explorer. Hopefully this is the same problem. Thanks!

由 jhughey 於 修改

jscher2000
  • Top 10 Contributor
8698 個解決方法 71097 個答案

Hi jhughey, that sounds like a different issue because the site uses popup windows. Could you start a new question and give a link to a sample video that does it?

You can use this link:

https://support.mozilla.org/questions/new/desktop/websites

Scroll down past the suggested articles to continue submitting your question.

Hi jhughey, that sounds like a different issue because the site uses popup windows. Could you start a new question and give a link to a sample video that does it? You can use this link: https://support.mozilla.org/questions/new/desktop/websites Scroll down past the suggested articles to continue submitting your question.