X
點擊此處開啟此網站的行動版。

技術支援討論區

stop firefox from redirectmg webpages

已張貼

How do I stop Firefox from not allowing redirected web pages

How do I stop Firefox from not allowing redirected web pages

被選擇的解決方法

Press Alt >Tools>Options>Preferences > Advanced > General : Accessibility : Check the option [ ] "Warn me when web sites try to redirect or reload the page"

從原來的回覆中察看解決方案 5

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 20.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.1.171
  • 5.1.41212.0

應用程式

  • Firefox 44.0.2
  • 使用者代理:Mozilla/5.0 (Windows NT 6.3; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/44.0.2/WINNT/en-US/

擴充套件

  • Redirect Control 0.1.0 (redirectcontrol@hjgwmvya)
  • Remove All Cookies 1.0.1-signed (jid0-JwgTzBOAS3QEhtcJAnAjX651jKA@jetpack)
  • HP SimplePass 1.0 (firefox@bho.com) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0f31
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 21de103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.18123
  • driverDate: 1-20-2014
  • driverDate2:
  • driverVersion: 10.18.10.3408
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

修改過的偏好設定

其他

  • User JS: 是
  • 輔助功能: 是
Samrat Bhattacharjee 7 個解決方法 74 個答案

選擇的解決方法

Press Alt >Tools>Options>Preferences > Advanced > General : Accessibility : Check the option [ ] "Warn me when web sites try to redirect or reload the page"

Press Alt >Tools>Options>Preferences > Advanced > General : Accessibility : Check the option [ ] "Warn me when web sites try to redirect or reload the page"

提出問題者

Worked great. Thank you so much. It was driving me crazy.

Worked great. Thank you so much. It was driving me crazy.
bellist 0 個解決方法 8 個答案

I installed a new modem. During the first use of firefox the first webpage I tried was redirected to the company's modem activation page, which didn't go smoothly. Now every time I try that webpage I get the redirection again. All other webpages go where I expect them to. The instructions above do catch the redirection, which is good, but I need to remove the redirection. How?

I installed a new modem. During the first use of firefox the first webpage I tried was redirected to the company's modem activation page, which didn't go smoothly. Now every time I try that webpage I get the redirection again. All other webpages go where I expect them to. The instructions above do catch the redirection, which is good, but I need to remove the redirection. How?
cor-el
  • Top 10 Contributor
  • Moderator
17472 個解決方法 157915 個答案

有幫助的回覆

Hi bellist

Clear the Cache and remove the Cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove the Cookies" from websites that cause problems.

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, history, cookies, passwords, cache, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

Hi bellist Clear the Cache and remove the Cookies from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove the Cookies" from websites that cause problems. *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page. Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, history, cookies, passwords, cache, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of the involved files. If you revisit a 'forgotten' website then data from that website will be saved once again.
Hershmab 3 個解決方法 33 個答案

I have a worse version of this problem. My bank's website is designed to prevent moving from page to page except by using the menus.

But when I used a pop-up menu option and then needed to return to the previous page, the redirection blocker prevented it even though it was a site-authorised option. So I clicked on the Firefox "Allow redirection" option ...... and was logged out of the site!

This happened several times, so I presume that it was the website that caused it, not Firefox. Any ideas?

I have a '''worse '''version of this problem. My bank's website is '''designed '''to prevent moving from page to page except by using the menus. But when I used a pop-up menu option and then needed to return to the previous page, the redirection blocker prevented it even though it was a site-authorised option. So I clicked on the Firefox "Allow redirection" option ...... and was logged out of the site! This happened several times, so I presume that it was the website that caused it, not Firefox. Any ideas?
cor-el
  • Top 10 Contributor
  • Moderator
17472 個解決方法 157915 個答案

Best is to have the redirect protection disabled and remove the checkmark. Having this feature enabled may not always work properly.

  • Firefox > Options/Preferences > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

The setting in "Options > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

Best is to have the redirect protection disabled and remove the checkmark. Having this feature enabled may not always work properly. *Firefox > Options/Preferences > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page" The setting in "Options > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.