X
點擊此處開啟此網站的行動版。

技術支援討論區

no search engine in search list

已張貼

when I click change search settings, I have no search engines in the list and cannot add any. Nothing on the search page works

when I click change search settings, I have no search engines in the list and cannot add any. Nothing on the search page works

被選擇的解決方法

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

You can use this button to go to the current Firefox profile folder:

Firefox will rebuild the search.json file from the default built-in search engines that come with Firefox and the searchplugins folder in the Firefox profile folder.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • GEPlugin
  • Version 5.41.3.0
  • Google Update
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Shockwave Flash 17.0 r0
  • Shockwave Flash 20.0 r0
  • 5.1.41212.0
  • NPWLPG

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

更多資訊

the-edmeister
  • Top 25 Contributor
  • Moderator
5395 個解決方法 40084 個答案

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.


Two Flash Plugins are on your system, which may cause problems. Shockwave Flash 17.0 r0 Shockwave Flash 20.0 r0

Adobe Flash is notorious for not always removing old Flash Plugin DLL files as part of a Flash program update. Sometimes the user needs to uninstall Flash completely and get a clean start.

First, grab the Adobe uninstaller from here: http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

Then download the latest Flash Plugin version from here: Select the Windows > Plugin-based browsers - the EXE version. https://www.adobe.com/products/flashplayer/distribution3.html

Run the Flash uninstaller program, then reboot your PC. Then install the Plugin version of Flash. So you'll have a clean installation of Flash for Firefox.

'''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' --------------- Two Flash Plugins are on your system, which may cause problems. Shockwave Flash 17.0 r0 Shockwave Flash 20.0 r0 Adobe Flash is notorious for not always removing old Flash Plugin DLL files as part of a Flash program update. Sometimes the user needs to uninstall Flash completely and get a clean start. First, grab the Adobe uninstaller from here: http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Then download the latest Flash Plugin version from here: Select the Windows > Plugin-based browsers - the EXE version. https://www.adobe.com/products/flashplayer/distribution3.html Run the Flash uninstaller program, then reboot your PC. Then install the Plugin version of Flash. So you'll have a clean installation of Flash for Firefox.

有幫助的回覆

safemode didn't help. This started (i think) after I did the firefox refresh which looks like it clears all search engines but now I don't have any and cant add any.

safemode didn't help. This started (i think) after I did the firefox refresh which looks like it clears all search engines but now I don't have any and cant add any.

提出問題者

I did the flash uninstall and re-install and still no search options

I did the flash uninstall and re-install and still no search options
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 個解決方法 40084 個答案

Please provide a screenshot of the "list" where those search engines are missing.

Search engine icons should appear in a "panel" in two places, once something has been typed in a "search field"; one appears below the Search "bar" and the other is on the about:home (default) homepage.

They will also appear in about:preferences#search.

Please provide a screenshot of the "list" where those search engines are missing. Search engine icons should appear in a "panel" in two places, once something has been typed in a "search field"; one appears below the Search "bar" and the other is on the about:home (default) homepage. They will also appear in '''about:preferences#search'''.

提出問題者

Here you go

Here you go
cor-el
  • Top 10 Contributor
  • Moderator
17416 個解決方法 157372 個答案

選擇的解決方法

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

You can use this button to go to the current Firefox profile folder:

Firefox will rebuild the search.json file from the default built-in search engines that come with Firefox and the searchplugins folder in the Firefox profile folder.

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default. You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox will rebuild the search.json file from the default built-in search engines that come with Firefox and the searchplugins folder in the Firefox profile folder.

提出問題者

Deleted the search.json and search-metadata.json files as there was no search.sqlite and that fixed it! Thanks to both of you who offered help. Regards

Deleted the search.json and search-metadata.json files as there was no search.sqlite and that fixed it! Thanks to both of you who offered help. Regards
gbvoris 0 個解決方法 4 個答案

I have no search engines, can't find them. With hidden files turned on I still have no search.json or search-metadata.json. A search of home shows no files starting with search. I am using Minit 18 cinamon. I can set my home page to Google, so it isn't a dead deal; but it is a bit of a pain.

I have no search engines, can't find them. With hidden files turned on I still have no search.json or search-metadata.json. A search of home shows no files starting with search. I am using Minit 18 cinamon. I can set my home page to Google, so it isn't a dead deal; but it is a bit of a pain.
rlindx 0 個解決方法 2 個答案

I am having the same issue (no search engines in list, no mechanism to add them) on Firefox 48 running on Linux Mint 18 Mate. The FF profile is "vanilla", with only the automatically-installed default plug-ins / extensions active (i.e., OpenH264 and Flash). Flash (and everything else) are current, per Linux Mint's update function.

The problem began a few days ago, with the automatic update to Firefox 48.

I have done the usual things (run in safe more, delete search.json and search-metadata.json, create a new vanilla profile, and completely remove / reinstall Firefox), all to no avail.

I am having the same issue (no search engines in list, no mechanism to add them) on Firefox 48 running on Linux Mint 18 Mate. The FF profile is "vanilla", with only the automatically-installed default plug-ins / extensions active (i.e., OpenH264 and Flash). Flash (and everything else) are current, per Linux Mint's update function. The problem began a few days ago, with the automatic update to Firefox 48. I have done the usual things (run in safe more, delete search.json and search-metadata.json, create a new vanilla profile, and completely remove / reinstall Firefox), all to no avail.

由 rlindx 於 修改

dobinator 0 個解決方法 1 個答案

same here with Linux Mint 18 - Cinnamon. Tried all the suggestions above, nothing worked. When I start Firefox with "firefox -jsconsole" I get the error "Services.search.defaultEngine is null"...see attached screenshot for details don't know if attaching the screenshot worked, so I paste the errors here:

TypeError: Services.search.currentEngine is null encountered in BrowserUITelemetry.jsm:575:7 and UITour.jsm:1928:15 [Exception... "[JavaScript Error: "Services.search.currentEngine is null" {file: "resource://app/modules/BrowserUITelemetry.jsm" line: 575}]'[JavaScript Error: "Services.search.currentEngine is null" {file: "resource://app/modules/BrowserUITelemetry.jsm" line: 575}]' when calling method: [nsIBrowserSearchInitObserver::onInitComplete]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: resource://gre/components/nsSearchService.js :: onSuccess :: line 3775" data: yes]

engine is null this.ContentSearch._currentEngineObj<() ContentSearch.jsm:487 next() self-hosted TaskImpl_run() Task.jsm:319 TaskImpl() Task.jsm:280 createAsyncFunction/asyncFunction() Task.jsm:254 this.ContentSearch._currentStateObj<() ContentSearch.jsm:470 next() self-hosted TaskImpl_run() Task.jsm:319 TaskImpl() Task.jsm:280 createAsyncFunction/asyncFunction() Task.jsm:254 this.ContentSearch._onMessageGetState() ContentSearch.jsm:258 this.ContentSearch._onMessage<() ContentSearch.jsm:252 next() self-hosted TaskImpl_run() Task.jsm:319 bound TaskImpl_run() self-hosted Handler.prototype.process() Promise-backend.js:937 this.PromiseWalker.walkerLoop() Promise-backend.js:816 bound () self-hosted bound bound () self-hosted this.PromiseWalker.scheduleWalkerLoop/<() Promise-backend.js:750 ContentSearch.jsm:487 TypeError: this.defaultEngine is undefined ContentSearchUIController.prototype._updateDefaultEngineHeader() contentSearchUI.js:621 ContentSearchUIController.prototype._onMsgStrings() contentSearchUI.js:612 ContentSearchUIController.prototype._onContentSearchService() contentSearchUI.js:521 ContentSearchUIController.prototype.handleEvent() contentSearchUI.js:230 ContentSearchMediator._fireEvent() tab-content.js:417 ContentSearchMediator.receiveMessage() tab-content.js:395

same here with Linux Mint 18 - Cinnamon. Tried all the suggestions above, nothing worked. When I start Firefox with "firefox -jsconsole" I get the error "Services.search.defaultEngine is null"...see attached screenshot for details don't know if attaching the screenshot worked, so I paste the errors here: TypeError: Services.search.currentEngine is null encountered in BrowserUITelemetry.jsm:575:7 and UITour.jsm:1928:15 [Exception... "[JavaScript Error: "Services.search.currentEngine is null" {file: "resource://app/modules/BrowserUITelemetry.jsm" line: 575}]'[JavaScript Error: "Services.search.currentEngine is null" {file: "resource://app/modules/BrowserUITelemetry.jsm" line: 575}]' when calling method: [nsIBrowserSearchInitObserver::onInitComplete]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: resource://gre/components/nsSearchService.js :: onSuccess :: line 3775" data: yes] engine is null this.ContentSearch._currentEngineObj<() ContentSearch.jsm:487 next() self-hosted TaskImpl_run() Task.jsm:319 TaskImpl() Task.jsm:280 createAsyncFunction/asyncFunction() Task.jsm:254 this.ContentSearch._currentStateObj<() ContentSearch.jsm:470 next() self-hosted TaskImpl_run() Task.jsm:319 TaskImpl() Task.jsm:280 createAsyncFunction/asyncFunction() Task.jsm:254 this.ContentSearch._onMessageGetState() ContentSearch.jsm:258 this.ContentSearch._onMessage<() ContentSearch.jsm:252 next() self-hosted TaskImpl_run() Task.jsm:319 bound TaskImpl_run() self-hosted Handler.prototype.process() Promise-backend.js:937 this.PromiseWalker.walkerLoop() Promise-backend.js:816 bound () self-hosted bound bound () self-hosted this.PromiseWalker.scheduleWalkerLoop/<() Promise-backend.js:750 ContentSearch.jsm:487 TypeError: this.defaultEngine is undefined ContentSearchUIController.prototype._updateDefaultEngineHeader() contentSearchUI.js:621 ContentSearchUIController.prototype._onMsgStrings() contentSearchUI.js:612 ContentSearchUIController.prototype._onContentSearchService() contentSearchUI.js:521 ContentSearchUIController.prototype.handleEvent() contentSearchUI.js:230 ContentSearchMediator._fireEvent() tab-content.js:417 ContentSearchMediator.receiveMessage() tab-content.js:395

由 dobinator 於 修改

the-edmeister
  • Top 25 Contributor
  • Moderator
5395 個解決方法 40084 個答案

有幫助的回覆

See the "solution" here: https://support.mozilla.org/en-US/questions/1134023
rlindx 0 個解決方法 2 個答案

Thank you - the solution posted by the-edmeister above (i.e., see https://support.mozilla.org/en-US/questions/1134023) resolved the problem for me (I used new value en-US). Thanks again!

Thank you - the solution posted by the-edmeister above (i.e., see https://support.mozilla.org/en-US/questions/1134023) resolved the problem for me (I used new value en-US). Thanks again!