搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Having Issues with Firefox running after upgrading to Win 10. I do have the last 5 crash report id's

more options

Since I've upgraded to Win 10 my existing Firefox is unusable. I run's insanely slow and I get "not responding" and then the script loading message. I do have the last 5 crash report Id's saved but not sure how to get those to you.

Since I've upgraded to Win 10 my existing Firefox is unusable. I run's insanely slow and I get "not responding" and then the script loading message. I do have the last 5 crash report Id's saved but not sure how to get those to you.

被選擇的解決方法

I have to wonder whether something in your Firefox settings from Windows 7 is not compatible with Windows 10.

Could you do this three-minute experiment:

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Don't delete anything here!

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like TEST2016, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile.

Any difference in performance?

When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

從原來的回覆中察看解決方案 👍 1

所有回覆 (15)

more options

Sorry to hear about the crashes. You can paste your report IDs into a reply. If they do not have bp- at the beginning of the code, please click through the report ID to the crash stats server and copy the full URL of the report from the address bar.

More info in this support article "Firefox crashes - asking for support" on getting submitted crash report IDs from the about:crashes page (or from disk).


Regarding two of the other issues, did you see these articles?

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

While still in Safe Mode, post your crash reports.

more options

Thanks much for the help and reply's. I will try the suggestions but in the mean time, I've attached the crashID's. Let me know if this isn't the correct id's.

Thanks

Crash ID: bp-3cba1d43-3378-4631-b00f-e0c322140425 Crash ID: bp-5a4d841b-3421-4336-9531-c44a32120723 Crash ID: bp-6cd8e677-fcce-4b04-a62f-2e1772140508 Crash ID: bp-952d5542-63d2-416b-8a63-4b0eb2120225 Crash ID: bp-9957002d-b820-4b1c-8e07-d71e82140213

more options

To Fred McD...I tried as you suggested, held down the shift key and launched Firefox. Still unresponsive. I might add that I had no issues while still on Win 7, it's only after I upgraded. I also was able after a lengthy time (20 min.) to disable all the extensions I have running and still no help.

more options

As a followup...I tried safe mode again and only slight improvement, but still "unresponsive" I've attached a screen shot. And it has stayed in Not Responding for the last 10 minutes.

由 blindlemon 於 修改

more options

Hi blindlemon, when I clicked the report links in your post, they didn't give me the actual reports. If you can access the reports, could you get the full URLs from the report pages themselves?

Or this might be a temporary glitch with the server -- it gets a lot of data...

more options

Ten minutes is too long. Something is blocking.

Since Flash can cause freezes and it is used pervasively through the web, I suggest the following to minimize potential issues with Flash during your troubleshooting:

(1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.)

The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

(2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

more options

Hello jscher2000, I will try your suggestions with the settings, it just takes a very long time to be able to interact at all in FF. I also tried the about:crashes to see if I could get you more info....been in a Not Responding mode for 5 min., but it did finally come up. Interesting, the last submitted crash report is from 11/11/2015. Does this help: https://crash-stats.mozilla.com/report/index/4e59b1ca-baaa-458e-b017-14b322160205

Or this: https://crash-stats.mozilla.com/report/index/34b49a85-735e-49a0-b5d1-4c1ec2160205

more options

Hi blindlemon, both of those reports are for freezes in the Flash plugin so it's probably a good idea to address Flash as a potential culprit.

more options

Update: I set shockwave to "ask to activate", closed FF and restarted. Entered a site and FF went into "Not Responding" mode and won't release now. Also after a time I got the unresponsive script message on our company site...never got that before with our site. I stopped the script and back into "Not Responding".

more options

選擇的解決方法

I have to wonder whether something in your Firefox settings from Windows 7 is not compatible with Windows 10.

Could you do this three-minute experiment:

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Don't delete anything here!

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like TEST2016, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile.

Any difference in performance?

When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

more options

I gave that a whirl and wow, the new profile made a big difference! Using the new profile runs like the way it used to. So it would make sense to stay with this profile and build extensions, plugins etc. That sounds like a good strategy? So what is happening with the old profile? Win 10 doesn't like something in that profile?

more options

Things that work in one Windows may not work with another.

more options

I really appreciate the help here. I use two browsers at work and without FF it was hamstringing my progress. You guys ROCK!!

more options

blindlemon said

So what is happening with the old profile? Win 10 doesn't like something in that profile?

Something in the old profile is not compatible, but it's hard to know what it is because so many little settings differences can accumulate.

As an intermediate step, you might try switching back to your regular profile, assuming it can run for 3 minutes, and then use the Refresh feature. That creates a new profile with a subset of your settings and it would be less data transfer work if that is stable.