X
點擊此處開啟此網站的行動版。
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

技術支援討論區

Connectivity issues after Firefox 44 update

已張貼

This is a follow-up to https://support.mozilla.org/en-US/questions/1107429?utm_campaign=questions-solved&utm_medium=email&utm_source=notification#answer-838609

After updating to 44.0, I am mostly unable to get FF to connect to the 'Net. Approximately 90% of the time It just hangs trying to connect.

I have found starting in safe mode works: FF connects to the 'Net.

I have found reinstalling 44.0 will work - just once. After that, FF hangs.

If I disable plugins and addons, FF _still_ does not connect.

1) I see other people are having this problem (see link above.)

2) What is the difference between disabling all addons and plugins and starting FF in safe mode?

This is a follow-up to https://support.mozilla.org/en-US/questions/1107429?utm_campaign=questions-solved&utm_medium=email&utm_source=notification#answer-838609 After updating to 44.0, I am mostly unable to get FF to connect to the 'Net. Approximately 90% of the time It just hangs trying to connect. I have found starting in safe mode works: FF connects to the 'Net. I have found reinstalling 44.0 will work - just once. After that, FF hangs. If I disable plugins and addons, FF _still_ does not connect. 1) I see other people are having this problem (see link above.) 2) What is the difference between disabling all addons and plugins and starting FF in safe mode?

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • Camera Control Class, version: 1.0.0.8111.
  • Dragon NaturallySpeaking Rich Internet Application Support - Plugin
  • GEPlugin
  • Google Update
  • Logitech Harmony Remote Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.71.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Motive Management Plug-in for Mozilla Browsers
  • Motive Plugin for Mozilla Browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 20.0 r0
  • 5.1.41212.0
  • TRENDnet Cloud Control, version: 1.0.1.4212.
  • iTunes Detector Plug-in

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

更多資訊

FredMcD
  • Top 10 Contributor
4388 個解決方法 61579 個答案

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?


Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

'''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode%20Safe%20Mode Safe Mode]''' is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else. ------------ Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? ---------- Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.'''

提出問題者

Responding to FredMcD.

Thank you FredMcD. Your suggestions did not solve my problem.

I tried as you suggested in sequence. Neither reenabled FF's ability to connect to the 'Net.

Restarting FF in safe mode restores FF's ability to connect to the net.

The website I tried to get to was www.google.com

Responding to FredMcD. Thank you FredMcD. Your suggestions did not solve my problem. I tried as you suggested in sequence. Neither reenabled FF's ability to connect to the 'Net. Restarting FF in safe mode restores FF's ability to connect to the net. The website I tried to get to was www.google.com

由 RalphShnelvar 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17850 個解決方法 161559 個答案

If it works in Safe Mode and in normal mode with all extensions (3-bar Menu button/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via *3-bar Menu button > Exit (Power button)

  • Windows: File > Exit
  • Mac: Firefox > Quit Firefox
  • Linux: File > Quit

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use this button to go to the current Firefox profile folder:

If it works in Safe Mode and in normal mode with all extensions (3-bar Menu button/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Close and restart Firefox after each change via *3-bar Menu button > Exit (Power button) *Windows: File > Exit *Mac: Firefox > Quit Firefox *Linux: File > Quit ---- You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox

提出問題者

cor-el said

If it works in Safe Mode and in normal mode with all extensions (3-bar Menu button/Tools > Add-ons > Extensions) disabled then

It works in safe mode. It does not work in normal mode with all extensions disabled.

''cor-el [[#answer-839483|said]]'' <blockquote> If it works in Safe Mode and in normal mode with all extensions (3-bar Menu button/Tools > Add-ons > Extensions) disabled then </blockquote> It works in safe mode. It does not work in normal mode with all extensions disabled.

由 RalphShnelvar 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17850 個解決方法 161559 個答案

Are there extensions appearing in about:addons that you do not see in normal mode or extensions that do not have a Remove button?

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Are there extensions appearing in about:addons that you do not see in normal mode or extensions that do not have a Remove button? Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

提出問題者

cor-el said

You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases. You can use this button to go to the current Firefox profile folder:

Ok ... a little bizarre now.

I renamed prefs to prefs.hold.

I restarted FF.

FF would not connect to the Internet.

I deleted prefs.

I renamed prefs.hold back to prefs.

Now FF is connecting.

Strange.

''cor-el [[#answer-839483|said]]'' <blockquote> You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox </blockquote> Ok ... a little bizarre now. I renamed prefs to prefs.hold. I restarted FF. FF would not connect to the Internet. I deleted prefs. I renamed prefs.hold back to prefs. Now FF is connecting. Strange.

提出問題者

RalphShnelvar said

cor-el said
Ok ... a little bizarre now. I renamed prefs to prefs.hold. I restarted FF. FF would not connect to the Internet. I deleted prefs. I renamed prefs.hold back to prefs. Now FF is connecting. Strange.

And then I logged out of FF and back in again ... Same problem. I need to be in safe mode to get it to work.

Sigh.

''RalphShnelvar [[#answer-839497|said]]'' <blockquote> ''cor-el [[#answer-839483|said]]'' <blockquote> Ok ... a little bizarre now. I renamed prefs to prefs.hold. I restarted FF. FF would not connect to the Internet. I deleted prefs. I renamed prefs.hold back to prefs. Now FF is connecting. Strange. </blockquote> And then I logged out of FF and back in again ... Same problem. I need to be in safe mode to get it to work. Sigh.
cor-el
  • Top 10 Contributor
  • Moderator
17850 個解決方法 161559 個答案

What are the connection settings?

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.


Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

What are the connection settings? *Tools > Options > Advanced > Network : Connection > Settings *https://support.mozilla.org/kb/Options+window+-+Advanced+panel If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/kb/Firefox+cannot+load+websites+but+other+programs+can Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 ---- Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

提出問題者

RalphShnelvar said

RalphShnelvar said
cor-el said
Ok ... a little bizarre now. I renamed prefs to prefs.hold. I restarted FF. FF would not connect to the Internet. I deleted prefs. I renamed prefs.hold back to prefs. Now FF is connecting. Strange.

And then I logged out of FF and back in again ... Same problem. I need to be in safe mode to get it to work.

Sigh.

A little more bizarre now. I attempted to start FF (not in safe mode, I think) ... and FF refused to start. I needed to reboot my system to get FF to start again.

cor-el, I will now try your suggestions about connection settings.

''RalphShnelvar [[#answer-839498|said]]'' <blockquote> ''RalphShnelvar [[#answer-839497|said]]'' <blockquote> ''cor-el [[#answer-839483|said]]'' <blockquote> Ok ... a little bizarre now. I renamed prefs to prefs.hold. I restarted FF. FF would not connect to the Internet. I deleted prefs. I renamed prefs.hold back to prefs. Now FF is connecting. Strange. </blockquote> And then I logged out of FF and back in again ... Same problem. I need to be in safe mode to get it to work. Sigh. </blockquote> A little more bizarre now. I attempted to start FF (not in safe mode, I think) ... and FF refused to start. I needed to reboot my system to get FF to start again. cor-el, I will now try your suggestions about connection settings.

提出問題者

cor-el said

What are the connection settings? If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

Dear god (or the god-like corel)!

Setting "no proxy" seems to have cleared the problem!

I made no changes to any network setting in the last few days except, of course, the change you recommended.

Let's not mark this as solved yet as it may be a coincidence.

''cor-el [[#answer-839505|said]]'' <blockquote> What are the connection settings? *Tools > Options > Advanced > Network : Connection > Settings *https://support.mozilla.org/kb/Options+window+-+Advanced+panel If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. </blockquote> Dear god (or the god-like corel)! Setting "no proxy" seems to have cleared the problem! I made no changes to any network setting in the last few days except, of course, the change you recommended. Let's not mark this as solved yet as it may be a coincidence.
cor-el
  • Top 10 Contributor
  • Moderator
17850 個解決方法 161559 個答案

You're welcome.

Do you still remember what the previous connection settings were?

You're welcome. Do you still remember what the previous connection settings were?

提出問題者

cor-el said

Do you still remember what the previous connection settings were?

I believe it was "Use System Proxy Settings"

I see in my current prefs.js: user_pref("network.proxy.type", 0);

I took an image backup of my system yesterday before I started fiddling with changes.

When I look at prefs.js from yesterday, there is no "user_pref("network.proxy.type", 0);" line so I guess it takes whatever the default is. What is the default?

''cor-el [[#answer-839513|said]]'' <blockquote> Do you still remember what the previous connection settings were? </blockquote> I believe it was "Use System Proxy Settings" I see in my current prefs.js: user_pref("network.proxy.type", 0); I took an image backup of my system yesterday before I started fiddling with changes. When I look at prefs.js from yesterday, there is no "user_pref("network.proxy.type", 0);" line so I guess it takes whatever the default is. What is the default?
cor-el
  • Top 10 Contributor
  • Moderator
17850 個解決方法 161559 個答案

Value "0" is the "No Proxy". The default is 5: "Use the system proxy settings"

Value "0" is the "No Proxy". The default is 5: "Use the system proxy settings" *http://kb.mozillazine.org/network.proxy.type

提出問題者

Sadly, the change to "no proxy" only solved the problem temporarily.

To repeat the symptoms:

  • FF seems to work fine in safe more. It is able to connect to the 'Net. In normal mode it does not.
  • Sometimes FF refuses to start.
  • Sometimes FF refuses to add a new window (not tab)
  • Disabling all addons and plugins does not cure the problem when restarting FF
  • New symptom: Adobe flash crashes a lot when installed and enabled. I have uninstalled Adobe flash and am still having problems.
  • If I reinstall FF, FF connects to the 'Net the first time and then does not.

Explorer and Chrome have no problems connecting to the 'Net.

Sadly, the change to "no proxy" only solved the problem temporarily. To repeat the symptoms: * FF seems to work fine in safe more. It is able to connect to the 'Net. In normal mode it does not. * Sometimes FF refuses to start. * Sometimes FF refuses to add a new window (not tab) * Disabling all addons and plugins does not cure the problem when restarting FF * New symptom: Adobe flash crashes a lot when installed and enabled. I have uninstalled Adobe flash and am still having problems. * If I reinstall FF, FF connects to the 'Net the first time and then does not. Explorer and Chrome have no problems connecting to the 'Net.
cor-el
  • Top 10 Contributor
  • Moderator
17850 個解決方法 161559 個答案

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

提出問題者

So I create a new profile.

FF works in safe mode. In normal mode it refuses to connect to the 'Net.

Chrome and IE does not have this problem.

- - -

From my old profile, I exported the bookmarks to an HTML file.

I am unable to import the bookmarks to the new profile.

I installed FF X64. I am unable to import the bookmarks there either.

Let me see if FF X64 has the same connectivity issue.

So I create a new profile. FF works in safe mode. In normal mode it refuses to connect to the 'Net. Chrome and IE does not have this problem. - - - From my old profile, I exported the bookmarks to an HTML file. I am unable to import the bookmarks to the new profile. I installed FF X64. I am unable to import the bookmarks there either. Let me see if FF X64 has the same connectivity issue.

有幫助的回覆

I have a work-around that worked for me.

I uninstalled FF-x86

I installed FF-x64

I created a new profile using

 firefox.exe -p

then

 I copied over the profile which did not work on FF-x86.

All is well now.

Note. The old profile had the proxy set to system. This works, as well.

Let's keep this open for a couple of day to see if this really resolved the issue.

I have a work-around that worked for me. I uninstalled FF-x86 I installed FF-x64 I created a new profile using firefox.exe -p then I copied over the profile which did not work on FF-x86. All is well now. Note. The old profile had the proxy set to system. This works, as well. Let's keep this open for a couple of day to see if this really resolved the issue.
msholind 0 個解決方法 5 個答案

Hi,

I have had similar issue. Just wondering, do you have NVidia video card? Not that it should be related but I found information that v44, 32-bit has issue with NVidia video cards and DNS.

Hi, I have had similar issue. Just wondering, do you have NVidia video card? Not that it should be related but I found information that v44, 32-bit has issue with NVidia video cards and DNS.

提出問題者

msholind said

Hi, I have had similar issue. Just wondering, do you have NVidia video card? Not that it should be related but I found information that v44, 32-bit has issue with NVidia video cards and DNS.

Yes, I have an NVIDIA video card. Could you please provide a link to the problem?

- - -

My solution posted on 2/5/16, 5:39 PM seems to be working.

''msholind [[#answer-842590|said]]'' <blockquote> Hi, I have had similar issue. Just wondering, do you have NVidia video card? Not that it should be related but I found information that v44, 32-bit has issue with NVidia video cards and DNS. </blockquote> Yes, I have an NVIDIA video card. Could you please provide a link to the problem? - - - My solution posted on 2/5/16, 5:39 PM seems to be working.
msholind 0 個解決方法 5 個答案

有幫助的回覆

The link to Mozilla bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1243765

Comment #1 ( philipp ) seems to correlated several similar reported issues to NVidia video card. Hopefully Mozilla support team can confirm all these similar issues are related to NVidia GPU.

The link to Mozilla bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1243765 Comment #1 ( philipp ) seems to correlated several similar reported issues to NVidia video card. Hopefully Mozilla support team can confirm all these similar issues are related to NVidia GPU.