搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Flash Player always crashes on Firefox. Tried everything!

  • 3 回覆
  • 2 有這個問題
  • 31 次檢視
  • 最近回覆由 FredMcD

more options

Flash player is always crashing with the message "Flash player has stopped working". I have uninstalled and reinstalled Firefox to the latest version it will allow 43.0.1 (I'm running Vista 32 bit if that makes a difference) and have completely uninstalled Flash and followed a guide to delete all previous Flash files. I then downloaded the latest version of Flash and checked about:plugins to make sure it was the only version running. I have also tried every other guide I've found that mentions changing the Flash protected mode settings and disabling hardware acceleration. Still no joy whatsoever. Any other diagnostics I can do or solutions you can think of? This has been a problem with Firefox for a long time now and whereas I can understand why they do it, it is also immensely frustrating that there isn't an easy way to enable Flash (yes, I've set it to Always Activate as well). At this stage I'm on the verge of uninstalling Firefox for good because I've had enough. Any suggestions for a fix? Or are sites that use Flash just incompatible with Firefox now?

所有回覆 (3)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?


If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

more options

Yes, the problem is still there in safe mode.

I checked for graphics driver updates and it did update, but the problem is still there.

Disabling protected mode doesn't make a difference.

I can't disable hardware acceleration. The advice is to go to the Flash help page and right click on the video with the tree and select the option from there. I can't do this however as the instant I go to the page the Flash Player immediately crashes and there's nothing to right click on. It constantly freezes the page too as the "Flash Player has stopped working" error message reappears every few seconds.

Nothing else in those links worked.

more options

This is not a cure, but should let the web page load without crashing.

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it


Hello,

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.