搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Why does searching.com show up every time I start firefox?

  • 3 回覆
  • 3 有這個問題
  • 19 次檢視
  • 最近回覆由 Annie_Miller

more options

Since the last firefox update, every time I open the browser, Searching.com comes up. I've deselected all the search engines in the options menu from the toolbar, but that didn't help. I've even put in my preferred search engine, but that one doesn't even show up. I'm getting a little irritated that this search engine keeps popping up, and it includes a 'your computer may be compromised. please do this to fix it.' I have avast full version, so there should be no issues with malware. Help!

被選擇的解決方法

Are you talking about the home page?

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

從原來的回覆中察看解決方案 👍 0

所有回覆 (3)

more options

選擇的解決方法

Are you talking about the home page?

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

more options

You can also check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

You can open the about:config page via the location/address bar and search for prefs that refer to Searching.com. You can reset user set (bold) Searching.com pref(s) via the right-click context menu to the default value. You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

It seems that your browser is hijacked by Searching.com browser hijacker. You can try removing this browser hijacker by following the manual removal guide given in this post.