Search Support

Only My Default Profile user Cannot Add a Permanent Exception

  • 6 回覆
  • 8 有這個問題
  • 1607 次檢視
  • 最近回覆由 mmartin0926

more options

Hello All,

Running Firefox 31.8.0 for OpenSUSE 11.4 (*which is the highest version available for my OS)

A few months back I had updated Firefox (*I installed a patch that was available this morning to go to version 31.8), but I can't remember from what version to what version, or if that was even the root cause of the issue when I updated it sometime in 2015. But, ever since that I have been having issues adding a "Permanent" Exception for any of our Internal https sites/servers that have an expired certificate.

So for example, I go to this one server and when I do, I get a warning that: "This Connection is Untrusted You have asked Firefox to connect securely to, but we can't confirm that your connection is secure...."

So I click "Add Exception" and then in the Pop-up I leave "Permanently store this exception" checkbox checked, and I click "Confirm Security Exception" and when I do nothing happens at all... If I were to then uncheck the "Permanently store this exception" checkbox and click on "Confirm Security Exception" again, this time it works. But, it's only storing a temporary exception, the permanent checkbox used to work at some point a while back but now its not...

However, if I re-open Firefox and choose my secondary profile called "temp" and load that instead of my regular profile "default", and I naviagte to the same page and Confirm Security Exception with the Permanent checkbox checked, it works perfectly.

Is there something wrong with my Profile? I have some much under this Profile I really don't want to loose it.

If anyone has any thoughts or suggestions, please feel free to respond. It would be greatly appreciated!

Thanks in Advance, Matt


Firefox needs to be closed when you do such modifications to files in the profile folder. Otherwise Firefox may create a new file when closing.

從原來的回覆中察看解決方案 👍 1

All Replies (6)

more options

Make sure that you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; never remember history).

  • Edit > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

Note that it isn't recommended to make a permanent exception, but you should investigate the cause and possibly install missing intermediate certificate in case the server doesn't send a full certificate chain.

You should be able to install and run the current release on OpenSUSE 11.4

What is preventing you from using more recent Firefox versions?

Did you check the System Requirements?

more options

Hi cor-el, thanks for the reply!

In my Privacy settings I have, "Firefox Will: Remember History"...

The Exception is for an INTERNAL Cisco Unified Communications server that has an expired Certificate, so it is not really a threat... And currently my company is in our busiest time of the year and making changes to any of our important servers like these is just not possible at this time...

Since I can Permanently add an exception with a different Firefox Profile, wouldn't that point to something being wrong with My default Profile that I use everyday?

The Repo for my Suse version only goes up to the version that I currently have now... And I thought I remember something about my Kernel is not supported by anything higher then the version I have now... Kernel =

Thanks again for the reply, much appreciated!


more options

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored.

If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

more options

Hey Cor-el, thanks again for the reply!

I wasn't sure if I needed to restart Firefox after modifying those files, but I renamed cert8.db to cert8.db.old and I renamed cert_override.txt to cert_override.txt_OLD and then retired getting to that server. When it loaded I got the Security warning page again, but with the "Permanently store this Exception" checkbox checked nothing happened when I clicked "Confirm Security Exception". Un-checking the checkbox and clicking the Confirm button again allows me to continue to the server, but without adding it permanently...

I guess I'm curious if it matters if Firefox was running when I modified those files and if I needed to restart firefox after doing so?

Thanks Again, Matt

more options


Firefox needs to be closed when you do such modifications to files in the profile folder. Otherwise Firefox may create a new file when closing.

more options

Nice..! That seemed to do it...!

Before starting up Firefox today, I did the modifications to the cert* files as you suggested, then I started up Firefox, went to the "trouble" page and this time clicking the "Confirm Security Exception" button WITH the "Permanently...." checkbox checked seemed worked!

Thanks again for your help on this, it is very much appreciated!

Thanks Again, Matt