X
點擊此處開啟此網站的行動版。

技術支援討論區

Secure connection failed TLS Message

已張貼

Hi,

I have been using a website daily without issue for several years, suddenly last week I received a message saying secure connection failed when trying to do a search function on the website.

It has today got worse as I get the message now as soon as I log on, rather than when I just do a search.

The site is fine and I have used it for years. Please see attached screenshot.

Please help as its really driving me crazy!!

Many thanks Helen

Hi, I have been using a website daily without issue for several years, suddenly last week I received a message saying secure connection failed when trying to do a search function on the website. It has today got worse as I get the message now as soon as I log on, rather than when I just do a search. The site is fine and I have used it for years. Please see attached screenshot. Please help as its really driving me crazy!! Many thanks Helen

被選擇的解決方法

Hi All,

Its been some time, but just for completeness, this issue here was with using British Telecom, the ISP. They did something, I don't know what. We have changed ISP and everything is working fine.

Its all a bit of a mystery what BT did but the ISP was the the issue. Thank you for all your help.

Regards Helen

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • My.com Games Detector Plug-in
  • Shockwave Flash 20.0 r0
  • Skype Web Plugin 7.12.0.55
  • VLC media player Web Plugin
  • Zoom launcher - 3.0.1

應用程式

  • Firefox 43.0.2
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/43.0.2/WINNT/en-GB/

擴充套件

  • Adblock Plus 2.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Ghostery 5.4.9 (firefox@ghostery.com)
  • Avast Online Security 10.3.3.13 (wrc@avast.com) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 163d1043
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 6-11-2014
  • driverDate2:
  • driverVersion: 10.18.10.3643
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

修改過的偏好設定

其他

  • User JS: 是
  • 輔助功能: 否
FredMcD
  • Top 10 Contributor
4266 個解決方法 59836 個答案

There is security software like Avast and Kaspersky and BitDefender and ESET that intercept secure connections and send their own certificate.

http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html

https://support.mozilla.org/en-US/kb/server-not-found-connection-problem

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites

This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

There is security software like Avast and Kaspersky and BitDefender and ESET that intercept secure connections and send their own certificate. http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html https://support.mozilla.org/en-US/kb/server-not-found-connection-problem https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message '''http://kb.mozillazine.org/Error_loading_websites''' '''This Connection is Untrusted''' is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

提出問題者

Hi Fred,

I think I tried everything related to this issue from the links. I even uninstalled Avast completely and tried again but that didn't work either.

Still having the same issue.

Cheers Helen

Hi Fred, I think I tried everything related to this issue from the links. I even uninstalled Avast completely and tried again but that didn't work either. Still having the same issue. Cheers Helen
FredMcD
  • Top 10 Contributor
4266 個解決方法 59836 個答案

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. Is the problem still there? ----------- Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''
cor-el
  • Top 10 Contributor
  • Moderator
17567 個解決方法 158896 個答案

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate: *chrome://pippki/content/exceptionDialog.xul In the location field of this window type or paste the URL of the website. *retrieve the certificate via the "Get certificate" button *click the "View..." button to inspect the certificate in the Certificate Viewer You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

提出問題者

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Hi Fred,

Yes, the problem still exists after doing this.

Regards Helen

''FredMcD [[#answer-822817|said]]'' <blockquote> Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. Is the problem still there? ----------- Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]''' </blockquote> Hi Fred, Yes, the problem still exists after doing this. Regards Helen

提出問題者

cor-el said

If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:
  • chrome://pippki/content/exceptionDialog.xul
In the location field of this window type or paste the URL of the website.
  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer
You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

Hi Cor-el,

I did this and it said the certificate is ok - please see attached.

Cheers Helen

''cor-el [[#answer-822841|said]]'' <blockquote> If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate: *chrome://pippki/content/exceptionDialog.xul In the location field of this window type or paste the URL of the website. *retrieve the certificate via the "Get certificate" button *click the "View..." button to inspect the certificate in the Certificate Viewer You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer. </blockquote> Hi Cor-el, I did this and it said the certificate is ok - please see attached. Cheers Helen
FredMcD
  • Top 10 Contributor
4266 個解決方法 59836 個答案

You still had the problem with the Computer in Safe Mode?

Please post a public link we can check out.

You still had the problem with the '''Computer''' in Safe Mode? Please post a public link we can check out.

提出問題者

FredMcD said

You still had the problem with the Computer in Safe Mode? Please post a public link we can check out.

Hi Fred,

Yes, I had the problem in safe mode with networking.

For the public link, do you mean the web site I'm trying to access?

Cheers Helen

''FredMcD [[#answer-822966|said]]'' <blockquote> You still had the problem with the '''Computer''' in Safe Mode? Please post a public link we can check out. </blockquote> Hi Fred, Yes, I had the problem in safe mode with networking. For the public link, do you mean the web site I'm trying to access? Cheers Helen
FredMcD
  • Top 10 Contributor
4266 個解決方法 59836 個答案

Post the link(s) you are using, and describe what you did that brought up the error.

Post the link(s) you are using, and describe what you did that brought up the error.

提出問題者

FredMcD said

Post the link(s) you are using, and describe what you did that brought up the error.

Ok,

I go to https://www.appeagle.com/ then I click the login button in the top right corner. I then add my account details and click the login button under the account details. The error comes up at that point after quite a few seconds.

''FredMcD [[#answer-823008|said]]'' <blockquote> Post the link(s) you are using, and describe what you did that brought up the error. </blockquote> Ok, I go to https://www.appeagle.com/ then I click the login button in the top right corner. I then add my account details and click the login button under the account details. The error comes up at that point after quite a few seconds.
jscher2000
  • Top 10 Contributor
8785 個解決方法 71849 個答案

Just in case you haven't already...

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

Just in case you haven't already... When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click a blank area of the page and choose View Page Info > Security > "View Cookies" * (menu bar) Tools > Page Info > Security > "View Cookies" * click the padlock or globe icon in the address bar > More Information > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does that help?
cor-el
  • Top 10 Contributor
  • Moderator
17567 個解決方法 158896 個答案

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored.

If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored. If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

提出問題者

jscher2000 said

Just in case you haven't already... When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: How to clear the Firefox cache If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:
  • right-click a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"
In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does that help?

Hi,

Already tried that, but many thanks for your reply.

Cheers Helen

''jscher2000 [[#answer-823040|said]]'' <blockquote> Just in case you haven't already... When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click a blank area of the page and choose View Page Info > Security > "View Cookies" * (menu bar) Tools > Page Info > Security > "View Cookies" * click the padlock or globe icon in the address bar > More Information > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does that help? </blockquote> Hi, Already tried that, but many thanks for your reply. Cheers Helen

提出問題者

Hi,

Just a bit of further information which seems wierd.

When I first started getting this issue on Firefox, I tried accessing the site on Chrome browser and it worked. However, I've just tried it again and it has stopped working.

So, I have just now tried it on Internet Explorer and it worked, then I tried it for a second time and it stopped working.

It looks like using a browser once on the site seems to break it!

So maybe this isn't just a Firefox issue after all. But I've no idea what it could be.

Cheers Helen

Hi, Just a bit of further information which seems wierd. When I first started getting this issue on Firefox, I tried accessing the site on Chrome browser and it worked. However, I've just tried it again and it has stopped working. So, I have just now tried it on Internet Explorer and it worked, then I tried it for a second time and it stopped working. It looks like using a browser once on the site seems to break it! So maybe this isn't just a Firefox issue after all. But I've no idea what it could be. Cheers Helen
cor-el
  • Top 10 Contributor
  • Moderator
17567 個解決方法 158896 個答案

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.


Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 ---- Do a malware check with several malware scanning programs on the Windows computer. *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked

提出問題者

cor-el said

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Hi Cor-el,

I tried the safe mode with networking before and it didn't help. My thinking was also going down the malware route. May take a while but I will run all those programs.

Cheers Helen

''cor-el [[#answer-823123|said]]'' <blockquote> Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10 ---- Do a malware check with several malware scanning programs on the Windows computer. *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked </blockquote> Hi Cor-el, I tried the safe mode with networking before and it didn't help. My thinking was also going down the malware route. May take a while but I will run all those programs. Cheers Helen

提出問題者

Hi Cor-el,

I tried all the scans, plus I did a boot scan using Avast. A couple of things were found and fixed but no progress with the original connection problem.

Cheers Helen

Hi Cor-el, I tried all the scans, plus I did a boot scan using Avast. A couple of things were found and fixed but no progress with the original connection problem. Cheers Helen
FredMcD
  • Top 10 Contributor
4266 個解決方法 59836 個答案

SpoodleDoodle said

When I first started getting this issue on Firefox, I tried accessing the site on Chrome browser and it worked. However, I've just tried it again and it has stopped working.

So, I have just now tried it on Internet Explorer and it worked, then I tried it for a second time and it stopped working.

As a test, disable your protection programs.

''SpoodleDoodle [[#answer-823120|said]]'' <blockquote> When I first started getting this issue on Firefox, I tried accessing the site on Chrome browser and it worked. However, I've just tried it again and it has stopped working. <br><br> So, I have just now tried it on Internet Explorer and it worked, then I tried it for a second time and it stopped working. </blockquote> As a test, disable your protection programs.

提出問題者

FredMcD said

SpoodleDoodle said
When I first started getting this issue on Firefox, I tried accessing the site on Chrome browser and it worked. However, I've just tried it again and it has stopped working.

So, I have just now tried it on Internet Explorer and it worked, then I tried it for a second time and it stopped working.

As a test, disable your protection programs.

Hi Fred,

I deleted my Antivirus and tried it but that didn't make any difference. I could try deleting it and disabling the firewall and windows defender. I will report back.

Cheers Helen

''FredMcD [[#answer-823382|said]]'' <blockquote> ''SpoodleDoodle [[#answer-823120|said]]'' <blockquote> When I first started getting this issue on Firefox, I tried accessing the site on Chrome browser and it worked. However, I've just tried it again and it has stopped working. <br><br> So, I have just now tried it on Internet Explorer and it worked, then I tried it for a second time and it stopped working. </blockquote> As a test, disable your protection programs. </blockquote> Hi Fred, I deleted my Antivirus and tried it but that didn't make any difference. I could try deleting it and disabling the firewall and windows defender. I will report back. Cheers Helen

提出問題者

</blockquote>

Hi Fred,

I deleted my Antivirus and tried it but that didn't make any difference. I could try deleting it and disabling the firewall and windows defender. I will report back.

Cheers Helen </blockquote>

Sadly, this had no effect either.

Cheers Helen

</blockquote> Hi Fred, I deleted my Antivirus and tried it but that didn't make any difference. I could try deleting it and disabling the firewall and windows defender. I will report back. Cheers Helen </blockquote> Sadly, this had no effect either. Cheers Helen