X
點擊此處開啟此網站的行動版。

技術支援討論區

Jerky scrolling, unresponsive

已張貼

Hi,

Scrolling has become unresponsive (at times a few seconds) and, when it finally scrolls, it does so with a jerk. This happens especially on websites as Rakuten and eBay when there are lots of small images and lots of open tabs. Page loading too is slow.

Please note that I have sufficient throughput as we regularly stream 2 XHD (1080p) movies simoultaneously flawlessly. I experience the problem on my Sony Vaio VPCSA (6GB RAM) running Win7. everything is updated.

Troubleshooting: Deselected hardware acceleration: no improvement. FF in safemode: very slight improvement (but maybe this was only my wishful perception). Disable Add-Ons: I could not test. The tabs "Services", "Appearance" and "Extensions" show this message: "You don't have any add-ons of this type installed" while I do have quite a few extensions installed. The "Plug-ins" tab regularly shows all the correct plug-ins that are installed.

Please advise how to restore smooth and fast scrolling.

Tommaso

Hi, Scrolling has become unresponsive (at times a few seconds) and, when it finally scrolls, it does so with a jerk. This happens especially on websites as Rakuten and eBay when there are lots of small images and lots of open tabs. Page loading too is slow. Please note that I have sufficient throughput as we regularly stream 2 XHD (1080p) movies simoultaneously flawlessly. I experience the problem on my Sony Vaio VPCSA (6GB RAM) running Win7. everything is updated. Troubleshooting: Deselected hardware acceleration: no improvement. FF in safemode: very slight improvement (but maybe this was only my wishful perception). Disable Add-Ons: I could not test. The tabs "Services", "Appearance" and "Extensions" show this message: "You don't have any add-ons of this type installed" while I do have quite a few extensions installed. The "Plug-ins" tab regularly shows all the correct plug-ins that are installed. Please advise how to restore smooth and fast scrolling. Tommaso

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Picasa plugin
  • Shockwave Flash 20.0 r0
  • 5.1.40728.0
  • VLC media player Web Plugin
  • NPWLPG

應用程式

  • Firefox 43.0
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/43.0/WINNT/en-US/

擴充套件

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0126
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: D [ Gamma: 3600 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200 ] D [ Gamma: 3600 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ]
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedMismatchedVersion']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 9-26-2011
  • driverDate2:
  • driverVersion: 8.862.4.2000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedMismatchedVersion']
  • numTotalWindows: 1
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webglRendererMessage: [u'blockedMismatchedVersion']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
FredMcD
  • Top 10 Contributor
4274 個解決方法 59937 個答案

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?


Type about:preferences#advanced<enter> in the address bar. Check the Scroll settings.

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. Is the problem still there? ---------- Type '''about:preferences#advanced'''<enter> in the address bar. Check the '''Scroll''' settings.

提出問題者

Hi FredMcD,

Merry Christmas and thanks for answering. In my original help request I wrote: "FF in safemode: very slight improvement (but maybe this was only my wishful perception)"

Yes. The problems is still there.

Hi FredMcD, Merry Christmas and thanks for answering. In my original help request I wrote: "FF in safemode: very slight improvement (but maybe this was only my wishful perception)" Yes. The problems is still there.
FredMcD
  • Top 10 Contributor
4274 個解決方法 59937 個答案

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''
cor-el
  • Top 10 Contributor
  • Moderator
17589 個解決方法 159130 個答案

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

提出問題者

FredMcD said

Try Safe web sites. Is the problem still there?

If eBay, Rakuten and similar websites are considered not safe then I cannot use FF.

-(

I need tech support to help me browse those websites, but without experiencing jerkyness and unresponsiveness.

FF becomes unresponsive when I open more than 6 or 7 tabs. This does not happen with IE.

Pls, can you help me fix this problem. It really makes the browser not usable. I don't want to switch to IE but I will have to if I cannot fix this problem.

''FredMcD [[#answer-822719|said]]'' <blockquote>Try '''Safe''' web sites. Is the problem still there?</blockquote> If eBay, Rakuten and similar websites are considered not safe then I cannot use FF. :-( I need tech support to help me browse those websites, but without experiencing jerkyness and unresponsiveness. FF becomes unresponsive when I open more than 6 or 7 tabs. This does not happen with IE. Pls, can you help me fix this problem. It really makes the browser not usable. I don't want to switch to IE but I will have to if I cannot fix this problem.
FredMcD
  • Top 10 Contributor
4274 個解決方法 59937 個答案

ascanio1 said

If eBay, Rakuten and similar websites are considered not safe then I cannot use FF.

I did not say these were not safe. They are secured sites, yes?

''ascanio1 [[#answer-823820|said]]'' <blockquote> If eBay, Rakuten and similar websites are considered not safe then I cannot use FF. </blockquote> I did not say these were not safe. They are secured sites, yes?

提出問題者

I have always used eBay and Rakuten, they are not porn, they are online sell/buy websites. I guess that they are secure... I don't know what you mean by secured.

I have always used eBay and Rakuten, they are not porn, they are online sell/buy websites. I guess that they are secure... I don't know what you mean by secured.
FredMcD
  • Top 10 Contributor
4274 個解決方法 59937 個答案

After the site is loaded, look at the right side of the address bar. Do you see a padlock? That means the site / connection is secure.

After the site is loaded, look at the right side of the address bar. Do you see a padlock? That means the site / connection is secure.

提出問題者

I checked and they have the little padlock so, yes, they are secured sites. But I thought that eBay was famous... anyway, I tested with IE, and IE works fine. The problem is that I want to stay with FF as I hate MS... I will test Chrome tomorrow but if you have solutions to fix FF I would prefer to stay with FF...

I checked and they have the little padlock so, yes, they are secured sites. But I thought that eBay was famous... anyway, I tested with IE, and IE works fine. The problem is that I want to stay with FF as I hate MS... I will test Chrome tomorrow but if you have solutions to fix FF I would prefer to stay with FF...
FredMcD
  • Top 10 Contributor
4274 個解決方法 59937 個答案

Do you have nvidia's network access manager or forceware network manager software installed? Disable / remove it. https://support.mozilla.org/en-US/kb/connectivity-crashing-firefox-43-update

Do you have nvidia's network access manager or forceware network manager software installed? Disable / remove it. https://support.mozilla.org/en-US/kb/connectivity-crashing-firefox-43-update

提出問題者

No, I can't see that Nvidia programme.

No, I can't see that Nvidia programme.

提出問題者

Hello,

I am still hoping and waiting for someone to help me or follow up to these messages.

My problem is not resolved. Please read all the thread, carefully, as I tried many solutions...

The only VERY SMALL improvement was creating a new profile but still remains jerky and unresponsive when pages like Amazon, eBay and other that display lots of images are opened in numerous tabs.

PLEASE HELP! I don't want to dis-install Firefox and revert to IE !!!

Hello, I am still hoping and waiting for someone to help me or follow up to these messages. My problem is not resolved. Please read all the thread, carefully, as I tried many solutions... The only VERY SMALL improvement was creating a new profile but still remains jerky and unresponsive when pages like Amazon, eBay and other that display lots of images are opened in numerous tabs. PLEASE HELP! I don't want to dis-install Firefox and revert to IE !!!
FredMcD
  • Top 10 Contributor
4274 個解決方法 59937 個答案

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Restart Firefox. Is there any problems?

Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Restart Firefox. Is there any problems?

提出問題者

FredMcD,

Thanks for your time and for suggesting the hardware acceleration. Unfortunately no improvement.

Please, can you suggest any other solution not already listed here? I'm desperate to solve this problem or I'll have to leave FF...

Tommaso

FredMcD, Thanks for your time and for suggesting the hardware acceleration. Unfortunately no improvement. Please, can you suggest any other solution not already listed here? I'm desperate to solve this problem or I'll have to leave FF... Tommaso
cor-el
  • Top 10 Contributor
  • Moderator
17589 個解決方法 159130 個答案

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that has effect.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that has effect. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10
Riksoft 0 個解決方法 13 個答案

Same problem and here a solution: https://support.mozilla.org/en-US/questions/1112023

Same problem and here a solution: https://support.mozilla.org/en-US/questions/1112023

提出問題者

@ Riksoft, I tried all those before asking this question.

@ cor-el I don't experience jerkiness and unresponsiveness with the same websites (eBay, Amazon) when I use Chrome and IE work, so it's not Windows.

I'm really frustrated and baffled why FF won't scroll smoothly when I open many tabs!

@ Riksoft, I tried all those before asking this question. @ cor-el I don't experience jerkiness and unresponsiveness with the same websites (eBay, Amazon) when I use Chrome and IE work, so it's not Windows. I'm really frustrated and baffled why FF won't scroll smoothly when I open many tabs!
Krow 0 個解決方法 9 個答案

@ascanio1: Do you use smooth scrolling? If yes, read on -

Important!

  1. The "solution_2" might work but also might not. Since it depends on the type of hardware you have. And even if it works, in my experience it is still a bit laggy. So I suggest you use the first option.
  2. Also Firefox will be issuing a fix for the lagging scroll in v46, see here.

So again, you can just disable the smooth scroll (solution_1) for now and enable it after the release of version 46 (released in April).


SOLUTION 1 Disable smooth scrolling -

  • Preferences -> Advanced -> Use smooth scrolling (uncheck the check-box).
  • You can also enable Use hardware acceleration when available now (as this has no effect on normal scroll).

SOLUTION 2 If you like smooth scrolling and dont want to disable it, first check if your Firefox windows are accelerated -

  • press <Alt>,
  • choose from the menu: Help -> Troubleshooting Information. Find the following - GPU Accelerated Windows (see attached image).

The "GPU Accelerated Windows" will show either "0/1 ****" or "1/1 ****". The first one means that acceleration is disabled. You have to update your GPU drivers to the latest version to enable this.

  • Use this guide to do so.
  • Then enable Use hardware acceleration when available option if you disabled it (restart the browser after this).
  • Check again the "GPU Accelerated Windows". It should now show "1/1 ****"

Hope this helps! If you run into trouble dont hesitate to ask.

@ascanio1: Do you use smooth scrolling? If yes, read on - '''Important!''' # The "solution_2" might work but also might not. Since it depends on the type of hardware you have. And even if it works, in my experience it is still a bit laggy. '''So I suggest you use the first option.''' # Also Firefox will be issuing a fix for the lagging scroll in v46, [https://hacks.mozilla.org/2016/02/smoother-scrolling-in-firefox-46-with-apz/ see here]. So again, you can just disable the smooth scroll (solution_1) for now and enable it after the release of version 46 (released in April). '''SOLUTION 1''' Disable smooth scrolling - *''' Preferences -> Advanced -> Use smooth scrolling''' (uncheck the check-box). * You can also enable '''Use hardware acceleration when available''' now (as this has no effect on normal scroll). '''SOLUTION 2''' If you like smooth scrolling and dont want to disable it, first check if your Firefox windows are accelerated - * press '''<Alt>''', * choose from the menu: '''Help -> Troubleshooting Information'''. Find the following - '''GPU Accelerated Windows''' (see attached image). The "'''GPU Accelerated Windows'''" will show either "'''0/1 ****'''" or "'''1/1 ****'''". The first one means that acceleration is disabled. You have to update your GPU drivers to the latest version to enable this. * Use [https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration#w_search-for-and-install-new-graphics-drivers this guide] to do so. * Then enable '''Use hardware acceleration when available''' option if you disabled it (restart the browser after this). * Check again the "'''GPU Accelerated Windows'''". It should now show "'''1/1 ****'''" Hope this helps! If you run into trouble dont hesitate to ask.

由 Krow 於 修改

Riksoft 0 個解決方法 13 個答案

About " GPU Accelerated Windows" On the same PC V39 was perfect while v40+ is like a dead. From V46a it starts to work properly again. https://support.mozilla.org/en-US/questions/1112023 So the problem it's not a matter of drivers but a software problem.

There is a sort of basic wrong thinking here...

Scenario: I'm happy with hardware X with linux Y and Firefox in a company with 100 PCs. The day after Firefox upgrade itself from v39 to 40 and starts working like a tired snail. Should I change 100 PCs because of a bunch of of wrong line of code in Firefox? In such scenario I prefer to change browser than 100 PCs.

That's why a product should always take care of pre-existing situations.

About " GPU Accelerated Windows" On the same PC V39 was perfect while v40+ is like a dead. From V46a it starts to work properly again. https://support.mozilla.org/en-US/questions/1112023 So the problem it's not a matter of drivers but a software problem. There is a sort of basic wrong thinking here... Scenario: I'm happy with hardware X with linux Y and Firefox in a company with 100 PCs. The day after Firefox upgrade itself from v39 to 40 and starts working like a tired snail. Should I change 100 PCs because of a bunch of of wrong line of code in Firefox? In such scenario I prefer to change browser than 100 PCs. That's why a product should always take care of pre-existing situations.
Krow 0 個解決方法 9 個答案

Riksoft said

About " GPU Accelerated Windows" On the same PC V39 was perfect while v40+ is like a dead. From V46a it starts to work properly again. https://support.mozilla.org/en-US/questions/1112023 So the problem it's not a matter of drivers but a software problem.

Actually it works well on an Intell GPU with occasional lagging.

But on my AMD machine, not so much. The only reason I didnt notice it so much is because I wasnt using smooth scroll.

Also, if the "GPU Accelerated Windows" is disabled, you can force enable it - about:config -> layers.acceleration.force-enabled But this option might make things worse and even crash the browser. Or might actually help.

''Riksoft [[#answer-854301|said]]'' <blockquote> About " GPU Accelerated Windows" On the same PC V39 was perfect while v40+ is like a dead. From V46a it starts to work properly again. https://support.mozilla.org/en-US/questions/1112023 So the problem it's not a matter of drivers but a software problem. </blockquote> Actually it works well on an Intell GPU with occasional lagging. But on my AMD machine, not so much. The only reason I didnt notice it so much is because I wasnt using smooth scroll. Also, if the "GPU Accelerated Windows" is disabled, you can force enable it - about:config -> layers.acceleration.force-enabled But this option might make things worse and even crash the browser. Or might actually help.

由 Krow 於 修改