X
點擊此處開啟此網站的行動版。

技術支援討論區

When Shockwave Flash is enabled it causes flash videos to lag

已張貼

I just got a new laptop (Acer) with Windows 10. In Firefox 42.0, all youtube videos play fine (because of HTML5, I assume), but Flash videos lag. I set Shockwave Flash in the plugin list to 'Never Activate' and that fixes the lagging. But now some videos on other sites don't show up at all because they need Shockwave Flash (they also lagged before, for your information).

What do you think the problem is? I obviously want to have it enabled all the time, but without all that lagging.

I just got a new laptop (Acer) with Windows 10. In Firefox 42.0, all youtube videos play fine (because of HTML5, I assume), but Flash videos lag. I set Shockwave Flash in the plugin list to 'Never Activate' and that fixes the lagging. But now some videos on other sites don't show up at all because they need Shockwave Flash (they also lagged before, for your information). What do you think the problem is? I obviously want to have it enabled all the time, but without all that lagging.

被選擇的解決方法

I've found the problem. It was the Acer's crappy CPU. When playing Youtube videos Firefox took the CPU to 95% most of the time, and with Flash it was even worse because of Firefox and Flash player running at the same time.

So my problem should be fixed by buying a better laptop. That's what I get for assuming every laptop these days can run Youtube videos.

Thanks for the help, and I hope that what I found helps other people too who have this problem.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Google Update
  • 5.1.41105.0

應用程式

  • Firefox 42.0
  • 使用者代理:Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/42.0/WINNT/en-US/

擴充套件

  • Adblock Plus 2.6.13 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Gif Delayer 0.7.1-signed (jid1-mqCpKcAruymyAA@jetpack)
  • NoScript 2.7 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Status-4-Evar 2015.11.16.23.1-signed.1-let-fixed (status4evar@caligonstudios.com)
  • Tabs on Bottom 0.5.1-signed (tabsonbottom@piro.sakura.ne.jp)
  • Amazon 1Button App for Firefox 5.38 (abb@amazon.com) (Inactive)
  • AVG Web TuneUp 4.2.2.128 (avg@toolbar) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: AMD Radeon HD 8240
  • adapterDescription2:
  • adapterDeviceID: 0x9838
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterSubsysID: 104b1025
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 8-6-2015
  • driverDate2:
  • driverVersion: 15.201.1101.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 8240 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
FredMcD
  • Top 10 Contributor
4341 個解決方法 61038 個答案

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

有幫助的回覆

I just updated my drivers to the latest ones, tried disabling protected mode and tried disabling hardware acceleration. Nothing worked. The problem still persists.

I just updated my drivers to the latest ones, tried disabling protected mode and tried disabling hardware acceleration. Nothing worked. The problem still persists.
FredMcD
  • Top 10 Contributor
4341 個解決方法 61038 個答案
https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues?redirectlocale=en-US&redirectslug=Video+or+audio+does+not+play https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

提出問題者

And I just found out that youtube videos are only fine up to 480p. Any higher and they start lagging too.

And any quality fullscreen lags too.

And I just found out that youtube videos are only fine up to 480p. Any higher and they start lagging too. And any quality fullscreen lags too.
FredMcD
  • Top 10 Contributor
4341 個解決方法 61038 個答案

Perhaps this is a web site issue.

Perhaps this is a web site issue.

有幫助的回覆

Do you think so? I thought it was pretty funny when I tested other browsers. Firefox played youtube fine and flash laggy, Chrome had great flash and laggy youtube and Edge had no problem with either.

I'm really not looking forward to Edge being my choice, hehe.

I'm gonna try some more of those links you posted last. Maybe I'll find the problem there.

Do you think so? I thought it was pretty funny when I tested other browsers. Firefox played youtube fine and flash laggy, Chrome had great flash and laggy youtube and Edge had no problem with either. I'm really not looking forward to Edge being my choice, hehe. I'm gonna try some more of those links you posted last. Maybe I'll find the problem there.

選擇的解決方法

I've found the problem. It was the Acer's crappy CPU. When playing Youtube videos Firefox took the CPU to 95% most of the time, and with Flash it was even worse because of Firefox and Flash player running at the same time.

So my problem should be fixed by buying a better laptop. That's what I get for assuming every laptop these days can run Youtube videos.

Thanks for the help, and I hope that what I found helps other people too who have this problem.

I've found the problem. It was the Acer's crappy CPU. When playing Youtube videos Firefox took the CPU to 95% most of the time, and with Flash it was even worse because of Firefox and Flash player running at the same time. So my problem should be fixed by buying a better laptop. That's what I get for assuming every laptop these days can run Youtube videos. Thanks for the help, and I hope that what I found helps other people too who have this problem.
FredMcD
  • Top 10 Contributor
4341 個解決方法 61038 個答案

That was very good work. Well Done.

That was very good work. Well Done.