X
點擊此處開啟此網站的行動版。

技術支援討論區

no sound on facebook videos

已張貼

Hi I've suddenly got no sound when playing facebook videos. It's OK on Chrome. I've updated plug-ins; downloaded Youtube Flash video player. Can't think what else to do. Help!!

Hi I've suddenly got no sound when playing facebook videos. It's OK on Chrome. I've updated plug-ins; downloaded Youtube Flash video player. Can't think what else to do. Help!!

被選擇的解決方法

Well, if I was stumped this morning, I'm even more so now, because all the videos which I heard no sound on have now started working!!

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • Citrix Online App Detector Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Motive Management Plug-in for Mozilla Browsers
  • Motive Plug-in for Mozilla Browsers
  • Picasa plugin
  • Shockwave Flash 19.0 r0
  • 5.1.40728.0
  • iTunes Detector Plug-in

應用程式

  • Firefox 42.0
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; rv:42.0) Gecko/20100101 Firefox/42.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/42.0/WINNT/en-US/

擴充套件

  • Facebook Phishing Protector 4.4.3.1-signed ({023e9ca0-63f3-47b1-bcb2-9badf9d9ef28})
  • YouTube Flash Video Player 42.2 ({f3bd3dd2-2888-44c5-91a2-2caeb33fb898})
  • Motive Extension 1.0 (mcciwbch@motive.com) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: NVIDIA GeForce 6150 LE
  • adapterDescription2:
  • adapterDeviceID: 0x0241
  • adapterDeviceID2:
  • adapterDrivers: nvd3dum
  • adapterDrivers2:
  • adapterRAM: 64
  • adapterRAM2:
  • adapterSubsysID: 01f41028
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 9.18.13.783
  • driverVersion2:
  • failures: [u'[GFX1]: D3D11 device creation failed: 0x887a0004']
  • indices: [0]
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 6150 LE Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
alex_mayorga
  • Top 25 Contributor
  • Moderator
369 個解決方法 2887 個答案

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

提出問題者

Thanks for your suggestion. Sorry, I should have said. I tried Safe Mode; the problem was the same, and I also refreshed Firefox. Since then, though, I've found that some videos play so am wondering if it's some kind of facebook/Firefox linked issue with some of the video clips.

Thanks for your suggestion. Sorry, I should have said. I tried Safe Mode; the problem was the same, and I also refreshed Firefox. Since then, though, I've found that some videos play so am wondering if it's some kind of facebook/Firefox linked issue with some of the video clips.
alex_mayorga
  • Top 25 Contributor
  • Moderator
369 個解決方法 2887 個答案

Please report the videos with problems at https://facebook.com/help

Please report the videos with problems at https://facebook.com/help

提出問題者

Thank you. I have done.

Thank you. I have done.
bastinazus 1 個解決方法 11 個答案

I have exactly the same problem. Some facebook videos have sound, others not (the majority). It's kinda annoying, and I have tried everything. As you said, no problems on Chrome.

I have exactly the same problem. Some facebook videos have sound, others not (the majority). It's kinda annoying, and I have tried everything. As you said, no problems on Chrome.

提出問題者

I'm glad I'm not the only one so to that extent your reply is reassuring. I'm at a loss now. I so prefer Firefox to Chrome but it's so aggravating, isn't it, when you go to play something and it's like a silent movie? I'll press on with trying to find a solution

I'm glad I'm not the only one so to that extent your reply is reassuring. I'm at a loss now. I so prefer Firefox to Chrome but it's so aggravating, isn't it, when you go to play something and it's like a silent movie? I'll press on with trying to find a solution
mohitagarwal 1 個解決方法 13 個答案

try reinstalling firefox with latest version and use adobe flash player as plug in

try reinstalling firefox with latest version and use adobe flash player as plug in

提出問題者

Thanks for all suggestions. I'm now stumped. I've uninstalled and reinstalled Flash player. I've uninstalled and reinstalled Firefox. I've followed most of the steps in a 10 point guide; clearing all caches and temp files in case there was a corruption. It seems to be a very random problem; some clips playing and others not from the same person, for instance.

Thanks for all suggestions. I'm now stumped. I've uninstalled and reinstalled Flash player. I've uninstalled and reinstalled Firefox. I've followed most of the steps in a 10 point guide; clearing all caches and temp files in case there was a corruption. It seems to be a very random problem; some clips playing and others not from the same person, for instance.
werty20 2 個解決方法 37 個答案

i have the same problem , safe mode , new profile , hardware acc on , of

i have the same problem , safe mode , new profile , hardware acc on , of
alex_mayorga
  • Top 25 Contributor
  • Moderator
369 個解決方法 2887 個答案

¡Hola!

Do things improve if you fully remove Adobe Flash as detailed at http://occupyflash.org/#resources ?

Please leave it uninstalled for a while and report back if videos work.

¡Gracias!

¡Hola! Do things improve if you fully remove Adobe Flash as detailed at http://occupyflash.org/#resources ? Please leave it uninstalled for a while and report back if videos work. ¡Gracias!

由 alex_mayorga 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17517 個解決方法 158408 個答案

What media player is used? Is a Shockwave Flash based player used or the HTML5 media player?

You can check this via the right-click context menu of the player area. A Flash based player shows a context menu with the Flash version.

What media player is used? Is a Shockwave Flash based player used or the HTML5 media player? You can check this via the right-click context menu of the player area. A Flash based player shows a context menu with the Flash version.
bastinazus 1 個解決方法 11 個答案

alex_mayorga said

¡Hola! Do things improve if you fully remove Adobe Flash as detailed at http://occupyflash.org/#resources ? Please leave it uninstalled for a while and report back if videos work. ¡Gracias!

I have done it, and the issue is still here. No sound on facebook videos (although some videos plays sound, it's weird). And of course, as I have said, Chrome has no problems.

''alex_mayorga [[#answer-815670|said]]'' <blockquote> ¡Hola! Do things improve if you fully remove Adobe Flash as detailed at http://occupyflash.org/#resources ? Please leave it uninstalled for a while and report back if videos work. ¡Gracias! </blockquote> I have done it, and the issue is still here. No sound on facebook videos (although some videos plays sound, it's weird). And of course, as I have said, Chrome has no problems.
alex_mayorga
  • Top 25 Contributor
  • Moderator
369 個解決方法 2887 個答案

Could you please tag https://www.facebook.com/alex.mayorga in one of the problematic videos?

Could you please tag https://www.facebook.com/alex.mayorga in one of the problematic videos?
werty20 2 個解決方法 37 個答案

done , send pm to u

done , send pm to u

提出問題者

Bastinazus: I tried that; still not working properly.

Cor-el: It was Flash Video Player. When trying to suss all this out I realised that there was the option to change to HTML5 so I tried that. Then I got the Youtube Video Player add-on to see if that would make a difference. None of them did

Bastinazus: I tried that; still not working properly. Cor-el: It was Flash Video Player. When trying to suss all this out I realised that there was the option to change to HTML5 so I tried that. Then I got the Youtube Video Player add-on to see if that would make a difference. None of them did
bastinazus 1 個解決方法 11 個答案

I think it's Firefox-side problem. How can we report this bug to Firefox?

I think it's Firefox-side problem. How can we report this bug to Firefox?

提出問題者

I've just reported it on 'Submit Feedback' from the Help drop down list. There was a Video survey which popped up when I submitted it so I completed that as well.

I've just reported it on 'Submit Feedback' from the Help drop down list. There was a Video survey which popped up when I submitted it so I completed that as well.
cor-el
  • Top 10 Contributor
  • Moderator
17517 個解決方法 158408 個答案

Try to clear the Flash local storage and settings.

  • Windows Control Panel > Flash Player > Storage: Local Storage Settings
    • Remove a specific domain: Local Storage Settings by site
    • Remove all domains: Delete All and Delete Data

Flash Website Storage Settings panel:

Global Storage Settings Panel:

Flash Local storage settings Help:


Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Try to clear the Flash local storage and settings. *Windows Control Panel > Flash Player > Storage: Local Storage Settings **Remove a specific domain: Local Storage Settings by site **Remove all domains: Delete All and Delete Data Flash Website Storage Settings panel: *http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager07.html Global Storage Settings Panel: *http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager03.html Flash Local storage settings Help: *http://www.macromedia.com/support/documentation/en/flashplayer/help/help02.html ----- Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
werty20 2 個解決方法 37 個答案

all done , even new profile , uninstall flash https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

same problem , some video play with sound , other dont also i don't have flash right now so i think facebook switch to html5 player

all done , even new profile , uninstall flash https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html same problem , some video play with sound , other dont also i don't have flash right now so i think facebook switch to html5 player
bastinazus 1 個解決方法 11 個答案

As I have said, i'm pretty sure this is a Firefox-side issue. It has nothing to do with the user.

As I have said, i'm pretty sure this is a Firefox-side issue. It has nothing to do with the user.