X
點擊此處開啟此網站的行動版。

技術支援討論區

How can I get the "remember password" window to show for more than 2s?

已張貼

Many hotels offer wifi access with a voucher and an ID that you need to enter every time you connect. Firefox easily remembers the ID and password so I don't have to bother finding the voucher but the hotel portal displays a pop-up right after the connection. At the same time Firefox offers to save the password and the popup makes the remember password prompt disappear. Can I can this setting somewhere or get the prompt back? I am never quick enough to click"remember password". Thank you Chris

Many hotels offer wifi access with a voucher and an ID that you need to enter every time you connect. Firefox easily remembers the ID and password so I don't have to bother finding the voucher but the hotel portal displays a pop-up right after the connection. At the same time Firefox offers to save the password and the popup makes the remember password prompt disappear. Can I can this setting somewhere or get the prompt back? I am never quick enough to click"remember password". Thank you Chris

被選擇的解決方法

Does this occur on all websites or just this one?

If there is a key icon located on the left side of your address bar, you can click this to open the password prompt again.

If there is no key icon in the address bar, it is most likely because the website is setup to redirect to a different page or domain. Once you are redirected or navigate to a different page, the password dialog will disappear.

Unfortunately, if this is the case, there is nothing that you can do, as the redirection is probably in the website's codes. The only option would be to try and stop the website from redirecting by clicking the stop button in the address bar.

You could also try temporarily enabling the accessibility setting that prevents Firefox from redirecting websites. This can be changed from the Advanced settings in the options page, under the general tab.

Let us know if this works.

Note: If you stop the page from redirecting, you will most likely have to reload the page after saving the password, to allow the website to load the proper content. If you turn on the warn me when redirecting setting, you will have to disable that feature after you save that password, in order for the website to function properly.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Citrix Access Gateway
  • Citrix Receiver Plugin (Win32)
  • Citrix URL-Redirection Helper Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Microsoft Lync Web App Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • Shockwave Flash 11.8 r800
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • 5.1.40728.0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

更多資訊

Wesley Branton
  • Top 10 Contributor
617 個解決方法 5141 個答案

選擇的解決方法

Does this occur on all websites or just this one?

If there is a key icon located on the left side of your address bar, you can click this to open the password prompt again.

If there is no key icon in the address bar, it is most likely because the website is setup to redirect to a different page or domain. Once you are redirected or navigate to a different page, the password dialog will disappear.

Unfortunately, if this is the case, there is nothing that you can do, as the redirection is probably in the website's codes. The only option would be to try and stop the website from redirecting by clicking the stop button in the address bar.

You could also try temporarily enabling the accessibility setting that prevents Firefox from redirecting websites. This can be changed from the Advanced settings in the options page, under the general tab.

Let us know if this works.

Note: If you stop the page from redirecting, you will most likely have to reload the page after saving the password, to allow the website to load the proper content. If you turn on the warn me when redirecting setting, you will have to disable that feature after you save that password, in order for the website to function properly.

Does this occur on all websites or just this one? If there is a key icon located on the left side of your address bar, you can click this to open the password prompt again. If there is no key icon in the address bar, it is most likely because the website is setup to redirect to a different page or domain. Once you are redirected or navigate to a different page, the password dialog will disappear. Unfortunately, if this is the case, there is nothing that you can do, as the redirection is probably in the website's codes. The only option would be to try and stop the website from redirecting by clicking the stop button in the address bar. You could also try temporarily enabling the accessibility setting that prevents Firefox from redirecting websites. This can be changed from the Advanced settings in the options page, under the general tab. Let us know if this works. '''Note: '''If you stop the page from redirecting, you will most likely have to reload the page after saving the password, to allow the website to load the proper content. If you turn on the warn me when redirecting setting, you will have to disable that feature after you save that password, in order for the website to function properly.

提出問題者

Hi Wesley, the option of preventing redirecting websites works just fine! Many thanks. This is closed from my perspective. I hope this will help other users.

Hi Wesley, the option of preventing redirecting websites works just fine! Many thanks. This is closed from my perspective. I hope this will help other users.
cor-el
  • Top 10 Contributor
  • Moderator
17528 個解決方法 158481 個答案
See also: *Saved Password Editor: https://addons.mozilla.org/firefox/addon/saved-password-editor/