搜尋 Mozilla 技術支援網站

小心釣魚網站: Mozilla 絕對不會要求您來電,或造訪不是 Mozilla 的網站,請忽略這類請求。

Learn More

website images suddenly disappear

  • 20 回覆
  • 1 有這個問題
  • 59 次檢視
  • 最近回覆由 cor-el

more options

Suddenly my images on all websites disappeared. I had backed up my settings with MozBackup 1.5.1 . The first time I restored with the latest backup file the problem came back immediately with images gone. I went to another backup created a few days prior and the problem went away temporarily. As I was surfing the images disappeared again. I have restored again and the images are back. My tech people at HP SmartFriends suggested I post the question to Mozilla support...

所有回覆 (20)

more options

If images are missing then check that you do not block images.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1. You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can tap the Alt key or press F10 to show the Menu Bar Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"

Check "Tools > Page Info > Media" for blocked images

  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain.

Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings. Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

This setting affects background images.

See also:


There are extensions like Adblock Plus (Firefox menu button/Tools > Add-ons > Extensions) and Anti-Virus software that can block images and other content.

See also:

more options

I had my tech people check all of what you said and the problem still is there. They believe there is a compatibility issue with Windows 10 since the profile I saved with MozBackup 1.5.1 was created prior to my update to 10. Can you check the PCV files to see where the compatibility problem is? We would need to know which saved add on or setting is causing the image problem... Again, the problem goes away temporarily when I do a profile restore but the images disappear soon afterwards...

more options

MozBackup is a 3rd party program - it isn't made by Mozilla. http://mozbackup.jasnapaka.com/support.php

more options

I don't think the problem is with MozBackup since it just saves the settings as they are. It just looks like there is something in the settings that is incompatible with Windows 10 in Firefox that causes the images to disappear. I think it is in some add on or extension but I don't know which one(s) could cause the problem. My tech people said that someone who is knowledgeable with Firefox could determine which part of Firefox is incompatible with Windows 10 to cause the disappearance of the images...

more options

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

Delete the permissions.sqlite file to reset all permissions.

You can use this button to go to the current Firefox profile folder:

more options

My HP tech said the last entry you made was not applicable in my problem and then proceeded to make adjustments to the add ons with Java and Flash fixes. The problem went away for awhile but returned after I ran some YouTube videos. He felt the problem is Windows 10 compatibility related... I never had this problem with Windows 7 home premium.

more options

Don't you see any images at all on a web page and also not in "Tools > Page Info > Media" ?

There is no reason that images are blocked under normal conditions like default Firefox settings and no content blocking extensions.

Also make sure that you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; never remember history). To see all History and Cookie settings, choose:

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"

Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

This setting affects background images.

See also:

more options

I have no content blocking extensions except AdBlock. No color problems. Just no images. I have added screen shots for you to see my settings.

more options

Here are all my extensions from current screen shots.

more options

Anything unusual in the Network Monitor?

You can check the log in the Web Console for error messages and the Network Monitor (Firefox/Tools > Web Developer) to see if content fails to load or is possibly blocked.

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

more options

Nothing unusual and nothing is blocking. Flash and Java have been updated as well. HP SmartFriends has concluded that Mozilla and Microsoft need to update their systems to make Firefox and Windows 10 more compatible.

more options

Are there images like .png and .jpg files requested and do they arrive if you check this in the Network Monitor?

more options

Right now the images are working... Here is the screen shot of what I am seeing in the Network Monitor.

more options

Images are gone by themselves again. Here are the current network screen shots...

more options

Can you load such a blocked image via the location/address bar if you copy and paste the URL?

more options

How do you load a blocked image to the location/address bar? When I click on the blocked image I get sent to the site that is linked to the gone image.

more options

You can select the image URL as you see in the first screenshot you posted above and paste it in the location/address bar.

more options

This is one of the images I put into the address bar.

more options

I just updated to 43 and the problem is still there. NO images show up on websites...

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

Try to rename (or delete) the permissions.sqlite and content-prefs.sqlite files in the Firefox profile folder once again.

You can use this button to go to the current Firefox profile folder: