搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Why is it when I right click on Firefox icon I get a purple flag with "New Private Window"? Is there no way to delete this?

  • 4 回覆
  • 1 有這個問題
  • 14 次檢視
  • 最近回覆由 anonymous

more options

Am I a prisoner of "New Private Window"? Is it OK if I don't want it? Will God punish me? It certainly looks that way.

I've had Win 10 for 4 months and until yesterday, 11/10, I never even knew about "New Private Window" and the purple flag that now appears when I right-click the Firefox icon. Someone tried to help by suggesting new Privacy settings. As a result I lost most of my desktop shortcuts but not the Private Window! I got most of the shortcuts back but I'm still stuck with the purple flag business. I don't have a tech background, and just for that reason I try to keep it all simple. If it's that vital, how did I manage before? Any help or clarification will be appreciated. Thanks for listening.

被選擇的解決方法

The image used for Private Browsing from the Task Bar was changed for Firefox 42. Previously the image wasn't colored purple, more like a lighter blue color.

從原來的回覆中察看解決方案 👍 1

所有回覆 (4)

more options

Hi, if you mean when you right click on the Firefox Taskbar icon, under Tasks, you see the purple 'New private window' option - that is normal, and if you don't want to use it, you can just ignore it. Firefox should open by left clicking in the usual way.

If you are getting a private window option when you right click the Firefox Desktop icon, you may have a corrupt shortcut icon. So in the Start Menu, right click on Mozilla Firefox in All Programs/Apps > Send to > Desktop (create shortcut). You should now have a clean shortcut on your Desktop. if it's OK, you can now right click on the old Desktop icon > Delete.

More about Private Browsing - Private Browsing - Use Firefox without saving history.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options

Thanks for your reply. I'll try to ignore the purple flag as you suggested. Why I questioned it is that I never saw it until a few days ago, no matter how many times I might've right-clicked the taskbar icon in the past. Is it part of a recent update where they just added an easy way to access a new private window?

I'm always puzzled when it's a change I myself didn't make. In this case it's also because I don't fully understand the functions of Private Browsing, so I've consistently avoided it. Perhaps I misunderstood that in order to use Private Browsing, I lose my "Don't remember history" ability, which is a must. I'll appreciate anything you can add. Thanks again.

more options

選擇的解決方法

The image used for Private Browsing from the Task Bar was changed for Firefox 42. Previously the image wasn't colored purple, more like a lighter blue color.

more options

Thanks. I probably never noticed it before the color change.