搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to install firefox in windows 7 after getting "this publisher has been blocked" warning.

  • 7 回覆
  • 1 有這個問題
  • 505 次檢視
  • 最近回覆由 FredMcD

more options

Here's the back story in case it helps... I upgraded windows 7 to windows 10, had many performance issues with windows 10 and reinstalled windows 7. After the reinstall, I tried to download mozilla firefox again and install the browser. When I try to run the setup file for firefox I get a message that reads: "This publisher has been blocked from running software on your machine." The only option is to click "OK". There is no way to ignore the security warning and proceed with the install. I have had no trouble installing any other software (IE and Chrome included). I have tried starting windows in safe mode, but I still get the same warning. I do have administrator privileges while running the setup. I have found other forums addressing similar issues, but have not found a solution for my specific case yet. I have attached a screen capture of the security warning window so you can see there is no way to proceed. If I click the windows help link, it goes nowhere.

被選擇的解決方法

Well, I had an "ah-ha" moment and the fix was extremely simple. Not sure why it eluded me this long, but you can right-click the installer file, select "properties" and under the "General" tab there is a button to "unblock" the file. Still, after this step I was not able to run the installer. For some unknown reason my administrator role is all messed up, but that's a different issue. To bypass the blocked publisher warnings after unblocking the program, you must run the installer from the command prompt with administrator privileges. Goto START --> All Programs --> Accessories ... right-click "Command Prompt" and click "Run as administrator", click "Yes" if you get any User Account Control warnings to run the program. Once the command prompt opens up in a new window cd into the directory containing your fireforx installer file and run it. This fixed my issue.

從原來的回覆中察看解決方案 👍 0

所有回覆 (7)

more options

Did you get the full installer from http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems


In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Both the stub and full installer give me the same security warning. I have attached a screen capture.

more options

Have you checked the "unblock" link on the bottom?

more options

Yes, it opens windows help to display that there is no help on this topic. lol!

more options

I've called the big guys to help you. Good luck.

more options

選擇的解決方法

Well, I had an "ah-ha" moment and the fix was extremely simple. Not sure why it eluded me this long, but you can right-click the installer file, select "properties" and under the "General" tab there is a button to "unblock" the file. Still, after this step I was not able to run the installer. For some unknown reason my administrator role is all messed up, but that's a different issue. To bypass the blocked publisher warnings after unblocking the program, you must run the installer from the command prompt with administrator privileges. Goto START --> All Programs --> Accessories ... right-click "Command Prompt" and click "Run as administrator", click "Yes" if you get any User Account Control warnings to run the program. Once the command prompt opens up in a new window cd into the directory containing your fireforx installer file and run it. This fixed my issue.

more options

That was very good work. Well Done.