搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Cookies are spontaneously blocked and end up in my exceptions list as blocked when visiting some sites.

  • 4 回覆
  • 1 有這個問題
  • 2 次檢視
  • 最近回覆由 LJlj

more options

Maybe this is associated with NoScript? I try to allow scripts on some sites (guardian.com, for instance) and occasionally get nowhere; things won't load. Eventually I think to check in Firefox's Options> Security>cookie Exceptions and find the site listed as blocked. Happens often with many sites, but not every time. Has happened even if I've put a site in the Exceptions as Allow. Is there a way to fix this?

Maybe this is associated with NoScript? I try to allow scripts on some sites (guardian.com, for instance) and occasionally get nowhere; things won't load. Eventually I think to check in Firefox's Options> Security>cookie Exceptions and find the site listed as blocked. Happens often with many sites, but not every time. Has happened even if I've put a site in the Exceptions as Allow. Is there a way to fix this?

所有回覆 (4)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Separate Issue; Your System Details shows;

Installed Plug-ins

Shockwave Flash 19.0 r0 Shockwave Flash 16.0 r0
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Note: Edge on Win10 does not use ActiveX version but its own Flash.

Flash: Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac

Then reinstall the latest version.

Flash Player Version 19.0.0.226
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users should download the ‘’’active_x’’’ for “Internet Explorer,” and the ‘’’plugin’’’ for “Plugin-based browsers” (like Firefox).

Adobe still offers Flash 18.0.0.255 as its extended support release further down

more options

This is mlore likely a problem with other content blocking extensions like BetterPrivacy or Ghostery.

If you use extensions (Firefox menu button/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery, and others) then make sure that such extensions aren't blocking content.

more options

Okay, cleaning up my Flash player didn't help (I know it wasn't expected to). Running Firefox in safe mode kinda confirms that it's associated with NoScript; with scripts running it doesn't happen. Maybe I should be on a NoScript forum?

On the sites support.mozilla.org, and theguardian.com/us there are initially no cookies blocked with NoScript set to "temporarily allow all this page". But if I click on a link and open a daughter tab, the Options>Privacy>Exceptions now shows cookies for that site blocked-- 2 to 5 times. So worse, even. Just logging in on the mozilla site made 5 listings of the cookie block appear, without any NoScript right-clicking.

more options

Also just refreshed this page, and a block was put on cookies from support.mozilla.org, with the NoScript status of temporarily allowing this page being unchanged.