X
點擊此處開啟此網站的行動版。

技術支援討論區

Twitter: Your account may not be allowed to perform this action. Please refresh the page and try again.

已張貼

Since the update to Firefox 41.0.2 I have been unable to use Twitter.com. When I try to tweet, favorite or retweet the following error occurs. Your account may not be allowed to perform this action. Please refresh the page and try again. There are a couple of other users that have the same issue, however one had tinkered with the Mozilla and the other unresolved.

It started with the updated to 41.0.2 and twitter works in all other browsers, just not mozilla.

Since the update to Firefox 41.0.2 I have been unable to use Twitter.com. When I try to tweet, favorite or retweet the following error occurs. Your account may not be allowed to perform this action. Please refresh the page and try again. There are a couple of other users that have the same issue, however one had tinkered with the Mozilla and the other unresolved. It started with the updated to 41.0.2 and twitter works in all other browsers, just not mozilla.

被選擇的解決方法

Here's that other thread with the tinkering: Unable to Retweet, tweet, or favorite items on Twitter, even when I refresh the page.

I think it has to be a setting or add-on issue. Your extensions look pretty standard, so I'm leaning toward a problem setting. You could test that as follows:

By default, Windows hides the .js extension. To ensure that the following steps work, you should turn off that feature, at least temporarily. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename prefs.js to something like prefs.old.

Start Firefox back up again and it should use default settings (e.g., built-in home page). If you need to restore your previous session windows and tabs, go ahead and select Restore Previous Session from the History menu.

Does Twitter work any better? If so, we could try to figure out the specific setting at fault or you could rebuild your settings. Or you could undo the change by renaming the new prefs.js to prefs.txt and renaming prefs.old back to prefs.js (with Firefox closed, as you did previously) and figure it out by a little trial and error.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.65.2 for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • npmnqmp 989898989877
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2
  • 5.1.30514.0
  • Unity Player 3.1.0f3
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

應用程式

  • Firefox 41.0.2
  • 使用者代理:Mozilla/5.0 (Windows NT 5.1; rv:41.0) Gecko/20100101 Firefox/41.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/41.0.2/WINNT/en-US/

擴充套件

  • Adblock Plus 2.6.11 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • NO Google Analytics 0.6.1-signed (jid1-JcGokIiQyjoBAQ@jetpack)
  • Qualys BrowserCheck 1.6.54.1 ({7D2FB79E-E58C-4DB5-A36F-AC1C73967F4D})
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Move Media Player 1.0.0.071303000006 (moveplayer@movenetworks.com) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: NVIDIA GeForce FX 5200
  • adapterDescription2:
  • adapterDeviceID: 0x0322
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 019210de
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'257.21']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 5-16-2008
  • driverDate2:
  • driverVersion: 6.14.11.7519
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'257.21']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRendererMessage: [u'tryNewerDriver', u'257.21']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
jscher2000
  • Top 10 Contributor
8838 個解決方法 72234 個答案

選擇的解決方法

Here's that other thread with the tinkering: Unable to Retweet, tweet, or favorite items on Twitter, even when I refresh the page.

I think it has to be a setting or add-on issue. Your extensions look pretty standard, so I'm leaning toward a problem setting. You could test that as follows:

By default, Windows hides the .js extension. To ensure that the following steps work, you should turn off that feature, at least temporarily. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename prefs.js to something like prefs.old.

Start Firefox back up again and it should use default settings (e.g., built-in home page). If you need to restore your previous session windows and tabs, go ahead and select Restore Previous Session from the History menu.

Does Twitter work any better? If so, we could try to figure out the specific setting at fault or you could rebuild your settings. Or you could undo the change by renaming the new prefs.js to prefs.txt and renaming prefs.old back to prefs.js (with Firefox closed, as you did previously) and figure it out by a little trial and error.

Here's that other thread with the tinkering: [https://support.mozilla.org/questions/1088799 Unable to Retweet, tweet, or favorite items on Twitter, even when I refresh the page.] I think it has to be a setting or add-on issue. Your extensions look pretty standard, so I'm leaning toward a problem setting. You could test that as follows: By default, Windows hides the .js extension. To ensure that the following steps work, you should turn off that feature, at least temporarily. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''prefs.js''' to something like prefs.old. Start Firefox back up again and it should use default settings (e.g., built-in home page). If you need to restore your previous session windows and tabs, go ahead and select Restore Previous Session from the History menu. Does Twitter work any better? If so, we could try to figure out the specific setting at fault or you could rebuild your settings. Or you could undo the change by renaming the ''new'' prefs.js to prefs.txt and renaming prefs.old back to prefs.js (with Firefox closed, as you did previously) and figure it out by a little trial and error.
cor-el
  • Top 10 Contributor
  • Moderator
17690 個解決方法 160049 個答案

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

提出問題者

Thank you both for the quick responses and excellent step by step instructions! Twitter is working properly again. Thank you!!

Thank you both for the quick responses and excellent step by step instructions! Twitter is working properly again. Thank you!!
XYll 0 個解決方法 3 個答案

有幫助的回覆

While the above solutions may (delete user profile, delete pref.js) or may not work (clear cache, remove cookies), this specific issue with twitter and a handful website is caused by the absence of referral information on image request.

Users of Configuration Mania extension or other privacy enhancing extensions may have configured the setting to withhold referral information, which leads to certain websites (e.g. twitter) to malfunction.

Deleting pref.js or the user profile can cause major disruptions to the user experience, effectively resetting the browser from all the custom configurations the user may have done.

A more focused solution is opening about:config and searching for the string network.http.sendRefererHeader this shall be reset to default either by right-clicking -> reset or editing the value to "2" (without quotes).

While the above solutions may (delete user profile, delete pref.js) or may not work (clear cache, remove cookies), this specific issue with twitter and a handful website is caused by the absence of referral information on image request. Users of Configuration Mania extension or other privacy enhancing extensions may have configured the setting to withhold referral information, which leads to certain websites (e.g. twitter) to malfunction. Deleting pref.js or the user profile can cause major disruptions to the user experience, effectively resetting the browser from all the custom configurations the user may have done. A more focused solution is opening '''about:config''' and searching for the string '''network.http.sendRefererHeader''' this shall be reset to default either by right-clicking -> reset or editing the value to "2" (without quotes).