X
點擊此處開啟此網站的行動版。

技術支援討論區

Can't watch youtube after system update

已張貼

Hi,

On my both laptops Im using linux and an exactly same vpn setting to access the free world on one of them Im able to open up youtube without any problem using any browser including FF on the another youtube keeps giving me "An error occurred, Please try agian later"

An error occurred during a connection to r9---sn-o097znel.googlevideo.com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)


I know the problem is with vpn and ssl certificates! I believe the vpn cant handle the new ssl certificates so its going to refuse them but the weird thing is when I replace the "working-youtube" firefox profile (.mozilla folder) to the "non-working-youtube" profile I can agian watch youtube normaly I can replace the profiles and just start using it but I prefer to keep the current settings because everything else works great

things I have done to get my youtube back again

deleting .mozilla folder [not working] replacing cert8.db [not working] replacing prefs.js [not working]

Hi, On my both laptops Im using linux and an exactly same vpn setting to access the free world on one of them Im able to open up youtube without any problem using any browser including FF on the another youtube keeps giving me "An error occurred, Please try agian later" An error occurred during a connection to r9---sn-o097znel.googlevideo.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long) I know the problem is with vpn and ssl certificates! I believe the vpn cant handle the new ssl certificates so its going to refuse them but the weird thing is when I replace the "working-youtube" firefox profile (.mozilla folder) to the "non-working-youtube" profile I can agian watch youtube normaly I can replace the profiles and just start using it but I prefer to keep the current settings because everything else works great things I have done to get my youtube back again deleting .mozilla folder [not working] replacing cert8.db [not working] replacing prefs.js [not working]

由 kotrebareka 於 修改

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36

更多資訊

Swarnava Sengupta
  • Locale Leader
493 個解決方法 3273 個答案

Make sure to reset the security.tls.version.max pref to 1 if you have previously changed this pref to 0 to disable TLS 1.0


Type about:config in the location (address) bar and press the "Enter" key to open the about:config page, just like you open a website by typing the URL in the location bar.

  • If you see a warning message then you can confirm that you want to access the about:config page.
  • use the Search bar at the top of the about:config page to locate preferences more easily

See also:

Make sure to reset the security.tls.version.max pref to 1 if you have previously changed this pref to 0 to disable TLS 1.0 Type about:config in the location (address) bar and press the "Enter" key to open the about:config page, just like you open a website by typing the URL in the location bar. * If you see a warning message then you can confirm that you want to access the about:config page. * use the Search bar at the top of the about:config page to locate preferences more easily See also: * http://kb.mozillazine.org/about:config * [[/questions/976504]]

由 Swarnava Sengupta 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17469 個解決方法 157871 個答案

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored.

If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.


Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Edit > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Edit > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored. If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate. ---- Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Edit > Preferences > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Edit > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page. Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of the involved files. If you revisit a 'forgotten' website then data from that website will be saved once again.

提出問題者

@Swarnava by default security.tls.version.max was 3 and changing it to 1 didn't helped.

@cor-el non of the solutions helped, as I previously said even removing the whole profile folder wont make any differences


I believe its not a firefox problem, after the recent system update Im getting same result from different browsers but firefox just works if I use the backedup profile that I performed before the system update.

@Swarnava by default security.tls.version.max was 3 and changing it to 1 didn't helped. @cor-el non of the solutions helped, as I previously said even removing the whole profile folder wont make any differences I believe its not a firefox problem, after the recent system update Im getting same result from different browsers but firefox just works if I use the backedup profile that I performed before the system update.

由 kotrebareka 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17469 個解決方法 157871 個答案

You can check the connection settings.

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can check the connection settings. *Tools > Options > Advanced > Network : Connection > Settings *https://support.mozilla.org/kb/Options+window+-+Advanced+panel If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/kb/Firefox+cannot+load+websites+but+other+programs+can