搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Search suggestions is enabled but not working?

  • 9 回覆
  • 18 有這個問題
  • 9259 次檢視
  • 最近回覆由 cor-el

more options

The search bar in the "Awesome bar" has recently stopped offering search suggestions, either from my search history or from Google itself. When I control-click in the search bar, "search suggestions" has a check next to it, and it is also ticked in the Preferences.

I've re-set network.http.speculative-parallel-limit to 0 and then set it to 6 and 10, with no difference. Re-starting the browser makes no difference.

browser.search.suggest.enabled = true browser.urlbar.suggest.bookmark = true browser.urlbar.suggest.history = true browser.urlbar.suggest.history.onlyTyped = false browser.urlbar.suggest.openpage = true browser.urlbar.suggest.searches = false

I've been having problems with Javascript seeming to just quit working after the browser has been running for a while over the last several updates, which affects things like comment loading on some sites, Java-based menus not working, etc. but I don't know if that would be related to this problem. A re-start didn't solve things in this case, not today anyway.

被選擇的解決方法

Try to clear the Google cookies.

Do you still get any suggestions if you type in the location/address bar or do you get no drop-down list at all?

Did you check the browser.urlbar prefs to see if any are user set (bold)?

  • browser.urlbar.maxRichResults
  • browser.urlbar.autocomplete.enabled
從原來的回覆中察看解決方案 👍 3

所有回覆 (9)

more options

選擇的解決方法

Try to clear the Google cookies.

Do you still get any suggestions if you type in the location/address bar or do you get no drop-down list at all?

Did you check the browser.urlbar prefs to see if any are user set (bold)?

  • browser.urlbar.maxRichResults
  • browser.urlbar.autocomplete.enabled
more options

Both of those prefs were untouched, but clearing the Google cookies worked.

(I was getting drop-downs from the location/address bar.)

Thanks, that was fast - guess I'll open something re: my Java issues soon. :)

more options

Oh dear. Less than 24 hours and the problem is back. What's corrupting my cookies so fast? I can't possibly just delete everything Google-related once a day.

more options

Do you have any cleanup software like CCleaner or Anti-Virus software that might be causing this corruption?

more options

Nope on either count.  :-/ I had Cookie Controller installed but it's been disabled for ages.

more options

If clearing cookies doesn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder in case cookies.sqlite got corrupted.

You can use this button to go to the current Firefox profile folder:

more options

I have renamed cookies.sqlite and moved it to the desktop. The other two I found were cookies.sqlite.bak and cookies.sqlite.bak-rebuild but I left them alone.

I shall report back.

more options

Here's what I'm finding:

Both deleting my Google-specific cookies, and deleting cookies.sqlite solves the problem briefly. But once my browser has been running a while, the search suggestions stop. If I shut down the browser and re-start it, they come back.

This is pretty much identical to problems I've had with Java (javascript?) for months now with Firefox. Comments on Livejournal show up for a while, then refuse to load. Item descriptions and sizing on Modcloth show up for a while, then nothing. Java-based menus on Kaiser Permanente's website work for a while, then nothing. It's bad enough that I'm considering switching to Chrome unless it can be fixed, but I can't seem to track the issue down.

more options

Make sure that all extensions are up to date, see about:addons

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window