Search Support

YouTube videos and comments hang

  • 12 回覆
  • 5 有這個問題
  • 60 次檢視
  • 最近回覆由 powerdump

more options

This only started earlier last week, or late the week before. EVERY YouTube video, does not matter which one, who uploaded it, or when it was originally uploaded, EVERY video causes Firefox to hang for up to 10-15 seconds, ever time. And it hangs a second time if I scroll down far enough to load the comments section. So far, all I've seen being used now is the HTML5 player on YouTube, so it's something with that possibly. Regardless, it is incredibly frustrating.

Is this due to something changing with the last couple updates to FireFox, or a plugin I have being out of date (even though they all say they're fine)? If not, is there anything I can do to fix it?

All Replies (12)

more options

check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

more options

Thank you Fred, but I did actually go through and check those on a different thread that I checked in at. As I mentioned, the videos in question aren't running in Flash player, they're running on the HTML5 player, so updating my flash (which is current) wouldn't have helped. And the first thing I did, when I saw this suggestion initially, was to upgrade my drivers, which at the time did have an update.

As of now, everything is up to date, Firefox included, and the issue is persisting.

Like... Just to explain on it a little... The video will continue playing for a second or two while the browser interface is completely locked up and unresponsive, then the video will usually lock up while the audio continues. Sometimes the entire video will lock up before Firefox finally resumes, but not always.

more options

We have been getting many complaints about problems with Youtube type sites.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Well unfortunately, it does persist into Firefox's safe mode. Same issue with the browser locking up after loading a video, and again after trying to load comments.

more options

FredMcD said

Start your Computer in safe mode with networking
more options

The issue persists into Safemode with Networking turned on. Silverlight is starting to have issues as well, when changing from a tab it is in to another. All this only started after a recent update to Firefox.

more options

I've called the big guys to help you. Good luck.

more options

Thanks Fred. :)

more options

As an added note: Silverlight has been freaking out as well. After pausing a movie in Netflix and changing to another tab, Silverlight completely locks up and Firefox has to terminate the script in order to proceed with anything else.

more options

Another update, since... That seems to be the only thing I can do at the moment...

I have verified that it's not the embedded videos FROM YouTube that cause an issue. Watching HTML5 YouTube videos that are embedded on different sites work fine and don't seem to cause the issues I outlined in my original post. They only seem to happen on YouTube itself. And it happens every. Single. Time. No exceptions.

And I've done everything to try and fix it. It's not my computer, it's obviously not just my version of Firefox, since this thread now has 2 others who have the same problems... And I've checked on that as well, as per Fred's guidance. So I don't know where to go from here.

more options

I feel I should bring this thread back to life as my problem was never given a solution. I still have the same issues with Firefox unable to preform properly while on YouTube. Videos play fine from other sites that have YouTube videos linked, but playing anything from the main page will still cause the browser to lock up. And the scrolling down far enough to see the comments will cause it to lock up. And then moving on to a different video will cause it to lock up. Really would like some help on this, because it's tiring having to launch another browser JUST to watch YouTube.

more options

Yeah, the crashing is out of control with 43.0.3 and 43.0.4. I've never experienced this degree of total application failure before. Somewhere around 30 crashes in the past week.

Until 44 is out, should I just set;

media.youtube-ua.override media.youtube-ua.override.from media.youtube-ua.override.to

all to undefined, blank, whatever. Or does "undefined" in the change log mean that it just hasn't been determined yet?

Also, any benefit in changing media.mediasource.webm.enabled to "true"?

由 powerdump 於 修改