搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How do I fix (Error code: sec_error_bad_der) when accessing google.com?

  • 7 回覆
  • 1 有這個問題
  • 1 次檢視
  • 最近回覆由 jscher2000

more options

An error occurred during a connection to www.google.com. security library: improperly formatted DER-encoded message. (Error code: sec_error_bad_der)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

I just recently started getting this error within the last week or so. As far as I've tested, google.com is the only website I have this issue with. I can access gmail just fine, just not the search engine. I'm just a normal, everyday user, not attached to any corporate entity, nor am I any kind of developer. I'm not on any kind of server, I'm running simple Avast anti-virus in which I haven't had any issues in the past in terms of firewall issues.

I have seen some articles that somewhat address this, however, I'm having a difficult time with even trying to apply a solution. Everything I see is a bit tech-jargon heavy. I'm somewhat familiar with messing around with some of the advanced settings in about:config for Firefox, but the areas that they say to use in the previously mentioned fixes don't seem to be there.

As far as I know, I'm using the latest version of Firefox 40 or something like that. I just want an easy, simple to implement fix, so I can stop using inferior search engines, lol. if there's any kind of screenshots needed, let me know where I can find the information and I'll post screens of it.

Thanks.

所有回覆 (7)

more options

All other HTTPS sites work normally?

As I noted in a recent thread, "Error code: sec_error_bad_der" is not reported very often on this forum, particularly when accessing well-run sites with normal certificates (i.e., not self-signed certificates).

(Constantly getting Secure Connection Failed message even for sites like google.com. Need a solution for non-techie user.)

I'm going to suggest some less drastic things to try:

(1) Clear Firefox's cache.

See: How to clear the Firefox cache

If you have a large hard drive, that might take a few minutes to run to completion.

Does that make any difference?

(2) Remove any server exceptions for Google. Open the Certificate Manager here:

"3-bar" menu button (or Tools menu) > Options > Advanced

Click the Network mini-tab and then the "View Certificates" button.

In the Certificate Manager, it's unpredictable which mini-tab will be open. Click the Server tab if necessary. This should list a number of certificate blocks (server indicated as *) and any exceptions you have added. If you find anything for Google, go ahead and remove it.

If you removed an exception, does that make any difference?

(3) Any difference accessing https://encrypted.google.com/ instead of the www domain?

more options

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "You can use the "View > Sidebar" menu. You can find a "Show sidebars" button in the Customize palette.

  • "3-bar" menu button > Customize
  • View > Toolbars > Customize
> History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

Alright. Cache clearing and cookie cleaning were the first things I did when I first noticed the issue. Didn't really do anything. Tried clearing certificates, only one entry was found (under the servers tab). deleted it, still didn't fix. also went and did the forget about it thing, not fixed.

I was however able to use the encrypted version of google successfully.

Any other info that might help the issue? I mean, I can manage just fine using the encrypted version, but if I can solve the root cause, that would be even better.

more options

Amendment: As far as I've noticed, any and all other http sites that I go to have no issues. it seems to be limited to just google.com.

more options

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

Google serves the identical certificate for these URLs:

www.google.com encrypted.google.com mail.google.com

I'm not sure about google.com since for me it immediately redirects to the www domain. Perhaps you meant that you're getting the error accessing the www domain. Could you double-check the address bar to see whether it's pre-redirect or post-redirect?

more options

Whoops, brain fade, your original post clearly says www.google.com.

In addition to the malware check, look in the Windows hosts file. It should be here (if it exists):

C:\Windows\System32\drivers\etc