搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to connect to secure website

  • 11 回覆
  • 3 有這個問題
  • 61 次檢視
  • 最近回覆由 cor-el

more options

Since upgrading to Win10, I can no longer sign into Amazon or several https websites. I've checked all the usual stuff and nothing works. What could be causing this?

所有回覆 (11)

more options
more options

Windows 10 users seem especially prone to compatibility issues between Firefox and Avast! and Microsoft Family Safety. If you don't have those, then this may not be relevant, but just in case.

Avast Web Shield

The Web Shield intercepts your browsing to scan for threats. Intercepting secure connections requires presenting "fake" certificates to Firefox, and unless Avast's installer set up Firefox to trust those certificates, you get errors on all secure sites. You could try switching off scanning HTTPS connections to see whether this is the cause in your case:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok

If that resolves the issue, you can still use the feature if you can get Firefox to trust Avast's signing certificate. You could try reinstalling Avast to trigger that process.

Microsoft Family Safety

Many users upgrading old systems to Windows 10 have encountered issues with Microsoft Family Safety. They accidentally apply parental controls to themselves. You can try disabling it (or not being part of a family): http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

Alternately, if you like that filter, you can import its certificate. See: https://support.mozilla.org/questions/1083592#answer-781104

more options

Took me this long to remember my forum password and get back to you guys....

I'm going to try again to attach a screen grab of the exact error I am getting on Hotmail, Amazon, and other secure websites. This isn't limited to Firefox though, I can't get to these websites with Edge, IE, or Chrome either. I've disabled AVG temporarily to see if that solves the problem, no luck. Firefox is my primary browser, just have the others for stuff Firefox doesn't like.

more options

You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.


In the event that the passwords information is lost, you should record all information in a separate text file somewhere else on your hard drive, or written down. You can easily copy and paste if you need to do so. If you are concerned about someone else looking at that file, you can compress it using a password.

more options

I'll run a deep scan with AVG and see if it picks anything up. Hotmail was working a half hour ago, I logged in and used the link at the bottom of the automated message to get back to this thread. Amazon was working fine a couple of days ago too. All this stuff started when I went to Win10.

I tried uploading the screen grab of the exact error message but it didn't show up. I could see the file listed under "Add images:" but it didn't actually upload it. What would cause that?

more options

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Trying again to attach a screen grab.

more options

Since Firefox's error page lacks detail, I wonder what message you get in the other browsers. Do any of them give more information?

more options

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.


Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

由 cor-el 於 修改

more options

I did that and it said the certificate was valid. I was able to login to Amazon and Hotmail this time but when I tried to view my Amazon cart, I got the same secure connection failed message again. I pulled my old WinXP laptop out and used it to complete my order. Can't let the dog run out of dog food!

This seems to be something connected to Win10. IE does nearly the same thing. Could a Java setting cause something like this?

more options

Try to click the View button that you see in the first screenshot to inspect the certificate.

You can check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.