X
點擊此處開啟此網站的行動版。

技術支援討論區

A flash ad in Yahoo Mail takes up 50% of CPU, even though I "blocked" Adobe Flash Player on that page

已張貼

The title says it all. I blocked Flash Player under Permissions, but the ads still run, consuming 10-50% of CPU, making the fan go crazy. Even after I reload the page, or exit and log back in.

Yes it's an old computer with limited RAM, but it serves me well on every other site.

Any suggestions? Why are Permissions not working? Thanks.

The title says it all. I blocked Flash Player under Permissions, but the ads still run, consuming 10-50% of CPU, making the fan go crazy. Even after I reload the page, or exit and log back in. Yes it's an old computer with limited RAM, but it serves me well on every other site. Any suggestions? Why are Permissions not working? Thanks.

被選擇的解決方法

Security Issue: Update your Flash Player Version 18.0.0.232
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Internet Explorer” and “Plugin-based browsers” installers.

Note: Edge on Win10 does not use ActiveX version but its own Flash.

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration


You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.


This is not a cure, but should let the web page load without crashing.

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it


Adblock Plus {web link} Blocks annoying video ads on YouTube, Facebook ads, banners and much more. Adblock Plus blocks all annoying ads, and supports websites by not blocking unobtrusive ads by default (configurable).

Adblock Plus Pop-up Addon {web link} Adblock Plus Pop-up Addon extends the blocking functionality of Adblock Plus to those annoying pop-up windows that open on mouse clicks and other user actions.

Forum; Adblock Plus Homepage {web link}

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Alipay Security Control
  • Alipay Internet Health Control
  • npaliedit
  • npalidcp
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • QQ2013 Chrome Plugin for Chrome V23.0.1271.64 or latest version
  • QQ2013 Firefox Plugin
  • Shockwave Flash 13.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • QQ QuickLogin Helper
  • VLC media player Web Plugin 2.1.3
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:38.0) Gecko/20100101 Firefox/38.0

更多資訊

FredMcD
  • Top 10 Contributor
4269 個解決方法 59845 個答案

選擇的解決方法

Security Issue: Update your Flash Player Version 18.0.0.232
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Internet Explorer” and “Plugin-based browsers” installers.

Note: Edge on Win10 does not use ActiveX version but its own Flash.

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration


You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.


This is not a cure, but should let the web page load without crashing.

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it


Adblock Plus {web link} Blocks annoying video ads on YouTube, Facebook ads, banners and much more. Adblock Plus blocks all annoying ads, and supports websites by not blocking unobtrusive ads by default (configurable).

Adblock Plus Pop-up Addon {web link} Adblock Plus Pop-up Addon extends the blocking functionality of Adblock Plus to those annoying pop-up windows that open on mouse clicks and other user actions.

Forum; Adblock Plus Homepage {web link}

Security Issue: Update your Flash Player '''Version 18.0.0.232<br>https://www.adobe.com/products/flashplayer/distribution3.html''' '''Note: Windows users''' must download the “Internet Explorer” '''and''' “Plugin-based browsers” installers. Note: Edge on Win10 does not use ActiveX version but its own Flash. See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration ------------------ You may have ad / mal-ware. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up. --------------------- This is not a cure, but should let the web page load without crashing. '''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it ----------------- '''[https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/ Adblock Plus]''' {web link} Blocks annoying video ads on YouTube, Facebook ads, banners and much more. Adblock Plus blocks all annoying ads, and supports websites by not blocking unobtrusive ads by default (configurable). '''[https://addons.mozilla.org/en-US/firefox/addon/adblock-plus-pop-up-addon/ Adblock Plus Pop-up Addon]''' {web link} Adblock Plus Pop-up Addon extends the blocking functionality of Adblock Plus to those annoying pop-up windows that open on mouse clicks and other user actions. Forum; '''[https://adblockplus.org/forum/ Adblock Plus Homepage]''' {web link}

提出問題者

Thanks Fred. Unfortunately, it's not a matter of updating Flash. I have the second most recent version.

The question remains: why blocking Flash in Permissions is NOT working? Do I have clear cookies/cache every time?

Thanks.

Thanks Fred. Unfortunately, it's not a matter of updating Flash. I have the second most recent version. The question remains: why blocking Flash in Permissions is NOT working? Do I have clear cookies/cache every time? Thanks.
jscher2000
  • Top 10 Contributor
8789 個解決方法 71880 個答案

有幫助的回覆

If you check the plugin notification icon in the address bar (looks like a dark gray lego block), does it indicate that Flash is blocked or allowed in the page? If the icon is missing, it might be HTML5 video. One way to double-check is to right-click the media and check the short content menu. Does the bottom line indicate Flash?

If you check the plugin notification icon in the address bar (looks like a dark gray lego block), does it indicate that Flash is blocked or allowed in the page? If the icon is missing, it might be HTML5 video. One way to double-check is to right-click the media and check the short content menu. Does the bottom line indicate Flash?
James
  • Top 25 Contributor
  • Moderator
1601 個解決方法 11324 個答案

有幫助的回覆

elzach said

Thanks Fred. Unfortunately, it's not a matter of updating Flash. I have the second most recent version.

Your system details says you have a old Flash 13.0 branch version on system and not a 18.0 version.

The previous Flash Player 13 ESR is no longer supported with security updates from Adobe as you can see at https://www.adobe.com/products/flashplayer/distribution3.html

https://addons.mozilla.org/firefox/blocked/ The Flash Player Plugin 13.0.0.302 (esr) and older is on blocklist due to being affected by critical vulnerabilities.

''elzach [[#answer-781557|said]]'' <blockquote> Thanks Fred. Unfortunately, it's not a matter of updating Flash. I have the second most recent version. </blockquote> Your system details says you have a old Flash 13.0 branch version on system and not a 18.0 version. The previous Flash Player 13 ESR is no longer supported with security updates from Adobe as you can see at https://www.adobe.com/products/flashplayer/distribution3.html https://addons.mozilla.org/firefox/blocked/ The Flash Player Plugin 13.0.0.302 (esr) and older is on blocklist due to being affected by critical vulnerabilities.

由 James 於 修改

提出問題者

jscher2000 said

If you check the plugin notification icon in the address bar (looks like a dark gray lego block), does it indicate that Flash is blocked or allowed in the page? If the icon is missing, it might be HTML5 video. One way to double-check is to right-click the media and check the short content menu. Does the bottom line indicate Flash?

Thanks! I think you're right, it doesn't indicate Flash. It's HTML5 I think.

So there is no way of blocking it inherently, correct?

''jscher2000 [[#answer-781583|said]]'' <blockquote> If you check the plugin notification icon in the address bar (looks like a dark gray lego block), does it indicate that Flash is blocked or allowed in the page? If the icon is missing, it might be HTML5 video. One way to double-check is to right-click the media and check the short content menu. Does the bottom line indicate Flash? </blockquote> Thanks! I think you're right, it doesn't indicate Flash. It's HTML5 I think. So there is no way of blocking it inherently, correct?
jscher2000
  • Top 10 Contributor
8789 個解決方法 71880 個答案

There is a setting to stop "autoplay" for HTML5 video but unfortunately sites have a workaround, which is to use a script to send a Play command to the media. So it's only effective on some sites. There is going to be a change in Firefox 41 to try to deal with that.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.autoplay.enabled preference to switch it from true to false.

I don't know whether that takes effect immediately on the next page reload, or whether you need to exit Firefox and start it up again.

Or some users prefer the Flash Control extension (it's for Flash and HTML5 media):

https://addons.mozilla.org/firefox/addon/flash-control/

There is a setting to stop "autoplay" for HTML5 video but unfortunately sites have a workaround, which is to use a script to send a Play command to the media. So it's only effective on some sites. There is going to be a change in Firefox 41 to try to deal with that. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media''' and pause while the list is filtered (3) Double-click the '''media.autoplay.enabled''' preference to switch it from true to false. I don't know whether that takes effect immediately on the next page reload, or whether you need to exit Firefox and start it up again. Or some users prefer the Flash Control extension (it's for Flash and HTML5 media): https://addons.mozilla.org/firefox/addon/flash-control/

提出問題者

I tried the Adblock Lite extension and it's working ok, but only in FULL mode. That took care of the problem for now.

I saved the other two extensions mentioned here.

Thank you all.

I tried the Adblock Lite extension and it's working ok, but only in FULL mode. That took care of the problem for now. I saved the other two extensions mentioned here. Thank you all.