X
點擊此處開啟此網站的行動版。

技術支援討論區

Error code: ssl_error_inappropriate_fallback_alert

已張貼

Hi,

I'm unable to login at aa.com for about six weeks now. This only happens when using Firefox. Error message is:

Error code: ssl_error_inappropriate_fallback_alert

I have been browsing the forums and looked up similiar errors but none of them were helpful.

1. All TLS settings are standard in about:config

2. I don't have Bit Defender anti virus or any other third-party product

3. I'm using Windows Defender

4. The issue just came up recently

It works fine in Chrome and even Internet Explorer. I am using Windows 10. Manipulating TLS settings in about:config does not solve the issue.

Any suggestions?

Hi, I'm unable to login at aa.com for about six weeks now. This only happens when using Firefox. Error message is: Error code: ssl_error_inappropriate_fallback_alert I have been browsing the forums and looked up similiar errors but none of them were helpful. 1. All TLS settings are standard in about:config 2. I don't have Bit Defender anti virus or any other third-party product 3. I'm using Windows Defender 4. The issue just came up recently It works fine in Chrome and even Internet Explorer. I am using Windows 10. Manipulating TLS settings in about:config does not solve the issue. Any suggestions?

由 ckx2 於 修改

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • Fuze Browser Extension
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.60.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • LastPass Plugin
  • Shockwave Flash 18.0 r0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

更多資訊

FredMcD
  • Top 10 Contributor
4254 個解決方法 59584 個答案

I had no problem. Try this link; http://www.aa.com/homePage.do

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

I had no problem. Try this link; '''http://www.aa.com/homePage.do''' Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

提出問題者

Thanks for your reply - unfortunately none of your suggestions has worked.

I even created a new, blank user profile / re-installed firefox completly after clearing all application data.

It still shows TLS error while logging in.

Thanks for your reply - unfortunately none of your suggestions has worked. I even created a new, blank user profile / re-installed firefox completly after clearing all application data. It still shows TLS error while logging in.
FredMcD
  • Top 10 Contributor
4254 個解決方法 59584 個答案
I've called the big guys to help you. Good luck. http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html https://support.mozilla.org/en-US/kb/server-not-found-connection-problem https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message '''http://kb.mozillazine.org/Error_loading_websites''' '''This Connection is Untrusted''' is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.
cor-el
  • Top 10 Contributor
  • Moderator
17525 個解決方法 158458 個答案

The website may try to fallback to a lower TLS version in a way that is no longer allowed in current releases or may be using a deprecated cipher suite.

You can open the about:config page via the location/address bar and use its search bar to locate this pref:

  • security.tls.insecure_fallback_hosts

You can double-click the line to modify the pref and add the full domain () to the value of this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). There should only be domains separated by a comma in the Value column (example.com,www.example.com).

If this helps then you can contact this website and ask them to look into this and update their security.

The website may try to fallback to a lower TLS version in a way that is no longer allowed in current releases or may be using a deprecated cipher suite. You can open the <b>about:config</b> page via the location/address bar and use its search bar to locate this pref: *security.tls.insecure_fallback_hosts You can double-click the line to modify the pref and add the full domain () to the value of this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). There should only be domains separated by a comma in the Value column (example.com,www.example.com). If this helps then you can contact this website and ask them to look into this and update their security.

提出問題者

FredMcD said

I've called the big guys to help you. Good luck. http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html https://support.mozilla.org/en-US/kb/server-not-found-connection-problem https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message http://kb.mozillazine.org/Error_loading_websites This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

Thank you. Unfortunately the problem still exists.

cor-el said

The website may try to fallback to a lower TLS version in a way that is no longer allowed in current releases or may be using a deprecated cipher suite. You can open the about:config page via the location/address bar and use its search bar to locate this pref:
  • security.tls.insecure_fallback_hosts
You can double-click the line to modify the pref and add the full domain () to the value of this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). There should only be domains separated by a comma in the Value column (example.com,www.example.com). If this helps then you can contact this website and ask them to look into this and update their security.

Thanks. I've added the website (aa.com) and restarted firefox. The problem still occurs - same error message.

The problem now also occurs on a second Windows 10 machine. It was working fine with Windows 7.

''FredMcD [[#answer-781689|said]]'' <blockquote> I've called the big guys to help you. Good luck. http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html https://support.mozilla.org/en-US/kb/server-not-found-connection-problem https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message '''http://kb.mozillazine.org/Error_loading_websites''' '''This Connection is Untrusted''' is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings. </blockquote> Thank you. Unfortunately the problem still exists. ''cor-el [[#answer-781709|said]]'' <blockquote> The website may try to fallback to a lower TLS version in a way that is no longer allowed in current releases or may be using a deprecated cipher suite. You can open the <b>about:config</b> page via the location/address bar and use its search bar to locate this pref: *security.tls.insecure_fallback_hosts You can double-click the line to modify the pref and add the full domain () to the value of this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). There should only be domains separated by a comma in the Value column (example.com,www.example.com). If this helps then you can contact this website and ask them to look into this and update their security. </blockquote> Thanks. I've added the website (aa.com) and restarted firefox. The problem still occurs - same error message. The problem now also occurs on a second Windows 10 machine. It was working fine with Windows 7.

由 ckx2 於 修改

guigs 1072 個解決方法 11697 個答案

What is the preference in about:config on your Windows 10 machine: I have attached all the unique fallback rules for Windows 10 in an image. Are any of them different on your machine?

Does removing the certificate of the site and asking for a new issued cert update the certificate.

Also are you using a proxy of web filter to connect?

What is the preference in about:config on your Windows 10 machine: I have attached all the unique fallback rules for Windows 10 in an image. Are any of them different on your machine? Does removing the certificate of the site and asking for a new issued cert update the certificate. Also are you using a proxy of web filter to connect?
jscher2000
  • Top 10 Contributor
8758 個解決方法 71658 個答案

When I try this page

https://www.aa.com/login/loginSubmit.do

I get a page loading (not very attractively) with a gray warning triangle. (Screen shot attached.) Although the site uses TLS 1.2 with me, it uses an RC4 cipher, which Firefox hasn't considered secure for several versions now.

I don't know whether that is at all relevant to your error message.


Aside from security software, do you use any proxy or filtering software? Many users upgrading old systems to Windows 10 have encountered issues with Microsoft Family Safety. You can try disabling it (or not being part of a family): http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

Alternately, if you like that filter, you can import its certificate. See: https://support.mozilla.org/questions/1083592#answer-781104

When I try this page https://www.aa.com/login/loginSubmit.do I get a page loading (not very attractively) with a gray warning triangle. (Screen shot attached.) Although the site uses TLS 1.2 with me, it uses an RC4 cipher, which Firefox hasn't considered secure for several versions now. I don't know whether that is at all relevant to your error message. ---- Aside from security software, do you use any proxy or filtering software? Many users upgrading old systems to Windows 10 have encountered issues with Microsoft Family Safety. You can try disabling it (or not being part of a family): http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings Alternately, if you like that filter, you can import its certificate. See: https://support.mozilla.org/questions/1083592#answer-781104

提出問題者

guigs said

What is the preference in about:config on your Windows 10 machine: I have attached all the unique fallback rules for Windows 10 in an image. Are any of them different on your machine? Does removing the certificate of the site and asking for a new issued cert update the certificate. Also are you using a proxy of web filter to connect?

Preference are matching the ones in your screenshot - except for the hosts entry where I've added http://www.aa.com as suggested in another post. I'm not using any proxy or web filter.

jscher2000 said

When I try this page https://www.aa.com/login/loginSubmit.do I get a page loading (not very attractively) with a gray warning triangle. (Screen shot attached.) Although the site uses TLS 1.2 with me, it uses an RC4 cipher, which Firefox hasn't considered secure for several versions now. I don't know whether that is at all relevant to your error message.

Aside from security software, do you use any proxy or filtering software? Many users upgrading old systems to Windows 10 have encountered issues with Microsoft Family Safety. You can try disabling it (or not being part of a family): http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

Alternately, if you like that filter, you can import its certificate. See: https://support.mozilla.org/questions/1083592#answer-781104

I'm not using MS family safety.


Maybe Firefox want's me to use another carrier than American Airlines ;)

''guigs [[#answer-782254|said]]'' <blockquote> What is the preference in about:config on your Windows 10 machine: I have attached all the unique fallback rules for Windows 10 in an image. Are any of them different on your machine? Does removing the certificate of the site and asking for a new issued cert update the certificate. Also are you using a proxy of web filter to connect? </blockquote> Preference are matching the ones in your screenshot - except for the hosts entry where I've added http://www.aa.com as suggested in another post. I'm not using any proxy or web filter. ''jscher2000 [[#answer-782341|said]]'' <blockquote> When I try this page https://www.aa.com/login/loginSubmit.do I get a page loading (not very attractively) with a gray warning triangle. (Screen shot attached.) Although the site uses TLS 1.2 with me, it uses an RC4 cipher, which Firefox hasn't considered secure for several versions now. I don't know whether that is at all relevant to your error message. ---- Aside from security software, do you use any proxy or filtering software? Many users upgrading old systems to Windows 10 have encountered issues with Microsoft Family Safety. You can try disabling it (or not being part of a family): http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings Alternately, if you like that filter, you can import its certificate. See: https://support.mozilla.org/questions/1083592#answer-781104 </blockquote> I'm not using MS family safety. Maybe Firefox want's me to use another carrier than American Airlines ;)
jscher2000
  • Top 10 Contributor
8758 個解決方法 71658 個答案

Could you do this test:

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

This will be in parallel to your current profile and not remove any data.

Exit Firefox and start up in the Profile Manager using the search box or Run dialog (hold down the Window key and press R):

firefox.exe -P

Don't delete anything here!

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like TEST091615, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile.

Any difference?

When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

Could you do this test: '''Create a new Firefox profile''' A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder. ''This will be in parallel to your current profile and not remove any data.'' Exit Firefox and start up in the Profile Manager using the search box or Run dialog (hold down the Window key and press R): firefox.exe -P ''Don't delete anything here!'' Any time you want to switch profiles, exit Firefox and return to this dialog. Click the Create Profile button, assign a name like TEST091615, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile. Any difference? When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.