X
點擊此處開啟此網站的行動版。

技術支援討論區

Is it mozilla firefox version 21, 22 and 23 can work with Mac OS X 10.7.5?

已張貼

I am currently using Mac OS X version 10.7.5 and the website that I'm going to use is needing to have a mozilla firefox with version of either of the 3 such as 21, 22 & 23. Unfortunately, I can't download or install the said version using my Macbook. Is there any way for downloading these mozilla firefox versions? Hope you could assist me on this matter.

I am currently using Mac OS X version 10.7.5 and the website that I'm going to use is needing to have a mozilla firefox with version of either of the 3 such as 21, 22 & 23. Unfortunately, I can't download or install the said version using my Macbook. Is there any way for downloading these mozilla firefox versions? Hope you could assist me on this matter.

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.78.2 (KHTML, like Gecko) Version/6.1.6 Safari/537.78.2

更多資訊

_ika 3 個解決方法 22 個答案

Firefox 21,22 and 23 for mac are here https://ftp.mozilla.org/pub/firefox/releases/21.0/mac/en-US/ https://ftp.mozilla.org/pub/firefox/releases/22.0/mac/en-US/ https://ftp.mozilla.org/pub/firefox/releases/23.0/mac/en-US/

I don't have Macbook, so I don't know how will work on your machine. Hence the 21 and 22 were targeted to darwin 11.2 which is bellow darwin 11.4.2 (OSX 10.7.5), most probably they should work.

P.S Using old versions of browser can be a security risk, as they have vulnerabilities. Avoid that ,if you can.

Firefox 21,22 and 23 for mac are here https://ftp.mozilla.org/pub/firefox/releases/21.0/mac/en-US/ https://ftp.mozilla.org/pub/firefox/releases/22.0/mac/en-US/ https://ftp.mozilla.org/pub/firefox/releases/23.0/mac/en-US/ I don't have Macbook, so I don't know how will work on your machine. Hence the 21 and 22 were targeted to darwin 11.2 which is bellow darwin 11.4.2 (OSX 10.7.5), most probably they should work. P.S Using old versions of browser can be a security risk, as they have vulnerabilities. Avoid that ,if you can.

由 _ika 於 修改

jscher2000
  • Top 10 Contributor
8763 個解決方法 71700 個答案

For security reasons, you should not use such old versions of Firefox. Mozilla discloses security flaws after each new release.

What kind of websites is so important to you and yet so cavalier about its users' security? Can't they get their act together?

Anyway, if you need such an old Firefox for the one site, if there isn't a way to use an up-to-date Firefox for others sites, you should use Safari or Chrome for other sites so you aren't as exposed.

For security reasons, you should not use such old versions of Firefox. Mozilla discloses [https://www.mozilla.org/security/known-vulnerabilities/firefox.html security flaws] after each new release. What kind of websites is so important to you and yet so cavalier about its users' security? Can't they get their act together? Anyway, if you need such an old Firefox for the one site, if there isn't a way to use an up-to-date Firefox for others sites, you should use Safari or Chrome for other sites so you aren't as exposed.