Search Support

Problem with fonts. If I enable Hardware acceleration bold fonts look weird, but if I disable it, bold fonts look good, but normal fonts look weird

  • 3 回覆
  • 10 有這個問題
  • 2825 次檢視
  • 最近回覆由 Piecito

more options

Title.

With hardware acceleration: http://imgur.com/jHRk6Yl Words look "empty", and look really weird instead of being bold. But if I disable it, normal fonts look 'weird' in some webs (not all), and are hard to read. Any solution?

Thanks!

被選擇的解決方法

Hmm, another Windows 10 user reported this after installing some Helvetica fonts.

In your screenshot, the "blue outlined" text has the following style rule:

font-family: "helvetica neue",arial,helvetica,sans-serif;

So I'm assuming you have Helvetica Neue installed locally, which seems to have strange issues in Firefox.

If you don't want to remove that font from your system, you may be able to use custom style rules to have Firefox substitute Arial, which is what I see on Windows 7 on that page. I first saw that documented in this article (from 2010!):

Helvetica on Firefox: Overriding Fonts with CSS | Keyvan Minoukadeh

從原來的回覆中察看解決方案 👍 2

All Replies (3)

more options

Where are my eye glasses?

From Mozilla help files: Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.


Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

more options

選擇的解決方法

Hmm, another Windows 10 user reported this after installing some Helvetica fonts.

In your screenshot, the "blue outlined" text has the following style rule:

font-family: "helvetica neue",arial,helvetica,sans-serif;

So I'm assuming you have Helvetica Neue installed locally, which seems to have strange issues in Firefox.

If you don't want to remove that font from your system, you may be able to use custom style rules to have Firefox substitute Arial, which is what I see on Windows 7 on that page. I first saw that documented in this article (from 2010!):

Helvetica on Firefox: Overriding Fonts with CSS | Keyvan Minoukadeh

more options

Thank you both for your answers! I have fixed it with jscher2000 solution :) I had installed some Helvetica fonts a while ago, and they were messing with Mozilla's fonts. I just deleted the Helvetica fonts, and all fixed.

Thanks again!