搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

connection reset for Amazon.com, but not other sites

  • 8 回覆
  • 1 有這個問題
  • 31 次檢視
  • 最近回覆由 Phoxuponyou

more options

I have tried safe mode, reset Firefox, uninstalled and reinstalled, but still constantly face a connection reset for Amazon.com, but not other sites. Am using Windows 10 64-bit.

所有回覆 (8)

more options

Hi, delete all references to the website in question, as shown under the heading 'How do I remove a single website from my history?' in this article - Delete browsing, search and download history on Firefox.

Also see Websites don't load - troubleshoot and fix error messages.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options

Thank you for the suggestions.

I tried the above, and it does not solve the problem.

more options

Good suggestion. I had checked that earlier. Does not affect the problem, which I'm not having in Chrome.

more options

What security software do you have?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

more options

thank you for the reply and suggestions. have tried: 1) Firefox safe mode 2) clean install of Firefox (though my history, etc restored via sync) 3) forgetting Amazon.com + deleting its cookie(s) 4) am using the default theme 5) have turned off hardware acceleration 6) bypassing cache to reload page

have not tried Windows Safe mode; that's a lot of trouble for a problem with Firefox but not SWIron Chrome browser.

Amazon also occasionally comes up in Firefox, which makes the problem even more vexing.

more options

It could be your antivirus interfering with Firefox; cor-el was asking about your security suite above.

So what suite do you use? Can you try turning off browser protection like anti-banner and anti-scam stuff or "advisors"?

more options

Thank you for the reply.

Anti-viral protection is not the problem. I have tried Firefox in safe mode with the firewalls and anti-malware off and the problem exists.

The one thing that does work is using a VPN (regardless of firewall & anti-malware). That indicates that it is not a Firefox problem, but perhaps an ISP problem.

more options

Definitely - good testing!