搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I'm missing photos on Yahoo.com home page and don't know why, any help?

  • 33 回覆
  • 4 有這個問題
  • 698 次檢視
  • 最近回覆由 jscher2000

more options

Yesterday, after restarting my computer when trying to launch firefox i received an option "start in safe mode or refresh". I refreshed and now anytime i search Yahoo.com the home page is missing files. I've tried to search for answers and haven't found anything that seems to work. Attached below are images of Yahoo.com and the sign in for yahoo mail. Any help or suggestions would really be nice. Thanks in advance!

附加的畫面擷圖

所有回覆 (20)

more options

Could you try this: right-click a blank area of the page with missing images, and choose "View Page Info". At the top of the dialog, click Media. This should show a list of images used in the page. Click the first one and notice there is a checkbox above the preview area to block images from that site. Use the down arrow on the keyboard to check each image on the list to see whether it is on a blocked server and, if it is uncheck the box. When you're done, close the Page Info dialog and reload the page (Ctrl+r). Does that help?

You also can see our general article: Fix problems that cause images to not show

By the way, the Safe Mode / Refresh dialog comes up if the Shift key is held down when starting Firefox. I haven't heard of other situations where it comes up.

more options

i followed your instructions and didn't have a check box, here is an image

more options

i meant there aren't any checks in the boxes

由 thedon01 於 修改

more options

Could you see whether Adblock Plus is blocking the images by either making an exception for the site or turning it off?

Alternately, you could test in Firefox's Safe Mode, which disables all extensions:

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

more options

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

i disabled adblock on yahoo > restart > nothing changed

I disabled all addons > restarted in safe mode > nothing change

more options

You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero).

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.


Do you see View Image Info if you right-click in the area where an image should be? If that isn't the case then you can try to inspect that element in the page source via Inspect Element.

If images are missing then check that you do not block images from some domains. You can tap the Alt key or press F10 to show the Menu Bar Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"

Check "Tools > Page Info > Media" for blocked images

  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.

more options

cor-el said

You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if content fails to load or possibly is blocked (file size is zero). Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

Do you see View Image Info if you right-click in the area where an image should be? If that isn't the case then you can try to inspect that element in the page source via Inspect Element.

If images are missing then check that you do not block images from some domains. You can tap the Alt key or press F10 to show the Menu Bar Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"

Check "Tools > Page Info > Media" for blocked images

  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.

what exactly am i looking for in the log files?

more options

here is the image with the web developer > web console log open

more options

You would have to enable the items under Net or go to the Network tab to get information about loaded files. Currently you only see security errors and what you see is normal and meant for website administrators.

more options

cor-el said

You would have to enable the items under Net or go to the Network tab to get information about loaded files. Currently you only see security errors and what you see is normal and meant for website administrators.

i have no idea how to change things in those tabs.

more options

Hi there!

Ok, keep let's keep it simple . I will tell exactly same thing that you have done till now, check thoroughly this time ok.

1. open your yahoo page , for eg. yahoo.com. 2. tap F12 to open inspector window. 3. go to Network option and press F5 to reload the page and you will see that the network data is generating in the panel.

4. Check if there is any image file showing in the type column . 5. If showing , then tap on that option , if the option is showing 304 warning status, then the status has not been updated. It means you will have to do some tweaks in the coding, if you know it , otherwise don't edit the code. Leave it as it is. 6. Next , right-click on the page , click on view page info , a window will open up. 7. Go to Media , see if the option Block Images has been checked out or not, 8.If everything is ok, go to permission option , there is a Load Images option , un-check it and select Allow.

9. Refresh your page. Or close the browser and re-open it.

If the problem still persist, please inform us, we will try to work it out.

由 fiest 於 修改

more options

there were a couple 304 warnings and i followed the rest of the options, unchecked load images (use default) > clicked allow > refreshed and same problem.

this may or may not be useful, but if i open yahoo in IE all the images load correctly.

more options

One way to at least diagnose this problem is to see if the image is being hosted on an alternate server; then try to locate it. Right-click the image or broken link icon and select Properties from the dropdown menu that appears. Look should see the Internet address of the image. Copy that link then paste it into your address bar and remove the name of the image. For example, if you were to do this on the image of the example above, you would copy "http://www.computerhope.com/issues/broken.gif" then remove "broken.gif" portion of the URL. Some websites list the directory of files (Computer Hope has this feature disabled) thus giving you the location of the image. This is also a good method for determining whether or not the computer hosting the image is still active.

If you trust the site you are visiting and have spyware protection, try temporarily disabling any protection to verify your protection is not blocking anything.

Try visiting the web page in a few hours or days. As we mentioned above, high traffic can be the culprit.

If you're running Microsoft Windows, verify your hosts file is not blocking or redirecting the website you're visiting.

由 fiest 於 修改

more options

Try the above information, yeah , i agree that firefox sometimes has serious issues, that are hard to solve , try the above information, see if that works.

Hope that helps.

more options

there's no "properties" link when right clicking yahoos main image. How could the image no longer be available on all the images in yahoo while they're visible using IE?

more options

Did you try to start Firefox in Safe Mode and reload the page(s)?

Did you try to boot the computer in Windows Safe Mode with network support in case security software is blocking content?

Does loading the pages in a New Private Window has any effect (no disk cache and a separate cookie jar)?

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)
more options

i just disabled avast shields, loaded yahoo and bingo there's the images.

由 thedon01 於 修改

more options

Avast has several different "shield" features. We often see issues with scanning encrypted content in the Web Shield, but I don't think it's that one in this case. Perhaps some kind of ad blocking?

more options

fiest said

Right-click the image or broken link icon and select Properties from the dropdown menu that appears. Look should see the Internet address of the image.

thedon01 said

there's no "properties" link when right clicking yahoos main image.

In Firefox, the right-click context menu item is "View Image Info" -- Properties is in Internet Explorer's menu

  1. 1
  2. 2