X
點擊此處開啟此網站的行動版。

技術支援討論區

Browser window shows black squares and lines, toolbar diappears when resizing

已張貼

Since updating to Firefox 40.0 (in OS X 10.9.5) browser windows and the toolbar show strange black lines and squares when the window is resized. Websites are messed up with black backgrounds or disappear beneath a black layer. The toolbar often disappears too, except for the three Mac resize buttons. It renders Firefox completely unusable.

It’s similar to what is described here: https://support.mozilla.org/nl/questions/1071126 and the bug described here: https://bugzilla.mozilla.org/show_bug.cgi?id=1032769

None of the offered solutions or workarounds seems to help. Disabling all add-ons and extensions doesn’t help either. I only use the Default theme.

Solution To my own surprise the issue disappeared completely when I installed and started to use another theme (Simple White)…

So it seems that Firefox’s Default theme has a serious bug?

Since updating to Firefox 40.0 (in OS X 10.9.5) browser windows and the toolbar show strange black lines and squares when the window is resized. Websites are messed up with black backgrounds or disappear beneath a black layer. The toolbar often disappears too, except for the three Mac resize buttons. It renders Firefox completely unusable. It’s similar to what is described here: https://support.mozilla.org/nl/questions/1071126 and the bug described here: https://bugzilla.mozilla.org/show_bug.cgi?id=1032769 None of the offered solutions or workarounds seems to help. Disabling all add-ons and extensions doesn’t help either. I only use the Default theme. Solution To my own surprise the issue disappeared completely when I installed and started to use another theme (Simple White)… So it seems that Firefox’s Default theme has a serious bug?

被選擇的解決方法

The default theme works on my computer and the bug you referenced was for a Windows machine. Safe Mode would disable hardware acceleration and determine if that was the issue.

OMTC you can try that work around here in about:config to false to determine it it is OMTC, however this should only affect the webpage, not the Firefox interface.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Biedt informatie over de standaardwebbrowser
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Met de QuickTime-plugin kunt u een grote verscheidenheid aan multimediamateriaal op webpagina's bekijken. Raadpleeg voor meer informatie de website van QuickTime.
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0

應用程式

  • Firefox 40.0
  • 使用者代理:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:40.0) Gecko/20100101 Firefox/40.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/40.0/Darwin/nl/

擴充套件

  • askDictionary 1.2.3.1-signed (kevin.erhardt@gmail.com)
  • Browsizer 1.3.5.1-signed (browsizer@nuko.org)
  • Ghostery 5.4.6.1 (firefox@ghostery.com)
  • mPage 0.7.6 ({b9ca4756-a187-4a50-b350-7c860e9a863d})
  • Strict Pop-up Blocker 0.2.1-signed (jid1-P34HaABBBpOerQ@jetpack)
  • Delete Bookmark Icons 0.6.1-signed ({04514a2c-a3ab-4f47-8688-55f911b0fe75}) (Inactive)
  • TinyURL Generator 2.6.1.1-signed (tinyurl.addon@fast-chat.co.uk) (Inactive)
  • YouTube Video and Audio Downloader 0.4.5 (feca4b87-3be4-43da-a1b1-137c24220968@jetpack) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription:
  • adapterDeviceID: 0x9588
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 2600 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
FredMcD
  • Top 10 Contributor
4246 個解決方法 59405 個答案

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.
cor-el
  • Top 10 Contributor
  • Moderator
17476 個解決方法 157949 個答案

You can try to disable hardware acceleration in Firefox.

  • Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to disable hardware acceleration in Firefox. *Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

提出問題者

Hi, thanks for your response, but I already tried troubleshooting as explained in those articles, except for the 'Refresh'.

Hardware acceleration enabled or disabled doesn’t make any difference. I’ve tried disabling all plug-ins and extensions manually, as well as a restart in safe mode. I’ve tried disabling WebGL. As far as I know there are no updates for my graphics display driver. My other browsers (Safari 7.1.8 , Chrome 44), or other apps don’t show problems of this kind. It’s not related to specific websites and it also occurs in blank windows.

If the issue seems to be fixed with the use of another theme, wouldn’t the logical conclusion be that there must be something wrong with the Default theme? Or can a theme get corrupted in the course of time, even when it's updated?

The only thing I haven’t tried is to ‘Refresh’ Firefox (because of the pain of having to reinstall all add ons when I do). Could this help in a case like this?

Hi, thanks for your response, but I already tried troubleshooting as explained in those articles, except for the 'Refresh'. Hardware acceleration enabled or disabled doesn’t make any difference. I’ve tried disabling all plug-ins and extensions manually, as well as a restart in safe mode. I’ve tried disabling WebGL. As far as I know there are no updates for my graphics display driver. My other browsers (Safari 7.1.8 , Chrome 44), or other apps don’t show problems of this kind. It’s not related to specific websites and it also occurs in blank windows. If the issue seems to be fixed with the use of another theme, wouldn’t the logical conclusion be that there must be something wrong with the Default theme? Or can a theme get corrupted in the course of time, even when it's updated? The only thing I haven’t tried is to ‘Refresh’ Firefox (because of the pain of having to reinstall all add ons when I do). Could this help in a case like this?
FredMcD
  • Top 10 Contributor
4246 個解決方法 59405 個答案

These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose.

OPIE {web link} Import/Export extension preferences

These add-ons can be a great help by backing up and restoring Firefox '''[https://addons.mozilla.org/en-US/firefox/addon/febe/ FEBE (Firefox Environment Backup Extension)]''' {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose. '''[https://addons.mozilla.org/en-US/firefox/addon/opie/ OPIE]''' {web link} Import/Export extension preferences
guigs 1072 個解決方法 11697 個答案

選擇的解決方法

The default theme works on my computer and the bug you referenced was for a Windows machine. Safe Mode would disable hardware acceleration and determine if that was the issue.

OMTC you can try that work around here in about:config to false to determine it it is OMTC, however this should only affect the webpage, not the Firefox interface.

The default theme works on my computer and the bug you referenced was for a Windows machine. Safe Mode would disable hardware acceleration and determine if that was the issue. OMTC you can try that work around [https://support.mozilla.org/en-US/questions/1039058 here] in about:config to false to determine it it is OMTC, however this should only affect the webpage, not the Firefox interface. *[[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]

由 guigs 於 修改

提出問題者

Thanks, guigs - setting OMTC to false worked!

I remember trying it before (after reading this post https://support.mozilla.org/nl/questions/1071126), but (foolishly) must have forgotten to restart then…

This time, after a restart, it works :-)

Thanks, guigs - setting OMTC to false worked! I remember trying it before (after reading this post https://support.mozilla.org/nl/questions/1071126), but (foolishly) must have forgotten to restart then… This time, after a restart, it works :-)