Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can get some websites to come up and some don't. When I try to sign into any site, I get this message and can't sign in

  • 1 回覆
  • 5 有這個問題
  • 303 次檢視
  • 最近回覆由 jscher2000

more options

Secure Connection Failed

An error occurred during a connection to mail.yahoo.com. Peer's certificate has an invalid signature. (Error code: sec_error_bad_signature)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

被選擇的解決方法

The most common reason for getting "sec_error_bad_signature" on numerous sites seems to be the Avast Web Shield. Web Shield intercepts your browsing and filters it, but to filter secure sites, it presents "fake" certificates to Firefox. Avast should have set up Firefox to trust its fake certificates but that seems to fail on a regular basis.

To test this theory, try turning off scanning of encrypted sites. I saw these steps in another post:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok

If that resolves the issue, but you prefer to filter encrypted communications, you may need to import the Avast! signing certficate into Firefox's Certificate Manager, Authorities tab.

從原來的回覆中察看解決方案 👍 4

所有回覆 (1)

more options

選擇的解決方法

The most common reason for getting "sec_error_bad_signature" on numerous sites seems to be the Avast Web Shield. Web Shield intercepts your browsing and filters it, but to filter secure sites, it presents "fake" certificates to Firefox. Avast should have set up Firefox to trust its fake certificates but that seems to fail on a regular basis.

To test this theory, try turning off scanning of encrypted sites. I saw these steps in another post:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok

If that resolves the issue, but you prefer to filter encrypted communications, you may need to import the Avast! signing certficate into Firefox's Certificate Manager, Authorities tab.