X
點擊此處開啟此網站的行動版。

技術支援討論區

Secure connection failed error and certain websites without pictures after Mozilla refresh

已張貼

Hello all. I recently updated to windows 10 and had not been having any issues. However, today Mozilla suggested I "refresh" the browser to allow it to run faster. After doing so sites like facebook and twitter appear with no photos. Just links in random places, and sites like google give me an error message saying Secure Connection Failed (Error code: sec_error_bad_signature). I have windows firewall and have tried to troubleshoot the problem from there but I am unsure of what I am actually doing. Please help!!!!

Hello all. I recently updated to windows 10 and had not been having any issues. However, today Mozilla suggested I "refresh" the browser to allow it to run faster. After doing so sites like facebook and twitter appear with no photos. Just links in random places, and sites like google give me an error message saying Secure Connection Failed (Error code: sec_error_bad_signature). I have windows firewall and have tried to troubleshoot the problem from there but I am unsure of what I am actually doing. Please help!!!!

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36 Edge/12.10240

更多資訊

guigs 1072 個解決方法 11697 個答案

Hi jessboehme, There should be a Old Firefox Data folder on your desktop. This is created each time that you refresh Firefox. In there, there is also a certificate file. Profiles - Where Firefox stores your bookmarks, passwords and other user data or Recovering important data from an old profile

Hi jessboehme, There should be a Old Firefox Data folder on your desktop. This is created each time that you refresh Firefox. In there, there is also a certificate file. [[Profiles - Where Firefox stores your bookmarks, passwords and other user data]] or [[Recovering important data from an old profile]]
jscher2000
  • Top 10 Contributor
8783 個解決方法 71827 個答案

The most common reason for getting "sec_error_bad_signature" on numerous sites seems to be the Avast Web Shield. Web Shield intercepts your browsing and filters it, but to filter secure sites, it presents "fake" certificates to Firefox. Firefox may have previously been set to trust Avast to sign certificates (in the cert8.db file), but the Refresh would have cleared that trust.

To test this theory, try turning off scanning of encrypted sites. I saw these steps in another post:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok

If that resolves the issue, but you prefer to filter encrypted communications, you may need to import the Avast! signing certficate into Firefox's Certificate Manager, Authorities tab.

The most common reason for getting "sec_error_bad_signature" on numerous sites seems to be the Avast Web Shield. Web Shield intercepts your browsing and filters it, but to filter secure sites, it presents "fake" certificates to Firefox. Firefox may have previously been set to trust Avast to sign certificates (in the cert8.db file), but the Refresh would have cleared that trust. To test this theory, try turning off scanning of encrypted sites. I saw these steps in another post: #Open the Avast dashboard on the affected system. #Select Settings from the left sidebar menu. #Switch to Active Protection. #Click on Customize next to Web Shield. #Uncheck the "Enable HTTPS Scanning" option and click ok If that resolves the issue, but you prefer to filter encrypted communications, you may need to import the Avast! signing certficate into Firefox's Certificate Manager, Authorities tab.