搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable tab toggle feature by mouse scrolling?

  • 6 回覆
  • 4 有這個問題
  • 28 次檢視
  • 最近回覆由 cor-el

more options

After upgrading to Firefox 40.0.2, mouse scrolling behavior on tabs has changed. In this new browser, by scrolling on tab toggles the active tab to other neighboring tabs to be opened. In the previous version, scrolling on tabs does not change the active tab, it only slides tabs in the tab bar. How can I change the new behavior to the old one? I do not like to jump from the active tab to the others without clicking.

所有回覆 (6)

more options

Hi newbieeng , There are two add ons I have seen used, the old Firefox theme and tab mix plus. Those might be helpful work arounds.

more options

That should still work in Firefox 40.

Did you check your extensions?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

This is the closest about:config manipulation I can find. Does this work around still disable it for you?

more options

The browser.tabs.tabMinWidth and browser.tabs.tabMaxWidth pref haven't been supported for quite some time in Firefox releases, so that won't help.

If you scroll tabs by hovering the Tab bar and rotating the mouse wheel then this shouldn't have affect on the tab focus. If the focus changes then this is either a problem with the mouse or an extension or theme that supports this feature.

more options

Hi guys, Thank you for your replies, however, they did not help. Firstly, I tried to open the browser in safe mode with all add-ons are disabled. This does not change anything. Secondly, I opened the configuration windows but there is no preferences for "browser.tabs.tabMinWidth" and "browser.tabs.tabMaxWidth". The weird thing is I use the same web browser on my work desktop and personal laptop which they are fully synchronized over my account, however, I have this problem on my laptop, there is nothing on the desktop. I am 100% sure that there is no hardware issue, it is all relevant to software.

more options

Does this still happen with the default Windows mouse driver?

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that has effect.


Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then create a new profile.