X
點擊此處開啟此網站的行動版。

技術支援討論區

Can't play music files in Amazon (m3u)

已張貼

Windows 7 x64 Firefox 39.0.3

I've always managed to play music files in Amazon until either a recent Windows or Firefox update - don't know which came first. Regardless now as Amazon apparently use m3u files & I don't seem to have a plugin for them it keeps wanting me to download or save them etc, which isn't what I want to do with a few dozen I want to sample.

I have the VLC media and WMP plugins both set to always active & have rebooted Firefox numerous times while working through this issue, but presumably neither of these work for m3u files?? I've read more posts about somewhat similar issues but none of the various fixes have worked for me e.g. about:options plugins - True (not sure exactly which one it was I had to change) . I've downloaded & tried installing a "media pack" for Win 7 but that didn't work either.

Never had this problem until recently through multiple updates of both Windows &/or Firefox so a bit stumped as to what else to do. The only file types mentioned in Options are mp3/4/mpeg4/wmp.

Appreciate any ideas. Thanks.

Windows 7 x64 Firefox 39.0.3 I've always managed to play music files in Amazon until either a recent Windows or Firefox update - don't know which came first. Regardless now as Amazon apparently use m3u files & I don't seem to have a plugin for them it keeps wanting me to download or save them etc, which isn't what I want to do with a few dozen I want to sample. I have the VLC media and WMP plugins both set to always active & have rebooted Firefox numerous times while working through this issue, but presumably neither of these work for m3u files?? I've read more posts about somewhat similar issues but none of the various fixes have worked for me e.g. about:options plugins - True (not sure exactly which one it was I had to change) . I've downloaded & tried installing a "media pack" for Win 7 but that didn't work either. Never had this problem until recently through multiple updates of both Windows &/or Firefox so a bit stumped as to what else to do. The only file types mentioned in Options are mp3/4/mpeg4/wmp. Appreciate any ideas. Thanks.

被選擇的解決方法

Please update to the most recent version of Firefox:

The old work around had to do with an add on, try Firefox is Safe Mode to make sure its not an issue with an add on:

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Google Update
  • IE Tab Plug-in for Mozilla/Firefox
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.51.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Picasa plugin
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0
  • VLC media player Web Plugin
  • iTunes Detector Plug-in

應用程式

  • Firefox 39.0.3
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/39.0.3/WINNT/en-GB/

擴充套件

  • All-in-One Sidebar 0.7.26 ({097d3191-e6fa-4728-9826-b533d755359d})
  • ColorfulTabs 28.1 ({0545b830-f0aa-4d7e-8820-50a4629a56fe})
  • eBay Sidebar for Firefox 3.1.6.1-signed ({62760FD6-B943-48C9-AB09-F99C6FE96088})
  • eBay Toolbar 1.3.3.0043.1-signed ({249df6a2-e336-47d1-b6c3-ec711ad140ca})
  • Empty Cache Button 2.7.1-signed ({4cc4a13b-94a6-7568-370d-5f9de54a9c7f})
  • Flash and Video Download 1.74 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • Ghostery 5.4.6 (firefox@ghostery.com)
  • Give as you Live™ 4.0.5 (gayl_firefox@everyclick.com)
  • IE Tab + 2.04.20110724.1-signed (coralietab@mozdev.org)
  • IE Tab 2 (FF 3.6+) 5.12.12.1.1-signed ({1BC9BA34-1EED-42ca-A505-6D2F1A935BBB})
  • JS Switch 0.2.10.1-signed ({88c7b321-2eb8-11da-8cd6-0800200c9a66})
  • Memory Fox 7.4.1-signed ({E173B749-DB5B-4fd2-BA0E-94ECEA0CA55B})
  • Noia 4 Theme Manager 2.0.0 (Noia4Options@ArisT2)
  • Noia Fox options 3.0.2 (NoiaFoxoption@davidvincent.tld)
  • Pin It button 1.37.9 (jid1-YcMV6ngYmQRA2w@jetpack)
  • QuickJava 2.0.6.1-signed ({E6C1199F-E687-42da-8C24-E7770CC3AE66})
  • Quidco Cashback Reminder 2.0.21.1-signed (quidcotoolbar@quidco.com)
  • RoboForm Toolbar for Firefox 7.9.14.4 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • Session Manager 0.8.1.7 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Tab Auto Reload 1.0.17 (TabAutoReload@schuzak.jp)
  • Tab Mix Plus 0.4.1.8 ({dc572301-7619-498c-a57d-39143191b318})
  • Tabs on Bottom 0.5.1-signed (tabsonbottom@piro.sakura.ne.jp)
  • The Addon Bar (restored) 3.2.1-signed (the-addon-bar@GeekInTraining-GiT)
  • TooManyTabs 1.4.7.1-signed (TooManyTabs@visibotech.com)
  • Translate This! 3.0.2.1-signed (jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack)
  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)
  • Adblock Plus Pop-up Addon 0.9.2.1-signed (adblockpopups@jessehakanen.net) (Inactive)
  • Bitdefender Wallet 2.0 (bdwteff@bitdefender.com) (Inactive)
  • Classic Theme Restorer 1.3.7.1 (ClassicThemeRestorer@ArisT2Noia4dev) (Inactive)
  • Firebug 2.0.11 (firebug@software.joehewitt.com) (Inactive)
  • GlassMyFox 1.3.7 (GlassMyFox@ArisT2_Noia4dev) (Inactive)
  • Image and Flash Blocker 0.7.1-signed (imgflashblocker@shimon.chohen) (Inactive)
  • MaskMe 1.40.366.1-signed (idme@abine.com) (Inactive)
  • Media Hint 0.1.13.1 (mediahint@jetpack) (Inactive)
  • Open in IE 1.4.1-signed (openinie@wittersworld.com) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: NVIDIA GeForce GT 610
  • adapterDescription2:
  • adapterDeviceID: 0x104a
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 26193842
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 2-5-2015
  • driverDate2:
  • driverVersion: 9.18.13.4752
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 610 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 是
guigs 1072 個解決方法 11697 個答案

選擇的解決方法

Please update to the most recent version of Firefox:

The old work around had to do with an add on, try Firefox is Safe Mode to make sure its not an issue with an add on:

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Please update to the most recent version of Firefox: *[[Update Firefox to the latest version]] The old work around had to do with an add on, try Firefox is Safe Mode to make sure its not an issue with an add on: '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

提出問題者

You are AMAZING!!! Not just for providing me with the solution (I'd totally forgotten I'd recently added in a new graphics card, so turning off the Hardware Acceleration as outlined in the Troubleshooter was all I needed to do, but for the lengthy & superb info you've provided for me.

So many sometimes just put up 2 or 3 lines of suggestions, which is fine too, but I appreciate the extensive info especially with the 'walkthrough' for each section.

PERFECT!!!! Thanks you SO much - truly appreciated.

You are '''AMAZING'''!!! Not just for providing me with the solution (I'd totally forgotten I'd recently added in a new graphics card, so turning off the Hardware Acceleration as outlined in the Troubleshooter was all I needed to do, but for the lengthy & superb info you've provided for me. So many sometimes just put up 2 or 3 lines of suggestions, which is fine too, but I appreciate the extensive info especially with the 'walkthrough' for each section. PERFECT!!!! Thanks you SO much - truly appreciated.
jscher2000
  • Top 10 Contributor
8792 個解決方法 71899 個答案

Are these the little samples in the MP3 store, for example: http://www.amazon.com/Hotel-California-Eagles/dp/B00DAKW7Q2/ref=tmm_msc_swatch_0?_encoding=UTF8&qid=&sr=

(Perhaps not, as I didn't see any .m3u files loading)

For me, after adjusting NoScript to allow some sites I hadn't previously allowed, the MP3 samples played using the built-in HTML5 player.

Does your Firefox support MP3 in the native player? You can test on this site: http://hpr.dogphilosophy.net/test/

Are these the little samples in the MP3 store, for example: http://www.amazon.com/Hotel-California-Eagles/dp/B00DAKW7Q2/ref=tmm_msc_swatch_0?_encoding=UTF8&qid=&sr= ''(Perhaps not, as I didn't see any .m3u files loading)'' For me, after adjusting NoScript to allow some sites I hadn't previously allowed, the MP3 samples played using the built-in HTML5 player. Does your Firefox support MP3 in the native player? You can test on this site: http://hpr.dogphilosophy.net/test/

提出問題者

Yep it's the samples I was talking about - I always assumed they were just MP3 files but when the box came up asking me to download or save them, it listed them as M3U ones hence my confusion too.

But it's thankfully all sorted now & they're playing happily in FF as they should.

Thanks for your input & links etc.

Yep it's the samples I was talking about - I always assumed they were just MP3 files but when the box came up asking me to download or save them, it listed them as M3U ones hence my confusion too. But it's thankfully all sorted now & they're playing happily in FF as they should. Thanks for your input & links etc.
cfcentaurea 0 個解決方法 56 個答案

I have a similar problem. I tried safe mode but it still exists. When I try to play an amazon music clip from a list of songs, a dialog box opens asking me how I want to open it. I tried asking it to open in Firefox and got dozens and dozens of new tabs opening. When I finally got that to stop (and it took several closings and re-openings of FF to stop it), I changed it to open with Windows Media Player (which is not the best way to listen to 30 second audio clips). But even though I checked "Do this automatically from now on" and it is listed as the default for m3u files in Options, it continues to ask me every time. What's even weirder is that if I go to the individual song page and click on the play button, it plays fine. It's just in the lists that it doesn't work. Any suggestions? I have version 40.0.2 of FF, which I think is the latest.

I have a similar problem. I tried safe mode but it still exists. When I try to play an amazon music clip from a list of songs, a dialog box opens asking me how I want to open it. I tried asking it to open in Firefox and got dozens and dozens of new tabs opening. When I finally got that to stop (and it took several closings and re-openings of FF to stop it), I changed it to open with Windows Media Player (which is not the best way to listen to 30 second audio clips). But even though I checked "Do this automatically from now on" and it is listed as the default for m3u files in Options, it continues to ask me every time. What's even weirder is that if I go to the individual song page and click on the play button, it plays fine. It's just in the lists that it doesn't work. Any suggestions? I have version 40.0.2 of FF, which I think is the latest.
jscher2000
  • Top 10 Contributor
8792 個解決方法 71899 個答案

Hi cfcentaurea, could you give a link to a specific page where this problem occurs?

Hi cfcentaurea, could you give a link to a specific page where this problem occurs?
cfcentaurea 0 個解決方法 56 個答案

It's any page in digital music downloads where you get a playlist of songs, e.g., with search results. The urls are absurdly long, but you can get it by going to digital music http://www.amazon.com/MP3-Music-Download/b/ref=topnav_storetab_dmusic?ie=UTF8&node=163856011 and searching on any artist. On results page, scroll past the albums to the playlist of individual songs. Where there is a list, when I click on the play button it opens the dialog box (as in 2nd screenshot). Where there is just one song on the page (as in 3rd screenshot), it plays fine.

It's any page in digital music downloads where you get a playlist of songs, e.g., with search results. The urls are absurdly long, but you can get it by going to digital music http://www.amazon.com/MP3-Music-Download/b/ref=topnav_storetab_dmusic?ie=UTF8&node=163856011 and searching on any artist. On results page, scroll past the albums to the playlist of individual songs. Where there is a list, when I click on the play button it opens the dialog box (as in 2nd screenshot). Where there is just one song on the page (as in 3rd screenshot), it plays fine.
jscher2000
  • Top 10 Contributor
8792 個解決方法 71899 個答案

有幫助的回覆

Hi cfcentaurea, thank you for the explanation. I think I see the difference because if i block Flash on the page, I get the same behavior as you.

When Flash is allowed there is a "Play Samples" button above the list and when you play an individual tune, that centered player shows a pause button.

When Flash blocked, clicking a play button causes the site to serve an m3u file with this header:

Content-Type: audio/x-mpegurl

None of my plugins handle that content type, so I get prompted to download it.

Hi cfcentaurea, thank you for the explanation. I think I see the difference because if i block Flash on the page, I get the same behavior as you. When Flash is ''allowed'' there is a "Play Samples" button above the list and when you play an individual tune, that centered player shows a pause button. When Flash ''blocked'', clicking a play button causes the site to serve an m3u file with this header: Content-Type: audio/x-mpegurl None of my plugins handle that content type, so I get prompted to download it.
cfcentaurea 0 個解決方法 56 個答案

Thank you jscher2000, that worked! I had no idea what that little icon on the address bar meant, or why I would ever need to look at it.

But it brings up the question, what was blocking flash in the first place? I had turned off adblock, and had no other flash-blocking add-on set to block it. I looked at https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins and it says if flash is blocked I would see a message telling me I need to update. But I didn't get any message, AND my flash plugin is up to date and set to "Always Activate".

And why was it that I could play the song by clicking the play button on the individual song page, but not by clicking the play button by the song in the list? Seems like there must be a bug in there somewhere...

Thank you jscher2000, that worked! I had no idea what that little icon on the address bar meant, or why I would ever need to look at it. But it brings up the question, what was blocking flash in the first place? I had turned off adblock, and had no other flash-blocking add-on set to block it. I looked at https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins and it says if flash is blocked I would see a message telling me I need to update. But I didn't get any message, AND my flash plugin is up to date and set to "Always Activate". And why was it that I could play the song by clicking the play button on the individual song page, but not by clicking the play button by the song in the list? Seems like there must be a bug in there somewhere...
jscher2000
  • Top 10 Contributor
8792 個解決方法 71899 個答案

有幫助的回覆

cfcentaurea said

But it brings up the question, what was blocking flash in the first place? ... my flash plugin is up to date and set to "Always Activate".

It might be site-specific to Amazon. You can check it on the Permissions panel of the Page Info dialog. You can call that up using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address > More Information > Permissions

Near the top you'll see a permission for Adobe Flash which may have been changed from Use Default to Ask to Activate. Perhaps when some Flash on the site was being particularly annoying?

And why was it that I could play the song by clicking the play button on the individual song page, but not by clicking the play button by the song in the list? Seems like there must be a bug in there somewhere...

It may be that you only get the m3u when there is more than one to play. They could do a better job with the design if most people don't have a relevant plugin.

''cfcentaurea [[#answer-774310|said]]'' <blockquote> But it brings up the question, what was blocking flash in the first place? ... my flash plugin is up to date and set to "Always Activate".</blockquote> It might be site-specific to Amazon. You can check it on the Permissions panel of the Page Info dialog. You can call that up using any of these: * right-click a blank area of the page and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or globe icon to the left of the site address > More Information > Permissions Near the top you'll see a permission for Adobe Flash which may have been changed from Use Default to Ask to Activate. Perhaps when some Flash on the site was being particularly annoying? <blockquote>And why was it that I could play the song by clicking the play button on the individual song page, but not by clicking the play button by the song in the list? Seems like there must be a bug in there somewhere... </blockquote> It may be that you only get the m3u when there is more than one to play. They could do a better job with the design if most people don't have a relevant plugin.
cfcentaurea 0 個解決方法 56 個答案

You were right! The permissions for Flash on Amazon were set to "always ask". I changed it to "use default" and the center controls appeared.

But I'm pretty sure I didn't set that - I avoid changing individual settings for specific sites for the very reason that I'm afraid I will forget I changed them and then be baffled later when they don't work right. I didn't know about that permission tabs on site info, so I normally set adblock to filter everywhere or disable everywhere. If I want to block an individual annoyance, I use quickjava, where the setting icons are always clearly visible to me.

Is it possible that flash was blocked by mozilla at some time when flash was vulnerable, and after it was updated the setting was not automatically changed? Or would mozilla block it because I have it set not to do automatic updates?

The sample on the individual song page does appear to be m3u - I looked at the html code and this was the link for the sample button: <a class="a-link-normal" href="/gp/dmusic/media/sample.m3u/ref=dm_ws_tlw_smpl_nojs_trk1?ASIN=B003UPINCO&catalogItemType=track"></a>

Sure is complicated!

You were right! The permissions for Flash on Amazon were set to "always ask". I changed it to "use default" and the center controls appeared. But I'm pretty sure I didn't set that - I avoid changing individual settings for specific sites for the very reason that I'm afraid I will forget I changed them and then be baffled later when they don't work right. I didn't know about that permission tabs on site info, so I normally set adblock to filter everywhere or disable everywhere. If I want to block an individual annoyance, I use quickjava, where the setting icons are always clearly visible to me. Is it possible that flash was blocked by mozilla at some time when flash was vulnerable, and after it was updated the setting was not automatically changed? Or would mozilla block it because I have it set not to do automatic updates? The sample on the individual song page does appear to be m3u - I looked at the html code and this was the link for the sample button: <a class="a-link-normal" href="/gp/dmusic/media/sample.m3u/ref=dm_ws_tlw_smpl_nojs_trk1?ASIN=B003UPINCO&amp;catalogItemType=track"></a> Sure is complicated!
jscher2000
  • Top 10 Contributor
8792 個解決方法 71899 個答案

I don't think Firefox ever sets a site-specific block on its own, but perhaps the Continue Blocking button caused it?? Anyway, when in doubt about whether a plugin is working or blocked in a page, you can click the notification icon in the address bar to check (looks like a small Lego block).

I don't think Firefox ever sets a site-specific block on its own, but perhaps the Continue Blocking button caused it?? Anyway, when in doubt about whether a plugin is working or blocked in a page, you can click the notification icon in the address bar to check (looks like a small Lego block).
cfcentaurea 0 個解決方法 56 個答案

A mystery that will probably remain unsolved. Now that I know what that little icon is (it certainly does look like a Lego!) I'll check that first if I'm having plugin problems. Thanks for all your help!

A mystery that will probably remain unsolved. Now that I know what that little icon is (it certainly does look like a Lego!) I'll check that first if I'm having plugin problems. Thanks for all your help!