搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can no longer save any new bookmarks after updating to Firefox 40.0.2. I have more than 1000 bookmarks and also use xMarks.

  • 5 回覆
  • 11 有這個問題
  • 330 次檢視
  • 最近回覆由 FredMcD

more options

I can no longer save any new bookmarks after updating to Firefox 40.0.2. I have more than 1000 bookmarks and also use xMarks. I tried deleting 5 bookmarks, and saving a new bookmark, but it doesn't work. When I click the bookmark star, the star jumps into the bookmark folder, but doesn't save, and it doesn't offer me the option of filing it in the right subfolder, and the star is unfilled (it should be a filled star when the the website is bookmarked)

被選擇的解決方法

Thank you for your help. I tried places maintenance,without luck. I disabled xMarks, but it made no difference, I could not save any new bookmarks. I went to the help website above, and deleted the "places.sqlite" file, and recreated a new file, but it didn't work. I uninstalled Firefox completely using IOBit Uninstaller, and reinstalled it, but I found this program didn't delete the profile folder (Firefox used to have a checked box during uninstall, but it seems to be gone in recent versions). The problem persisted.

Finally, I took a screenshot of all my addons. Then, I uninstalled Firefox a second time, then deleted the entire Profiles folder (located as very usefully described in the second link above https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file I reinstalled Firefox, reinstalled xMarks and logged in and uploaded all my bookmarks, I reinstalled all my previous addons, and VIOLA - it now all works perfectly!

Thank you for your kind help

從原來的回覆中察看解決方案 👍 0

所有回覆 (5)

more options

Hi MichaelDGu,

Is it listed in all bookmarks? Also if you temporarily disable xmarks, does the blue star appear?

It might also be useful to make sure that the local places.sqlite file has not been corrupted, try this add on:

more options
more options

選擇的解決方法

Thank you for your help. I tried places maintenance,without luck. I disabled xMarks, but it made no difference, I could not save any new bookmarks. I went to the help website above, and deleted the "places.sqlite" file, and recreated a new file, but it didn't work. I uninstalled Firefox completely using IOBit Uninstaller, and reinstalled it, but I found this program didn't delete the profile folder (Firefox used to have a checked box during uninstall, but it seems to be gone in recent versions). The problem persisted.

Finally, I took a screenshot of all my addons. Then, I uninstalled Firefox a second time, then deleted the entire Profiles folder (located as very usefully described in the second link above https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file I reinstalled Firefox, reinstalled xMarks and logged in and uploaded all my bookmarks, I reinstalled all my previous addons, and VIOLA - it now all works perfectly!

Thank you for your kind help

more options

I tried these and they did not work for me. Anything else? Thanks Sherry Is there some way that I can just go back to 39.0.0?

more options

These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose.

OPIE {web link} Import/Export extension preferences