搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why are fonts not displaying correctly after upgrading to Firefox 40 (on Windows 7)?

  • 8 回覆
  • 1 有這個問題
  • 37 次檢視
  • 最近回覆由 jscher2000

more options

Hi, after (auto-)upgrading to Firefox 40 (on Windows 7, 64-bit), I notice that various fonts look different...in fact they look much worse. For example, button text using the Open Sans font looked great in all versions prior to FF 40, yet they now look thin and wispy starting with FF 40. What did you change and why? Is this a known bug? Can you please go back to the previous font rendering? (See uploaded before/after screen shot.)

NOTE: Unfortunately, my 6KB png file is not uploading properly (and I tried uploading it twice)!

Thank you, Marc

所有回覆 (8)

more options

Phew...I was able to upload my screen shot (png) now, only after submitting my question.

more options

I think Firefox is no longer using hardware acceleration for your fonts. In the Question Details > More System Details next to your post, the Graphics section indicates

  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedGfxCard']

Can you update your graphics card/chipset drivers? This article suggest safe places to check for updates if your OEM doesn't make it convenient to update: Upgrade your graphics drivers to use hardware acceleration and WebGL.

more options

I just (successfully) updated my Intel graphics adapter to the latest driver (5/26/2015), restarted my computer and Firefox still displays the poor quality fonts. I tried FF both with "Use hardware acceleration when available" enabled and with it disabled...no difference. I also tried setting webgl.disabled to true...again no difference in font quality.

more options

Hi marcd, if you check your support information page, Graphics section, does it still show "blocked" notes or direct2d disabled? You can open that page using either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

I was a little puzzled that in your initial post it had

adapterDescription: RDPDD Chained DD

When I search that, it seems to be somehow related to remote desktop/terminal services. If the support information page still shows that, perhaps that's the problem?

more options

Hi jscher2000,

Attached is a screen shot of the settings you requested. Note that 3 items, including the one you mentioned (Direct2D) display "Blocked for your graphics card because of unresolved driver issues." And now that you mention it, I *am* viewing this particular Firefox via Windows Remote Desktop, though it's never been an issue before...ever (for years). Do you have a suggestion that I can try re: Remote Desktop settings?

Thank you! Marc

由 marcd 於 修改

more options

Hmm, graphics drivers usually are blocked if enabling them causes crashes, so I'm not sure how strenuously to try to bypass that. Perhaps another volunteer could suggest a technique to use a different display driver on the remote system, although this might affect refresh rates over the wire.

more options

I haven't been able to view FF on my actual local machine yet (still using RDC), but co-workers *are* seeing the exact same issue on their local Windows machines.

more options

Do those system also indicate a blocked graphics card on the support information page? If not, there might be some other explanation.