X
點擊此處開啟此網站的行動版。

技術支援討論區

When I clink on a link in an email, how can I get Firefox not to open to my home page?

已張貼

When I clink on a link in an email, how can I get Firefox not to open to my home page and the link from my email? It always opens 2 pages. One is the link page and one is my homepage. It usually opens the homepage first. I close that page and the 'link' will open up. I really get tired of having to close the homepage before I can view the linked page. Thanks, cozzz

When I clink on a link in an email, how can I get Firefox not to open to my home page and the link from my email? It always opens 2 pages. One is the link page and one is my homepage. It usually opens the homepage first. I close that page and the 'link' will open up. I really get tired of having to close the homepage before I can view the linked page. Thanks, cozzz

被選擇的解決方法

Places Maintenance {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox.

Open the Add-ons Manager. Locate the add-on and press the Options button. Select All of the tests. Then press Execute on the bottom.


You may have corrupt sessionstore file(s).

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the sessionstore file(s). Then rename or delete them. Restart Firefox.


Separate Issue; Your System Details shows;

Installed Plug-ins

Garmin Communicator Plug-in Version 4.0.1.0 Garmin Communicator Plug-in Version 4.1.0.0
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.14
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Garmin Communicator Plug-in Version 4.0.1.0
  • Garmin Communicator Plug-in Version 4.1.0.0
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Logitech Harmony Browser Plug-In 1.2.0.2
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Office Live Update v1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.0
  • 5.1.30317.0
  • Unity Web Player version 4.5.0f6. (c) 2013 Unity Technologies ApS. All rights reserved.
  • iPhoto6

應用程式

  • Firefox 40.0
  • 使用者代理:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:40.0) Gecko/20100101 Firefox/40.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/40.0/Darwin/en-US/

擴充套件

  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AniWeather 0.8.50.1-signed ({4176DFF4-4698-11DE-BEEB-45DA55D89593})
  • Docs Online Viewer 4.2.8.1-signed ({bfb54675-2fd9-4e22-949d-c36333aff6b5})
  • DoNotTrackMe 2.2.9.812 (donottrackplus@abine.com)
  • Download Statusbar 0.9.10.1-signed ({D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389})
  • DownThemAll! 2.0.18.1-signed ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Flash Video Downloader - YouTube HD Downloader [4K] 7.3.1.1-signed (artur.dubovoy@gmail.com)
  • FlashGot 1.5.6.12.1-signed ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • Garmin Communicator 4.1.0.1-signed ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • MaskMe 1.39.345 (idme@abine.com)
  • PDF Viewer 1.0.277.1-signed (uriloader@pdf.js)
  • Video DownloadHelper 5.3.1.1-signed ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Ebay Shopping Assistant by Spigot 2.2 ({A92BC493-FA5B-40a5-AFC8-6672926C9544}) (Inactive)
  • Searchme 2.6 (searchme@mybrowserbar.com) (Inactive)
  • Slick Savings 3.7 ({84977DE9-1026-4508-B9A7-9116BDAAB098}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription:
  • adapterDeviceID: 0x9583
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 2600 PRO OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
firefoxbob2 17 個解決方法 109 個答案

Hi cozzz, I can understand that it would get very tiring to do that every time a link is supposed to open in a new tab. The good news is that I am here to help.

You did not specify if the 2 pages are opening in a new window or if they are opening in the window that you already had open. For this reply I am going to assume that they are opening in a new window.

The way to go about fixing this is to click on the three horizontal lines in the top right, then click on options. Next you will want to open General if that is not what is showing. Near the bottom of the general page it will have "Tabs" in bold. Under that it will have an option "Open new windows in a new tab instead". You will want to click that box so it has a check mark in it. Then close the Options tab and check to see if this fixed the problem for you.

I hope this works for you. If you have any question, need any additional help or if this doesn't fix the problem for you please feel free to contact me.

Hi cozzz, I can understand that it would get very tiring to do that every time a link is supposed to open in a new tab. The good news is that I am here to help. You did not specify if the 2 pages are opening in a new window or if they are opening in the window that you already had open. For this reply I am going to assume that they are opening in a new window. The way to go about fixing this is to click on the three horizontal lines in the top right, then click on options. Next you will want to open General if that is not what is showing. Near the bottom of the general page it will have "Tabs" in bold. Under that it will have an option "Open new windows in a new tab instead". You will want to click that box so it has a check mark in it. Then close the Options tab and check to see if this fixed the problem for you. I hope this works for you. If you have any question, need any additional help or if this doesn't fix the problem for you please feel free to contact me.
jscher2000
  • Top 10 Contributor
8839 個解決方法 72253 個答案

When this happens, what is the state of Firefox?

  • Completely closed
  • Running, but hidden in the dock
  • Running, with at least one window visible

We did have some threads about dock-related issues opening links during the past year, but unfortunately, as a Windows user, they went over my head.

When this happens, what is the state of Firefox? * Completely closed * Running, but hidden in the dock * Running, with at least one window visible We did have some threads about dock-related issues opening links during the past year, but unfortunately, as a Windows user, they went over my head.

提出問題者

Firefox is completely closed. If it is open and minimized the link in the email will load without any problems.

Firefox is completely closed. If it is open and minimized the link in the email will load without any problems.

提出問題者

firefoxbob2 said

Hi cozzz, I can understand that it would get very tiring to do that every time a link is supposed to open in a new tab. The good news is that I am here to help. You did not specify if the 2 pages are opening in a new window or if they are opening in the window that you already had open. For this reply I am going to assume that they are opening in a new window. The way to go about fixing this is to click on the three horizontal lines in the top right, then click on options. Next you will want to open General if that is not what is showing. Near the bottom of the general page it will have "Tabs" in bold. Under that it will have an option "Open new windows in a new tab instead". You will want to click that box so it has a check mark in it. Then close the Options tab and check to see if this fixed the problem for you. I hope this works for you. If you have any question, need any additional help or if this doesn't fix the problem for you please feel free to contact me.

didn't work... I forgot to mention that I'm on a Mac.

''firefoxbob2 [[#answer-765999|said]]'' <blockquote> Hi cozzz, I can understand that it would get very tiring to do that every time a link is supposed to open in a new tab. The good news is that I am here to help. You did not specify if the 2 pages are opening in a new window or if they are opening in the window that you already had open. For this reply I am going to assume that they are opening in a new window. The way to go about fixing this is to click on the three horizontal lines in the top right, then click on options. Next you will want to open General if that is not what is showing. Near the bottom of the general page it will have "Tabs" in bold. Under that it will have an option "Open new windows in a new tab instead". You will want to click that box so it has a check mark in it. Then close the Options tab and check to see if this fixed the problem for you. I hope this works for you. If you have any question, need any additional help or if this doesn't fix the problem for you please feel free to contact me. </blockquote> didn't work... I forgot to mention that I'm on a Mac.
firefoxbob2 17 個解決方法 109 個答案

Thank you for that extra information. As a Windows user myself I may not be the most qualified person to help you with this. However I will never the less keep looking for the answer.

Thank you for that extra information. As a Windows user myself I may not be the most qualified person to help you with this. However I will never the less keep looking for the answer.
firefoxbob2 17 個解決方法 109 個答案

Hi cozzz, I am still looking into the problem. I have taken the step of escalating this question. This means that it will get investigated more by more people. Please understand that escalations can take up to 72 hours for a response, but no longer.

Hi cozzz, I am still looking into the problem. I have taken the step of escalating this question. This means that it will get investigated more by more people. Please understand that escalations can take up to 72 hours for a response, but no longer.
pm11 0 個解決方法 2 個答案

Hi. First post and I seem to have the same problem on my macbook air using the 'mail' programme. It took me a while to figure out that the page I was looking for was behind my home page.

Hi. First post and I seem to have the same problem on my macbook air using the 'mail' programme. It took me a while to figure out that the page I was looking for was behind my home page.
FredMcD
  • Top 10 Contributor
4314 個解決方法 60603 個答案

選擇的解決方法

Places Maintenance {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox.

Open the Add-ons Manager. Locate the add-on and press the Options button. Select All of the tests. Then press Execute on the bottom.


You may have corrupt sessionstore file(s).

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the sessionstore file(s). Then rename or delete them. Restart Firefox.


Separate Issue; Your System Details shows;

Installed Plug-ins

Garmin Communicator Plug-in Version 4.0.1.0 Garmin Communicator Plug-in Version 4.1.0.0
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

'''[https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/ Places Maintenance]''' {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox. Open the Add-ons Manager. Locate the add-on and press the '''Options''' button. Select All of the tests. Then press '''Execute''' on the bottom. --------------------- You may have corrupt '''sessionstore''' file(s). Type '''about:support''' in the address bar and press enter. Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the '''sessionstore''' file(s). Then rename or delete them. Restart Firefox. --------------------- Separate Issue; Your System Details shows; Installed Plug-ins Garmin Communicator Plug-in Version 4.0.1.0 Garmin Communicator Plug-in Version 4.1.0.0 <br>Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.