X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox crashing repeatedly in Windows 8.1

已張貼

I've tried removing all settings and add-ons, and reinstalling Firefox after deleting all data.

I mostly crash when I'm on Tumblr (both with XKit installed and with it removed), particularly on the Likes page.

Last reports:

bp-d0617a9d-d2b0-4658-b2c6-803ec2150811 bp-7ed575cd-184b-47b9-967c-3f4f52150811 bp-91091e91-c2aa-4f70-b63f-9f9c32150811 bp-184644dd-dfa9-4f78-9b77-f23192150810 bp-d8b6519e-750b-412f-abdd-c99dc2150810 bp-845c7bd1-16f1-4120-8803-b3f852150809 bp-6f9fedac-b327-46bb-b907-746732150808 bp-2f84cade-a198-44a5-bafc-d29152150807 bp-9cbc2c24-536a-4e8d-9ff2-cb1962150806

I've tried removing all settings and add-ons, and reinstalling Firefox after deleting all data. I mostly crash when I'm on Tumblr (both with XKit installed and with it removed), particularly on the Likes page. Last reports: bp-d0617a9d-d2b0-4658-b2c6-803ec2150811 bp-7ed575cd-184b-47b9-967c-3f4f52150811 bp-91091e91-c2aa-4f70-b63f-9f9c32150811 bp-184644dd-dfa9-4f78-9b77-f23192150810 bp-d8b6519e-750b-412f-abdd-c99dc2150810 bp-845c7bd1-16f1-4120-8803-b3f852150809 bp-6f9fedac-b327-46bb-b907-746732150808 bp-2f84cade-a198-44a5-bafc-d29152150807 bp-9cbc2c24-536a-4e8d-9ff2-cb1962150806

額外的系統細節

已安裝的外掛程式

  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Shockwave Flash 18.0 r0
  • Shockwave Flash 16.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • Plugin for Wacom tablets.

應用程式

  • Firefox 39.0.3
  • 使用者代理:Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/39.0.3/WINNT/en-US/

擴充套件

  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Webroot Filtering Extension 1.1.0.59 (webrootsecure@webroot.com)
  • XKit 7.4.5 (xkit@studioxenix.com)
  • HP SimplePass 1.0 (firefox@bho.com) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel(R) HD Graphics 5500
  • adapterDescription2: NVIDIA GeForce 840M
  • adapterDeviceID: 0x1616
  • adapterDeviceID2: 0x1341
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 229d103c
  • adapterSubsysID2: 229d103c
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.3.9600.17795
  • driverDate: 9-29-2014
  • driverDate2: 9-26-2014
  • driverVersion: 10.18.10.3960
  • driverVersion2: 9.18.13.4424
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 5500 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 是
guigs 1072 個解決方法 11697 個答案

The first listed crash is related to a bug that has to do with a null pointer and is still being troubleshooted. The OOM is an out of memory signature that sometimes can be managed with these troubleshooting tips:

Another was gfx layers crash. you can try to disable hardware acceleration. This would relate to the tumblr page since gfx is graphics rendering. =

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

The first listed crash is related to a bug that has to do with a null pointer and is still being troubleshooted. The OOM is an out of memory signature that sometimes can be managed with these troubleshooting tips: *[[Firefox uses too much memory (RAM) - How to fix]] Another was gfx layers crash. you can try to disable hardware acceleration. This would relate to the tumblr page since gfx is graphics rendering. = Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Click the menu button [[Image:New Fx Menu]] and select ''Options'' on Windows or ''Preferences'' on Mac or Linux. #Select the ''Advanced'' panel and then the ''General'' tab. #Uncheck '''Use hardware acceleration when available'''. #Restart Firefox and see if the problems persist. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.

提出問題者

Hello, thank you for the suggestions.

I read through the RAM link, and I'm reinstalling NoScript. Will test to see if this helps any. I was also having a problem where loading a page in FireFox would make the computer unresponsive for upwards of one minute, perhaps that was related and this could help?

"Use hardware acceleration when available" was already unchecked.

Graphics drivers are all up to date, and were up to date at the time of the problems (saw the suggestion on a similar thread and did checks to make sure).

Hello, thank you for the suggestions. I read through the RAM link, and I'm reinstalling NoScript. Will test to see if this helps any. I was also having a problem where loading a page in FireFox would make the computer unresponsive for upwards of one minute, perhaps that was related and this could help? "Use hardware acceleration when available" was already unchecked. Graphics drivers are all up to date, and were up to date at the time of the problems (saw the suggestion on a similar thread and did checks to make sure).
guigs 1072 個解決方法 11697 個答案

Yes, since it takes a while for a page to load, I am suspicious of the cache.

"Clear the Cache": Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems: Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" source: corel

Yes, since it takes a while for a page to load, I am suspicious of the cache. "Clear the Cache": Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" source: corel

提出問題者

Cleared cache recently and just did it again.

NoScript is running, and the crashing has started again when browsing Tumblr (specifically the Likes page).

Cleared cache recently and just did it again. NoScript is running, and the crashing has started again when browsing Tumblr (specifically the Likes page).
SHOBLE THOMAS 13 個解決方法 184 個答案

Start Firefox in Safe Mode {web Link} by holding down the <Shift> (Mac Options) key, and then starting Firefox. Is the problem still there?

While in Safe Mode;

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers, click it and select Submit.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

If you can't get Firefox to open, you will have to do this the hard way. https://support.mozilla.org/en-US/kb/mozillacrashreporter Open the file browser / explorer on your computer. Note: You may have to enable Show Hidden Folders / Files. Enter this in the address bar;

Windows: %APPDATA%\Mozilla\Firefox\Crash Reports\submitted Win 7/Vista: C:\Users\<username>\AppData\Roaming\Mozilla\Firefox\Crash Reports\submitted Win XP/2000: C:\Documents and Settings\<username>\Application Data\Mozilla\Firefox\Crash Reports\submitted

Mac OS: /Users/<username>/Library/Application Support/Firefox/Crash Reports/submitted Linux: /home/<username>/.mozilla/firefox/Crash Reports/submitted

Copy the last 5-7 Recent File Names in the folder. Post the information in the reply box below.

Start Firefox in Safe Mode {web Link} by holding down the <Shift> (Mac Options) key, and then starting Firefox. Is the problem still there? While in Safe Mode; In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers, click it and select Submit. Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in. If you can't get Firefox to open, you will have to do this the hard way. https://support.mozilla.org/en-US/kb/mozillacrashreporter Open the file browser / explorer on your computer. Note: You may have to enable Show Hidden Folders / Files. Enter this in the address bar; Windows: %APPDATA%\Mozilla\Firefox\Crash Reports\submitted Win 7/Vista: C:\Users\<username>\AppData\Roaming\Mozilla\Firefox\Crash Reports\submitted Win XP/2000: C:\Documents and Settings\<username>\Application Data\Mozilla\Firefox\Crash Reports\submitted Mac OS: /Users/<username>/Library/Application Support/Firefox/Crash Reports/submitted Linux: /home/<username>/.mozilla/firefox/Crash Reports/submitted Copy the last 5-7 Recent File Names in the folder. Post the information in the reply box below.
SHOBLE THOMAS 13 個解決方法 184 個答案

recent versions of Firefox are monitoring the shutdown time and reporting "shutdown hang" as a new kind of crash. If you look at the reports (you can click the links on the about:crashes page to observe how they are described on the crash stats server) are they shutdown hang crashes, or something else?

Since the causes of crashes can be very individual, you might want to start a new thread on these:

https://support.mozilla.org/questions/new/desktop/fix-problems

Keep scrolling down past the suggested articles/threads if they do not sound directly on point.

Go ahead and include links to the most recent crash reports.

recent versions of Firefox are monitoring the shutdown time and reporting "shutdown hang" as a new kind of crash. If you look at the reports (you can click the links on the about:crashes page to observe how they are described on the crash stats server) are they shutdown hang crashes, or something else? Since the causes of crashes can be very individual, you might want to start a new thread on these: https://support.mozilla.org/questions/new/desktop/fix-problems Keep scrolling down past the suggested articles/threads if they do not sound directly on point. Go ahead and include links to the most recent crash reports.

提出問題者

bp-c9ad4839-cfc1-4d2a-85b0-7b7fb2150815

Latest crash link.

bp-c9ad4839-cfc1-4d2a-85b0-7b7fb2150815 Latest crash link.
guigs 1072 個解決方法 11697 個答案

There were some crashes with the latest web root security in another thread that I noticed you have installed. If you toggle this does it continue to crash?

However this latest crash is a graphics related crash:

  • (Bug 1194775 - Crash in mozilla::layers::BorrowDrawTarget::ReturnDrawTarget() EXCEPTION_ACCESS_VIOLATION_READ)

Try to disable hardware acceleration if a graphics update check does not resolve this:

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

There were some crashes with the latest web root security in another thread that I noticed you have installed. If you toggle this does it continue to crash? However this latest crash is a graphics related crash: * (Bug 1194775 - Crash in mozilla::layers::BorrowDrawTarget::ReturnDrawTarget() EXCEPTION_ACCESS_VIOLATION_READ) Try to disable hardware acceleration if a graphics update check does not resolve this: Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Click the menu button [[Image:New Fx Menu]] and select ''Options'' on Windows or ''Preferences'' on Mac or Linux. #Select the ''Advanced'' panel and then the ''General'' tab. #Uncheck '''Use hardware acceleration when available'''. #Restart Firefox and see if the problems persist. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.

提出問題者

Hardware acceleration has been disabled for a while now. There are no updates for my graphics driver.

I will try disabling the Webroot extension and will update if it crashes again.

Hardware acceleration has been disabled for a while now. There are no updates for my graphics driver. I will try disabling the Webroot extension and will update if it crashes again.