搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Windows 10 Family Safety website not loading in Firefox

  • 5 回覆
  • 5 有這個問題
  • 831 次檢視
  • 最近回覆由 bluezed

more options

I've just upgraded to Windows 10 and while trying to set up the parental controls I came across this issue.

When I open the Family website and try to look at the details for one of the kids in Firefox 39.0.3 the page just sits there saying "Loading..." indefinitely.

In Microsoft Edge it loads the data instantly.

See attached screenshots...

I tried disabling uBlock Origin which I have always running but that didn't make a difference... Has Microsoft done something to prevent us from using Firefox for these pages!?

Thanks a lot Thomas

附加的畫面擷圖

被選擇的解決方法

Thanks for that but what you're describing is how to make Firefox use the correct certificates and that's nothing to do with the issue I've reported here.

Anyway... I just tried the site again and it's working now! So I assume Microsoft fixed the issue on their end :)

從原來的回覆中察看解決方案 👍 0

所有回覆 (5)

more options

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Thanks for that but I'm afraid these suggestions make no difference.

My guess is that Microsoft put something on that page that just doesn't work with Firefox at the moment.

I've tried on 4 different Windows 10 machines now and all have the same issue on that page.

If I open the page with Firebug running the log shows some errors that I've uploaded here: https://paste.ee/p/pfZH9

Maybe that helps narrow it down?

more options

This is still an issue with the latest Firefox 40.0.2 :(

btw... those pages work fine in Chrome 44 too.

more options

The issue is is that there is a filter proxy setup on the computer that checks all browsing activity to fulfill the protection service. Chrome works because it reads the certificates from Windows directly were as Firefox keeps it's own separate database of certificates. The basic steps are to export the Microsoft Family Security certificate from Windows and import it into Firefox.

The detailed steps to resolve this in Firefox are:

  1. Click start and type mmc and click the button with red toolbox, to open the Console
  2. Click File Add or Remove Snap-ins
  3. Choose Certificates from the available snap-ins and click Add>
  4. Manage certificates for: "My user account" and click Finish and OK
  5. Expand and select Trusted Root Certification Authorities > Certificates
  6. Look in the middle pane Microsoft Family Safety
  7. Right click the certificate then click on: All Tasks > "Export..."
  8. Click Next
  9. Leave the No... selected and click Next
  10. Leave DER... selected and click Next
  11. Browse and enter a desired name. You will use it to import the certificate into Firefox
  12. Click Next and Finish
  13. Open options in Firefox and go to the Advanced section
  14. Select the Certificates section and click the "View Certificates" button
  15. Select the Authorities tab
  16. Click "Import..."
  17. Chose the certificate we exported earlier and click Open
  18. Click OK and Close the Settings
  19. Try opening https://www.google.com/ and you should be good to go.

I suspect mozilla will need to start searching for the certificate and import it on installation or when the cert8.db file is created.

由 kensela 於 修改

more options

選擇的解決方法

Thanks for that but what you're describing is how to make Firefox use the correct certificates and that's nothing to do with the issue I've reported here.

Anyway... I just tried the site again and it's working now! So I assume Microsoft fixed the issue on their end :)