X
點擊此處開啟此網站的行動版。

技術支援討論區

I started with an sec_error_unknown_issuer and now have an sec_error_bad_signature after upgrading to Windows 10.

已張貼

I upgraded to Windows 10 from Windows 8.1 last night. I tried connecting to facebook a few hours ago and find I can't get in. The error is, "This Connection is Untrusted", with, "This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate".

I've browsed the help forums, and have learned this is because I have Family Safety active and am trying to access the accounts on a "Child" account. One suggested fix is to disable Family Safety; that is not an option. I absolutely must have Family Safety for my laptop.

This thread proves greatly helpful: https://support.mozilla.org/en-US/questions/1075301. I did the first answer philipp suggested, "Trust this CA to identify web sites", and I have confirmed this change.

Now whenever I try to access Facebook, Google, Yahoo, Youtube, etc., I get this: An error occurred during a connection to www.yahoo.com. Peer's certificate has an invalid signature. (Error code: sec_error_bad_signature)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

I've ran out of ideas. I went back to the helpful thread and tried the next thing philipp suggested: going to the webpage, "https://support.microsoft.com/en-us/kb/2965142", and then clicking the, "known issues for Mozilla Firefox users" link. The problem with that is the instructions seem to be written for a touchscreen enabled device; I don't have a touchscreen device, I have a gaming laptop with no touchscreen.

I know it's a lot of information, but I would really appreciate anyone's help in my struggle to be able to access those sites without asking my mom to get on her administrator account when I want to access those websites.

I upgraded to Windows 10 from Windows 8.1 last night. I tried connecting to facebook a few hours ago and find I can't get in. The error is, "This Connection is Untrusted", with, "This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate". I've browsed the help forums, and have learned this is because I have Family Safety active and am trying to access the accounts on a "Child" account. One suggested fix is to disable Family Safety; that is not an option. I absolutely must have Family Safety for my laptop. This thread proves greatly helpful: https://support.mozilla.org/en-US/questions/1075301. I did the first answer philipp suggested, "Trust this CA to identify web sites", and I have confirmed this change. Now whenever I try to access Facebook, Google, Yahoo, Youtube, etc., I get this: An error occurred during a connection to www.yahoo.com. Peer's certificate has an invalid signature. (Error code: sec_error_bad_signature) The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. I've ran out of ideas. I went back to the helpful thread and tried the next thing philipp suggested: going to the webpage, "https://support.microsoft.com/en-us/kb/2965142", and then clicking the, "known issues for Mozilla Firefox users" link. The problem with that is the instructions seem to be written for a touchscreen enabled device; I don't have a touchscreen device, I have a gaming laptop with no touchscreen. I know it's a lot of information, but I would really appreciate anyone's help in my struggle to be able to access those sites without asking my mom to get on her administrator account when I want to access those websites.

被選擇的解決方法

in case you want to use family protections by intention, you'd need to some configuration for it to work in firefox, and install the certificate of ms family safety that is getting used to intercept secure connections into the browser's trust store: while in firefox, click on this link - then a dialog about adding a cert should display. please check the box to Trust this CA to identify web sites & confirm the change.

alternatively you could also try the manual steps described at https://support.microsoft.com/en-us/kb/2965142 in the section about firefox.

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • PlayNow Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • Shockwave Flash 18.0 r0
  • Shockwave Flash 16.0 r0
  • 5.1.40416.0
  • Unity Player 5.0.3f2

應用程式

  • Firefox 39.0.3
  • 使用者代理:Mozilla/5.0 (Windows NT 10.0; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/39.0.3/WINNT/en-US/

擴充套件

  • Norton Toolbar 2015.5.2.16 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • Skype Click to Call 7.4.0.9058 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel(R) HD Graphics 4600
  • adapterDescription2: NVIDIA GeForce 840M
  • adapterDeviceID: 0x0416
  • adapterDeviceID2: 0x1341
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 11131462
  • adapterSubsysID2: 11131462
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16390
  • driverDate: 7-17-2015
  • driverDate2: 7-22-2015
  • driverVersion: 10.18.15.4256
  • driverVersion2: 10.18.13.5362
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
philipp
  • Top 25 Contributor
  • Moderator
5321 個解決方法 23502 個答案

有幫助的回覆

hi, in case you're an avast user, please disable https scanning within avast:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok.

http://www.ghacks.net/2014/10/31/avasts-https-scanning-interferes-with-firefox-and-other-programs/

hi, in case you're an avast user, please disable https scanning within avast: #Open the Avast dashboard on the affected system. #Select Settings from the left sidebar menu. #Switch to Active Protection. #Click on Customize next to Web Shield. #Uncheck the "Enable HTTPS Scanning" option and click ok. http://www.ghacks.net/2014/10/31/avasts-https-scanning-interferes-with-firefox-and-other-programs/

提出問題者

I don't have Avast Security, I use Norton 360 Premier Edition.

I don't have Avast Security, I use Norton 360 Premier Edition.
philipp
  • Top 25 Contributor
  • Moderator
5321 個解決方法 23502 個答案

this might also be happening in accounts restricted by microsoft family parental controls. you could turn that off for your account like described at: http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

this might also be happening in accounts restricted by microsoft family parental controls. you could turn that off for your account like described at: http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings

提出問題者

I thank you twice for replying and being helpful philipp. I need Family Safety. Here's some background:

I'm a twenty-something, and I have had very limited control when it comes to computer usage for a number of years. That, and with a large amount of available idle hours, could and has driven me to have dis-regulated computer usage. Several times I've stayed up all night playing games or watching videos and movies. So, for a number of years I have used the Family Safety curfew settings in a reasonably successful attempt to make me go to bed early and wake up early every day.

I see myself needing those curfew settings for many months or even years to come.

I thank you twice for replying and being helpful philipp. I need Family Safety. Here's some background: I'm a twenty-something, and I have had very limited control when it comes to computer usage for a number of years. That, and with a large amount of available idle hours, could and has driven me to have dis-regulated computer usage. Several times I've stayed up all night playing games or watching videos and movies. So, for a number of years I have used the Family Safety curfew settings in a reasonably successful attempt to make me go to bed early and wake up early every day. I see myself needing those curfew settings for many months or even years to come.

由 Yuril 於 修改

philipp
  • Top 25 Contributor
  • Moderator
5321 個解決方法 23502 個答案

選擇的解決方法

in case you want to use family protections by intention, you'd need to some configuration for it to work in firefox, and install the certificate of ms family safety that is getting used to intercept secure connections into the browser's trust store: while in firefox, click on this link - then a dialog about adding a cert should display. please check the box to Trust this CA to identify web sites & confirm the change.

alternatively you could also try the manual steps described at https://support.microsoft.com/en-us/kb/2965142 in the section about firefox.

in case you want to use family protections by intention, you'd need to some configuration for it to work in firefox, and install the certificate of ms family safety that is getting used to intercept secure connections into the browser's trust store: while in firefox, click on '''[http://tinyurl.com/purlf29 this link]''' - then a dialog about adding a cert should display. please check the box to '''Trust this CA to identify web sites''' & confirm the change. alternatively you could also try the manual steps described at https://support.microsoft.com/en-us/kb/2965142 in the section about firefox.

有幫助的回覆

Thank you philipp for your response. I had already tried the first link in your answer, and that is how I went from the original error to the new error. After a fair amount of research and tinkering, the second link is what finally made me able to access facebook, google, yahoo, and youtube. The second link instructions are for Windows 8 with a touchscreen laptop--I'm running Windows 10, no touchscreen laptop. My research is what allowed me to adapt the instructions, as the "Charms" feature has been replaced in Windows 10. Thank you very much!

Thank you philipp for your response. I had already tried the first link in your answer, and that is how I went from the original error to the new error. After a fair amount of research and tinkering, the second link is what finally made me able to access facebook, google, yahoo, and youtube. The second link instructions are for Windows 8 with a touchscreen laptop--I'm running Windows 10, no touchscreen laptop. My research is what allowed me to adapt the instructions, as the "Charms" feature has been replaced in Windows 10. Thank you very much!