X
點擊此處開啟此網站的行動版。

技術支援討論區

Pop-up pages don't open even when I want them to

已張貼

Hey everyone,

Let's say that I am trying to login to my bank's online banking site. As you know, usually you enter your login credentials in a new window separate from the home page. Unfortunately, that page doesn't open in Firefox yet it does in Chrome. When I hover my mouse cursor on the link which I want Firefox to open, all I see is javascript:void(0) and nothing happens. This problem also occurs on my GSM operator's page, too.

I tried starting the Firefox in safe mode and the problem wasn't there anymore. In order to find the culprit, I disabled every extension, plug-in and hardware acceleration but after the restart (while all are still disabled), problem was still there.

I don't want to refresh Firefox and lose every setting. Is there any other way?

I don't want to switch browsers, I am a fan of open-source software.

Thanks :)

PS: I have a Win7 64bit system. Every plug-in and extension are updated.

Hey everyone, Let's say that I am trying to login to my bank's online banking site. As you know, usually you enter your login credentials in a new window separate from the home page. Unfortunately, that page doesn't open in Firefox yet it does in Chrome. When I hover my mouse cursor on the link which I want Firefox to open, all I see is javascript:void(0) and nothing happens. This problem also occurs on my GSM operator's page, too. I tried starting the Firefox in safe mode and the problem wasn't there anymore. In order to find the culprit, I disabled every extension, plug-in and hardware acceleration but after the restart (while all are still disabled), problem was still there. I don't want to refresh Firefox and lose every setting. Is there any other way? I don't want to switch browsers, I am a fan of open-source software. Thanks :) PS: I have a Win7 64bit system. Every plug-in and extension are updated.

額外的系統細節

已安裝的外掛程式

  • Next Generation Java Plug-in 11.51.2 for Mozilla browsers
  • Shockwave Flash 18.0 r0
  • Shockwave Flash 17.0 r0
  • 5.1.40416.0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0

更多資訊

jscher2000
  • Top 10 Contributor
8775 個解決方法 71729 個答案

I'm out of ideas. Can you give links to pages that have this problem?

I'm out of ideas. Can you give links to pages that have this problem?

提出問題者

jscher2000 said

I'm out of ideas. Can you give links to pages that have this problem?

http://www.avea.com.tr/web/

You'll see that on the right hand upper corner, there is button called "Online Islemler". That button is supposed open a new window.

''jscher2000 [[#answer-761693|said]]'' <blockquote> I'm out of ideas. Can you give links to pages that have this problem? </blockquote> http://www.avea.com.tr/web/ You'll see that on the right hand upper corner, there is button called "Online Islemler". That button is supposed open a new window.
jscher2000
  • Top 10 Contributor
8775 個解決方法 71729 個答案

ohfirefox said

http://www.avea.com.tr/web/ You'll see that on the right hand upper corner, there is button called "Online Islemler". That button is supposed open a new window.

Yes, that button fails for me. The Browser Console shows this error:

ReferenceError: _gat is not defined

I use NoScript and block scripts from googletagmanager.com and for whatever reason, the script attached to the button requires me to allow that script because the function run by the button is in that script:

onclick=googleAnalyticsEvent('Online-Islemler','MenuBtn','/web/', 'http://www.avea.com.tr/mps/portal?cmd=onlineTransactionsHome&lang=tr&tb=redTab', '700'); return false;

So something in your Firefox seems to be blocking that script in regular mode but not in Safe Mode. Most often it is an extension, but... you already checked those. Hmm...

''ohfirefox [[#answer-761881|said]]'' <blockquote> http://www.avea.com.tr/web/ You'll see that on the right hand upper corner, there is button called "Online Islemler". That button is supposed open a new window. </blockquote> Yes, that button fails for me. The Browser Console shows this error: ReferenceError: _gat is not defined I use NoScript and block scripts from googletagmanager.com and for whatever reason, the script attached to the button requires me to allow that script because the function run by the button is in that script: onclick=googleAnalyticsEvent('Online-Islemler','MenuBtn','/web/', 'http://www.avea.com.tr/mps/portal?cmd=onlineTransactionsHome&lang=tr&tb=redTab', '700'); return false; So something in your Firefox seems to be blocking that script in regular mode but not in Safe Mode. Most often it is an extension, but... you already checked those. Hmm...

提出問題者

jscher2000 said

ohfirefox said
http://www.avea.com.tr/web/ You'll see that on the right hand upper corner, there is button called "Online Islemler". That button is supposed open a new window.

Yes, that button fails for me. The Browser Console shows this error:

ReferenceError: _gat is not defined

I use NoScript and block scripts from googletagmanager.com and for whatever reason, the script attached to the button requires me to allow that script because the function run by the button is in that script:

onclick=googleAnalyticsEvent('Online-Islemler','MenuBtn','/web/', 'http://www.avea.com.tr/mps/portal?cmd=onlineTransactionsHome&lang=tr&tb=redTab', '700'); return false;

So something in your Firefox seems to be blocking that script in regular mode but not in Safe Mode. Most often it is an extension, but... you already checked those. Hmm...

I have just deleted all my extensions and tried it again. Nope, still not working.

It's weird, right?

So Safe Mode disables some other stuff in Firefox besides extensions and themes. Whatever that "some other stuff" is that is causing the problem I guess.

Thank you for your efforts jscher2000. If you happen to find a solution, please let me know. Until then, I'll keep on using Firefox anyway. Some day I'll find a solution.

''jscher2000 [[#answer-761900|said]]'' <blockquote> ''ohfirefox [[#answer-761881|said]]'' <blockquote> http://www.avea.com.tr/web/ You'll see that on the right hand upper corner, there is button called "Online Islemler". That button is supposed open a new window. </blockquote> Yes, that button fails for me. The Browser Console shows this error: ReferenceError: _gat is not defined I use NoScript and block scripts from googletagmanager.com and for whatever reason, the script attached to the button requires me to allow that script because the function run by the button is in that script: onclick=googleAnalyticsEvent('Online-Islemler','MenuBtn','/web/', 'http://www.avea.com.tr/mps/portal?cmd=onlineTransactionsHome&lang=tr&tb=redTab', '700'); return false; So something in your Firefox seems to be blocking that script in regular mode but not in Safe Mode. Most often it is an extension, but... you already checked those. Hmm... </blockquote> I have just deleted all my extensions and tried it again. Nope, still not working. It's weird, right? So Safe Mode disables some other stuff in Firefox besides extensions and themes. Whatever that "some other stuff" is that is causing the problem I guess. Thank you for your efforts jscher2000. If you happen to find a solution, please let me know. Until then, I'll keep on using Firefox anyway. Some day I'll find a solution.
jscher2000
  • Top 10 Contributor
8775 個解決方法 71729 個答案

ohfirefox said

So Safe Mode disables some other stuff in Firefox besides extensions and themes. Whatever that "some other stuff" is that is causing the problem I guess.

That's a logical deduction in an illogical situation...

Our support article "Troubleshoot Firefox issues using Safe Mode" Does not list the details. An article on the unofficial mozillaZine site has more completely information, but there's nothing obvious: http://kb.mozillazine.org/Safe_Mode

Do you have any self-hiding extensions? If so, such extensions should be visible on the Add-ons page in Safe Mode because they are powerless to hide themselves there.

''ohfirefox [[#answer-761947|said]]'' <blockquote> So Safe Mode disables some other stuff in Firefox besides extensions and themes. Whatever that "some other stuff" is that is causing the problem I guess. </blockquote> That's a logical deduction in an illogical situation... Our support article "[[Troubleshoot Firefox issues using Safe Mode]]" Does not list the details. An article on the unofficial mozillaZine site has more completely information, but there's nothing obvious: http://kb.mozillazine.org/Safe_Mode Do you have any self-hiding extensions? If so, such extensions should be visible on the Add-ons page in Safe Mode because they are powerless to hide themselves there.

提出問題者

jscher2000 said

ohfirefox said
So Safe Mode disables some other stuff in Firefox besides extensions and themes. Whatever that "some other stuff" is that is causing the problem I guess.

That's a logical deduction in an illogical situation...

Our support article "Troubleshoot Firefox issues using Safe Mode" Does not list the details. An article on the unofficial mozillaZine site has more completely information, but there's nothing obvious: http://kb.mozillazine.org/Safe_Mode

Do you have any self-hiding extensions? If so, such extensions should be visible on the Add-ons page in Safe Mode because they are powerless to hide themselves there.

Nope, I've checked for hidden add-ons and there wasn't anything I'd not seen before.

I'll read that mozillazine article and let you know if I find anything relevant to my case.

Have a nice weekend.

''jscher2000 [[#answer-761950|said]]'' <blockquote> ''ohfirefox [[#answer-761947|said]]'' <blockquote> So Safe Mode disables some other stuff in Firefox besides extensions and themes. Whatever that "some other stuff" is that is causing the problem I guess. </blockquote> That's a logical deduction in an illogical situation... Our support article "[[Troubleshoot Firefox issues using Safe Mode]]" Does not list the details. An article on the unofficial mozillaZine site has more completely information, but there's nothing obvious: http://kb.mozillazine.org/Safe_Mode Do you have any self-hiding extensions? If so, such extensions should be visible on the Add-ons page in Safe Mode because they are powerless to hide themselves there. </blockquote> Nope, I've checked for hidden add-ons and there wasn't anything I'd not seen before. I'll read that mozillazine article and let you know if I find anything relevant to my case. Have a nice weekend.