X
點擊此處開啟此網站的行動版。

技術支援討論區

Pop-up pages don't open even when I want them to

已張貼

Hey everyone,

Let's say that I am trying to login to my bank's online banking site. As you know, usually you enter your login credentials in a new window separate from the home page. Unfortunately, that page doesn't open in Firefox yet it does in Chrome. When I hover my mouse cursor on the link which I want Firefox to open, all I see is javascript:void(0) and nothing happens. This problem also occurs on my GSM operator's page, too.

I tried starting the Firefox in safe mode and the problem wasn't there anymore. In order to find the culprit, I disabled every extension, plug-in and hardware acceleration but after the restart (while all are still disabled), problem was still there.

I don't want to refresh Firefox and lose every setting. Is there any other way?

I don't want to switch browsers, I am a fan of open-source software.

Thanks :)

PS: I have a Win7 64bit system. Every plug-in and extension are updated.

Hey everyone, Let's say that I am trying to login to my bank's online banking site. As you know, usually you enter your login credentials in a new window separate from the home page. Unfortunately, that page doesn't open in Firefox yet it does in Chrome. When I hover my mouse cursor on the link which I want Firefox to open, all I see is javascript:void(0) and nothing happens. This problem also occurs on my GSM operator's page, too. I tried starting the Firefox in safe mode and the problem wasn't there anymore. In order to find the culprit, I disabled every extension, plug-in and hardware acceleration but after the restart (while all are still disabled), problem was still there. I don't want to refresh Firefox and lose every setting. Is there any other way? I don't want to switch browsers, I am a fan of open-source software. Thanks :) PS: I have a Win7 64bit system. Every plug-in and extension are updated.

額外的系統細節

已安裝的外掛程式

  • Next Generation Java Plug-in 11.51.2 for Mozilla browsers
  • Shockwave Flash 18.0 r0
  • Shockwave Flash 17.0 r0
  • 5.1.40416.0

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0

更多資訊

FredMcD
  • Top 10 Contributor
4255 個解決方法 59591 個答案

Separate Issue; Your System Details shows;

Installed Plug-ins

Shockwave Flash 18.0 r0 Shockwave Flash 17.0 r0
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Flash: Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac

Then reinstall the latest version.

Flash Player Version 18.0.0.209
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Internet Explorer” and “Plugin-based browsers” installers.

Separate Issue; Your System Details shows; Installed Plug-ins Shockwave Flash 18.0 r0 Shockwave Flash 17.0 r0 <br>Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer. Flash: Grab the uninstaller from here: '''[http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows]''' '''[http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac]''' Then reinstall the latest version. Flash Player '''Version 18.0.0.209<br>https://www.adobe.com/products/flashplayer/distribution3.html''' '''Note: Windows users''' must download the “Internet Explorer” '''and''' “Plugin-based browsers” installers.
FredMcD
  • Top 10 Contributor
4255 個解決方法 59591 個答案

Type about:preferences#content<enter> in the address bar. Look for; Block pop-up windows. To its right, press Exceptions.

Type '''about:preferences#content'''<enter> in the address bar. Look for; '''Block pop-up windows.''' To its right, press '''Exceptions.'''
jscher2000
  • Top 10 Contributor
8758 個解決方法 71663 個答案

Firefox should never block popups for user-initiated actions like a click...

While you are viewing the site where popups don't work, could you check the Permissions panel of the Page Info dialog. You can call that up using any of these:

  • right-click and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address > More Information > Permissions

Scroll down to Open Pop-up Windows and if the "effective" permission is Block, change it to Allow (you might need to uncheck the "Use default" box).

Any difference?

Firefox should never block popups for user-initiated actions like a click... While you are viewing the site where popups don't work, could you check the Permissions panel of the Page Info dialog. You can call that up using any of these: * right-click and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or globe icon to the left of the site address > More Information > Permissions Scroll down to Open Pop-up Windows and if the "effective" permission is Block, change it to Allow (you might need to uncheck the "Use default" box). Any difference?

提出問題者

FredMcD said

Separate Issue; Your System Details shows; Installed Plug-ins Shockwave Flash 18.0 r0 Shockwave Flash 17.0 r0
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer. Flash: Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac Then reinstall the latest version. Flash Player Version 18.0.0.209
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Internet Explorer” and “Plugin-based browsers” installers.

I did what you said, now I don't have any Flash plug-in. Yet I still have the problem.

''FredMcD [[#answer-760127|said]]'' <blockquote> Separate Issue; Your System Details shows; Installed Plug-ins Shockwave Flash 18.0 r0 Shockwave Flash 17.0 r0 <br>Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer. Flash: Grab the uninstaller from here: '''[http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows]''' '''[http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac]''' Then reinstall the latest version. Flash Player '''Version 18.0.0.209<br>https://www.adobe.com/products/flashplayer/distribution3.html''' '''Note: Windows users''' must download the “Internet Explorer” '''and''' “Plugin-based browsers” installers. </blockquote> I did what you said, now I don't have any Flash plug-in. Yet I still have the problem.

提出問題者

FredMcD said

Type about:preferences#content<enter> in the address bar. Look for; Block pop-up windows. To its right, press Exceptions.

Those websites I mentioned (GSM operator, online banking) are already in that list and it doesn't help, unfortunately.

''FredMcD [[#answer-760129|said]]'' <blockquote> Type '''about:preferences#content'''<enter> in the address bar. Look for; '''Block pop-up windows.''' To its right, press '''Exceptions.''' </blockquote> Those websites I mentioned (GSM operator, online banking) are already in that list and it doesn't help, unfortunately.

提出問題者

jscher2000 said

Firefox should never block popups for user-initiated actions like a click... While you are viewing the site where popups don't work, could you check the Permissions panel of the Page Info dialog. You can call that up using any of these:
  • right-click and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address > More Information > Permissions
Scroll down to Open Pop-up Windows and if the "effective" permission is Block, change it to Allow (you might need to uncheck the "Use default" box). Any difference?

I've checked that Permissions tab and "Use Default" is already unchecked and the current preference is "Allow". Yet, it doesn't help.

''jscher2000 [[#answer-760135|said]]'' <blockquote> Firefox should never block popups for user-initiated actions like a click... While you are viewing the site where popups don't work, could you check the Permissions panel of the Page Info dialog. You can call that up using any of these: * right-click and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or globe icon to the left of the site address > More Information > Permissions Scroll down to Open Pop-up Windows and if the "effective" permission is Block, change it to Allow (you might need to uncheck the "Use default" box). Any difference? </blockquote> I've checked that Permissions tab and "Use Default" is already unchecked and the current preference is "Allow". Yet, it doesn't help.
jscher2000
  • Top 10 Contributor
8758 個解決方法 71663 個答案

Could you check for any error messages in the Browser Console? You can launch the console using either

  • Ctrl+Shift+j
  • Developer menu

When the window loads, it tends to fill with unhelpful information, so please click the Clear button on the top line

Then switch over to your problem site and click the non-working link, and check back in the console for anything such as:

  • error message
  • URL of a page that was retrieved (but which isn't visible)

Returning to the Safe Mode/Extensions issue: What, if any, extensions are currently enabled?

As an alternative to checking the Add-ons page, you can use the support information page. To open that, you can use either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

If you scroll down a bit, there is a table showing enabled and disabled extensions which is copy/pasteable should you want to inquire about anything you find there.

Could you check for any error messages in the Browser Console? You can launch the console using either * Ctrl+Shift+j * Developer menu When the window loads, it tends to fill with unhelpful information, so please click the Clear button on the top line Then switch over to your problem site and click the non-working link, and check back in the console for anything such as: * error message * URL of a page that was retrieved (but which isn't visible) ---- Returning to the Safe Mode/Extensions issue: What, if any, extensions are currently enabled? As an alternative to checking the Add-ons page, you can use the support information page. To open that, you can use either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter If you scroll down a bit, there is a table showing enabled and disabled extensions which is copy/pasteable should you want to inquire about anything you find there.
FredMcD
  • Top 10 Contributor
4255 個解決方法 59591 個答案

Are you using any kind of blocking program / add-on?

What anti-virus are you using?

Are you using any kind of blocking program / add-on? What anti-virus are you using?

提出問題者

FredMcD said

Are you using any kind of blocking program / add-on? What anti-virus are you using?

Here is the full list of my (enabled) extensions:

  • BetterPrivacy
  • Ghostery
  • HTTPS-Everywhere
  • uBlock Origin

And I use avast! Free Antivirus. I tried disabling "active shields" and checked the issue again, it didn't help unfortunately.

The thing is, as I mentioned, there wasn't any problem in Safe Mode. So I disabled every extension and plug-in that was installed and restarted the Firefox this time in normal mode yet problem was still there.

''FredMcD [[#answer-760481|said]]'' <blockquote> Are you using any kind of blocking program / add-on? What anti-virus are you using? </blockquote> Here is the full list of my (enabled) extensions: * BetterPrivacy * Ghostery * HTTPS-Everywhere * uBlock Origin And I use avast! Free Antivirus. I tried disabling "active shields" and checked the issue again, it didn't help unfortunately. The thing is, as I mentioned, there wasn't any problem in Safe Mode. So I disabled every extension and plug-in that was installed and restarted the Firefox this time in normal mode yet problem was still there.

由 ohfirefox 於 修改

jscher2000
  • Top 10 Contributor
8758 個解決方法 71663 個答案

uBlock should have a site-specific "off" button, according to its page here: https://addons.mozilla.org/firefox/addon/ublock-origin/

Could you try that on the problem site and see whether it makes any difference?

I don't think the other 3 would cause a pop-up to be blocked, although they could cause the contents of the pop-up to be broken in some way.

uBlock should have a site-specific "off" button, according to its page here: https://addons.mozilla.org/firefox/addon/ublock-origin/ Could you try that on the problem site and see whether it makes any difference? I don't think the other 3 would cause a pop-up to be blocked, although they could cause the contents of the pop-up to be broken in some way.

提出問題者

jscher2000 said

uBlock should have a site-specific "off" button, according to its page here: https://addons.mozilla.org/firefox/addon/ublock-origin/ Could you try that on the problem site and see whether it makes any difference? I don't think the other 3 would cause a pop-up to be blocked, although they could cause the contents of the pop-up to be broken in some way.

When there is a problem with a site first thing that comes to my mind is that I need to disable Ghostery and/or uBlock. I tried disabling these two add-ons for this particular online banking site, it wasn't helpful.

''jscher2000 [[#answer-760528|said]]'' <blockquote> uBlock should have a site-specific "off" button, according to its page here: https://addons.mozilla.org/firefox/addon/ublock-origin/ Could you try that on the problem site and see whether it makes any difference? I don't think the other 3 would cause a pop-up to be blocked, although they could cause the contents of the pop-up to be broken in some way. </blockquote> When there is a problem with a site first thing that comes to my mind is that I need to disable Ghostery and/or uBlock. I tried disabling these two add-ons for this particular online banking site, it wasn't helpful.

提出問題者

By the way, thank you all for trying to helping me :)

By the way, thank you all for trying to helping me :)
jscher2000
  • Top 10 Contributor
8758 個解決方法 71663 個答案

Hmm, were there any messages in the Browser Console that appeared when trying to use the button that isn't working?

Hmm, were there any messages in the Browser Console that appeared when trying to use the button that isn't working?
jscher2000
  • Top 10 Contributor
8758 個解決方法 71663 個答案

Sometime when Firefox is inexplicably broken, this is useful:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 39.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder, either:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement after this reinstall?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
Sometime when Firefox is inexplicably broken, this is useful: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (1) Download a fresh installer for Firefox 39.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (2) Exit out of Firefox (if applicable). (3) Rename the program folder, either: ''(64-bit Windows folder names)'' C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox ''(32-bit Windows folder names)'' C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (4) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Any improvement after this reinstall? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins
FredMcD
  • Top 10 Contributor
4255 個解決方法 59591 個答案

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Restart. Poke around safe web sites. Are there any problems?

'''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Restart. Poke around safe web sites. Are there any problems?

提出問題者

FredMcD said

Start Firefox in Safe Mode {web link} While you are in safe mode; Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration. Restart. Poke around safe web sites. Are there any problems?

I have tried switching "Hardware Acceleration" on and off to no avail.

''FredMcD [[#answer-760649|said]]'' <blockquote> '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Restart. Poke around safe web sites. Are there any problems? </blockquote> I have tried switching "Hardware Acceleration" on and off to no avail.

提出問題者

jscher2000 said

Hmm, were there any messages in the Browser Console that appeared when trying to use the button that isn't working?

Below you can see the list of errors I received after cleaning the console and clicking the link that doesn't work:

TypeError: e is undefined ReferenceError: cmCreateElementTag is not defined

''jscher2000 [[#answer-760543|said]]'' <blockquote> Hmm, were there any messages in the Browser Console that appeared when trying to use the button that isn't working? </blockquote> Below you can see the list of errors I received after cleaning the console and clicking the link that doesn't work: TypeError: e is undefined ReferenceError: cmCreateElementTag is not defined

提出問題者

jscher2000 said

Sometime when Firefox is inexplicably broken, this is useful: Clean Reinstall We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (1) Download a fresh installer for Firefox 39.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (2) Exit out of Firefox (if applicable). (3) Rename the program folder, either: (64-bit Windows folder names) C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox (32-bit Windows folder names) C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (4) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Any improvement after this reinstall? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:
  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

I've just done exactly what you said. Unfortunately, it didn't help.

''jscher2000 [[#answer-760546|said]]'' <blockquote> Sometime when Firefox is inexplicably broken, this is useful: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (1) Download a fresh installer for Firefox 39.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (2) Exit out of Firefox (if applicable). (3) Rename the program folder, either: ''(64-bit Windows folder names)'' C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox ''(32-bit Windows folder names)'' C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (4) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Any improvement after this reinstall? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins </blockquote> I've just done exactly what you said. Unfortunately, it didn't help.
jscher2000
  • Top 10 Contributor
8758 個解決方法 71663 個答案

ohfirefox said

jscher2000 said
Hmm, were there any messages in the Browser Console that appeared when trying to use the button that isn't working?

TypeError: e is undefined
ReferenceError: cmCreateElementTag is not defined

This could indicate a problem with the script code for the click event, but I don't understand why the script would work in Safe Mode and not work in regular mode. Perhaps it is necessary to check whether those same error messages appear in Safe Mode. Then we could rule them out as being relevant to the problem.

By the way, cmCreateElementTag seems to be associated with Coremetrics, which is for web page analytics, which could be considered a type of tracking. Have you turned on the optional feature to block tracking? I haven't tested it myself, but that would be in about:config the preference privacy.trackingprotection.enabled. If you set that to true, could you set it back to false, exit/restart Firefox, and see whether that makes any difference?

''ohfirefox [[#answer-761030|said]]'' <blockquote> ''jscher2000 [[#answer-760543|said]]'' <blockquote> Hmm, were there any messages in the Browser Console that appeared when trying to use the button that isn't working? </blockquote> TypeError: e is undefined <br> ReferenceError: cmCreateElementTag is not defined </blockquote> This could indicate a problem with the script code for the click event, but I don't understand why the script would work in Safe Mode and not work in regular mode. Perhaps it is necessary to check whether those same error messages appear in Safe Mode. Then we could rule them out as being relevant to the problem. By the way, cmCreateElementTag seems to be associated with Coremetrics, which is for web page analytics, which could be considered a type of tracking. Have you turned on the optional feature to block tracking? I haven't tested it myself, but that would be in '''about:config''' the preference '''privacy.trackingprotection.enabled'''. If you set that to true, could you set it back to false, exit/restart Firefox, and see whether that makes any difference?

提出問題者

jscher2000 said

ohfirefox said
jscher2000 said
Hmm, were there any messages in the Browser Console that appeared when trying to use the button that isn't working?

TypeError: e is undefined
ReferenceError: cmCreateElementTag is not defined

This could indicate a problem with the script code for the click event, but I don't understand why the script would work in Safe Mode and not work in regular mode. Perhaps it is necessary to check whether those same error messages appear in Safe Mode. Then we could rule them out as being relevant to the problem.

By the way, cmCreateElementTag seems to be associated with Coremetrics, which is for web page analytics, which could be considered a type of tracking. Have you turned on the optional feature to block tracking? I haven't tested it myself, but that would be in about:config the preference privacy.trackingprotection.enabled. If you set that to true, could you set it back to false, exit/restart Firefox, and see whether that makes any difference?

Some other error messages appear in Safe Mode since now the pop-up opens.

"privacy.trackingprotection.enabled" value is already true. I've just changed it to "false" just to see if it's gonna make a change but it didn't.

''jscher2000 [[#answer-761040|said]]'' <blockquote> ''ohfirefox [[#answer-761030|said]]'' <blockquote> ''jscher2000 [[#answer-760543|said]]'' <blockquote> Hmm, were there any messages in the Browser Console that appeared when trying to use the button that isn't working? </blockquote> TypeError: e is undefined <br> ReferenceError: cmCreateElementTag is not defined </blockquote> This could indicate a problem with the script code for the click event, but I don't understand why the script would work in Safe Mode and not work in regular mode. Perhaps it is necessary to check whether those same error messages appear in Safe Mode. Then we could rule them out as being relevant to the problem. By the way, cmCreateElementTag seems to be associated with Coremetrics, which is for web page analytics, which could be considered a type of tracking. Have you turned on the optional feature to block tracking? I haven't tested it myself, but that would be in '''about:config''' the preference '''privacy.trackingprotection.enabled'''. If you set that to true, could you set it back to false, exit/restart Firefox, and see whether that makes any difference? </blockquote> Some other error messages appear in Safe Mode since now the pop-up opens. "privacy.trackingprotection.enabled" value is already true. I've just changed it to "false" just to see if it's gonna make a change but it didn't.