搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

My e-newsletter is not formatted correctly in firefox

  • 6 回覆
  • 1 有這個問題
  • 80 次檢視
  • 最近回覆由 jvick

more options

I am using a email service called Sendgrid. Recently, I have created newsletters that display perfectly in other browsers such as Google Chrome, Internet Explorer, Safari. However, the newsletter is completely distorted when using Firefox. Please advise on how i can correct this / make it more compatible with Firefox.

You can view the newsletter using this link:

https://364255.content.nlgrid.com/wf/webmail?rp=ZTI1bGQzTnNaWFIwWlhKZmFXUTZNVEl6TkN4MWMyVnlYMmxrT2pJMU5qVTBmUWV5SnVaWGR6YkdWMGRHVnlYMmxrSWpvaU9UUXpOREUzT1NJc0ltNWxkM05zWlhSMFpYSmZkWE5sY2w5cFpDSTZOVEU0TURBek5ETTFOekI5

被選擇的解決方法

You need a clear:both CSS rule for the table that is moved to the right to prevent Firefox from staring right after the current position.

#TbBodyRow { clear: both; }
從原來的回覆中察看解決方案 👍 1

所有回覆 (6)

more options

Hi, After reviewing your question to solve this I need you to confirm a few things. 1. I have tried this on my FFox and its working fine 2. Have you tried doing a uninstall and reinstalling FFox 3. Can you check with Sendgrid for me just to find out if its problems at there end or yours. Please update as soon as you know!

^EMS Did this solve your question??

If you haven't already, please select the answer that solves the problem.  This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

more options

This forum is intended for end user support, not for web development issues. Try posting at the Web Development / Standards Evangelism forum at MozillaZine. The contributors over there are more knowledgeable about web page development issues with Firefox. http://forums.mozillazine.org/viewforum.php?f=25 You'll need to register and login to be able to post in that forum.

more options

選擇的解決方法

You need a clear:both CSS rule for the table that is moved to the right to prevent Firefox from staring right after the current position.

#TbBodyRow { clear: both; }
more options

TalkingFirefox said

Hi, After reviewing your question to solve this I need you to confirm a few things. 1. I have tried this on my FFox and its working fine 2. Have you tried doing a uninstall and reinstalling FFox 3. Can you check with Sendgrid for me just to find out if its problems at there end or yours. Please update as soon as you know!


Thank you for your response.

I have uninstalled and reinstalled and am experiencing the same issue. I am using Firefox 39.0.

I checked with SendGrid and they confirmed the newsletter was distorted in Firefox. They referred me to check with Firefox Support.

由 jvick 於 修改

more options

Hi again Jvick, Just before I respond about the responce above I need to advise you that:

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers.

If you could look at @Cor-el's Post which is quoted below: cor-el said

You need a clear:both CSS rule for the table that is moved to the right to prevent Firefox from staring right after the current position.
#TbBodyRow { clear: both; }

Also it might help you by leaving a post in another mozilla support center for web developers which may be able to help you in more details (the-edmeister also commented this above.)

the-edmeister said

This forum is intended for end user support, not for web development issues. Try posting at the Web Development / Standards Evangelism forum at MozillaZine. The contributors over there are more knowledgeable about web page development issues with Firefox. http://forums.mozillazine.org/viewforum.php?f=25 You'll need to register and login to be able to post in that forum.

I'll happly send feedback to both sendgrid / Mozilla regarding this issue and letting them know so that the next time they do a update of Mozilla Firefox (Every 6 wks) it might work. If you want me to look please reply to this message,I'll get a email and send future instructions. I await your reply, Ethan -TalkingFirefox

由 TalkingFirefox 於 修改

more options

cor-el said

You need a clear:both CSS rule for the table that is moved to the right to prevent Firefox from staring right after the current position.
#TbBodyRow { clear: both; }

This worked brilliantly. All issues are fixed. Thank you to all!