搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Save Image As used to show an ascii file name and now shows a HEX string instead of the ascii name. IE and Chrome do not do this. Why?

  • 3 回覆
  • 1 有這個問題
  • 11 次檢視
  • 最近回覆由 FredMcD

more options

Attempting to use the "Save Image As" used to display a dialog box with the proper ascii name of the image file. Now the display of the file name is the HEX part of the link http://assets.amuniversal.com/ec5ca0c0fl2d0132ea77005056a9545d with a proper extension. e.g. ec5ca0c0fl2d0132ea77005056a9545d.jpg

所有回覆 (3)

more options

Please post the web address where the image is and what image you are having problems with.

more options

That is a known bug in Firefox 39 caused by the file name as set via Content-Disposition not being used.

  • bug 1180126 - Content-Disposition: inline; filename= doesn't work with Save As

A possible workaround is to open the image in a tab and use "Save Page As" to save the image.

由 cor-el 於 修改

more options

I don't know if this can help

InlineDisposition 2 {web link} InlineDisposition 2 changes the disposition of Content-Disposition response headers from attachment to inline.