搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

is there a compatibility issue with Yosemite 10.10.4 and Firefox 39.0

  • 7 回覆
  • 1 有這個問題
  • 24 次檢視
  • 最近回覆由 jscher2000

more options

I get this message every time I try to browse.... This Connection is Untrusted

You have asked Firefox to connect securely to services.addons.mozilla.org, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate.

所有回覆 (7)

more options

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open this chrome URI by pasting or typing this URI in the location/address bar to open the "Add Security Exception" window and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field type/paste the URL of the website

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

Check who is the issuer of the certificate.

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer.


  • Note that some firewalls monitor (secure) connections and that programs like Sendori or FiddlerRoot can intercept connections and send their own certificate instead of the website's certificate.
more options

Thank you for info but I got this message...


This webpage is not available

ERR_INVALID_URL Hide details The webpage at chrome://pippki/content/exceptionDialog.xul might be temporarily down or it may have moved permanently to a new web address.

more options

However Firefox works only with the apple.com website

more options

I believe I found the issue; it was a conflict with the antivirus AVAST

more options

Like a few other programs, avast! has a feature to intercept and scan your web connections. In order to "read" your communications with sites that use HTTPS, avast! has to present a fake certificate to Firefox. You should be able to find the steps to have Firefox trust avast! if you like or you could disable that feature. You don't need to completely switch to a different security vendor if you like avast otherwise.

more options

Thanks, jscher 4 suggestion, but I ain't an expert... "yet"... Where can I find the steps to have FireFox trust Avast?

more options

Good question. I looked at some posts on the avast! forums and they make it sound pretty automatic:

"For chrome/IE we insert the certificate into the system store - that's why it works. For firefox, we insert the certificate into the firefox private store during the start of the browsers."

So here they suggest closing Firefox and opening it again: https://forum.avast.com/index.php?topic=167577.0

If that doesn't work, you might need to import an Authority certificate manually, which we could describe if needed. But I don't know where you find it on Mac.

Background article on this Web Shield HTTPS Scanning feature: https://blog.avast.com/2015/05/25/explaining-avasts-https-scanning-feature/