搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox 39 fuzzy font

  • 14 回覆
  • 11 有這個問題
  • 5171 次檢視
  • 最近回覆由 cor-el

more options

Hello!

Fonts looks fuzzy on most webpages, please see my screenshot below and have not found useful any solution on the internet yet. I am using Firefox v39, newest Nvidia driver.

Any ideas?

附加的畫面擷圖

被選擇的解決方法

I disabled ClearType and then went through setup process, now fonts are fine again! Thanks for both of you!

從原來的回覆中察看解決方案 👍 0

所有回覆 (14)

more options

hello, could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...

more options

Hello, please find requested information below

Application Basics


Name: Firefox Version: 39.0 Build ID: 20150630154324 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0 Multiprocess Windows: 0/1 (default: false)

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: about:addons-memory Version: 10.1-signed Enabled: true ID: about-addons-memory@tn123.org

Name: Adblock Plus Version: 2.6.9.1-signed Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Background Tabs Version: 1.8 Enabled: true ID: backgroundtabs@caseyconnor.org

Name: Download Panel Tweaker Version: 0.2.4.1-signed Enabled: true ID: downloadPanelTweaker@infocatcher

Name: FEBE Version: 8.7.1-signed Enabled: true ID: {4BBDD651-70CF-4821-84F8-2B918CF89CA3}

Name: Flash and Video Download Version: 1.73 Enabled: true ID: {bee6eb20-01e0-ebd1-da83-080329fb9a3a}

Name: FlashGot Version: 1.5.6.12.1-signed Enabled: true ID: {19503e42-ca3c-4c27-b1e2-9cdb2170ee34}

Name: Adobe Acrobat - Create PDF Version: 1.2 Enabled: false ID: web2pdfextension@web2pdf.adobedotcom

Name: Lightbeam Version: 1.2.1.1-signed Enabled: false ID: jid1-F9UJ2thwoAm5gQ@jetpack

Name: Location Bar Enhancer Version: 5.2.1-signed Enabled: false ID: UIEnhancer@girishsharma

Name: Logitech SetPoint Version: 6.5 Enabled: false ID: {F003DA68-8256-4b37-A6C4-350FA04494DF}

Graphics


Adapter Description: NVIDIA GeForce GTX 650 Ti Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Adapter RAM: 1024 Asynchronous Pan/Zoom: none Device ID: 0x11c6 DirectWrite Enabled: false (6.2.9200.17292) Driver Date: 6-17-2015 Driver Version: 10.18.13.5330 GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic Subsys ID: 35571458 Vendor ID: 0x10de windowLayerManagerRemote: false AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.parent_directory: i:\FirefoxTemp browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 3 browser.cache.memory.enable: false browser.download.importedFromSqlite: true browser.download.useDownloadDir: false browser.places.importBookmarksHTML: false browser.places.smartBookmarksVersion: 7 browser.search.useDBForOrder: true browser.sessionstore.upgradeBackup.latestBuildID: 20150630154324 browser.startup.homepage: about:home browser.startup.homepage_override.buildID: 20150630154324 browser.startup.homepage_override.mstone: 39.0 browser.tabs.loadBookmarksInBackground: true browser.tabs.onTop: false dom.mozApps.used: true dom.w3c_touch_events.expose: false extensions.lastAppVersion: 39.0 font.internaluseonly.changed: false gfx.content.azure.enabled: true gfx.direct2d.disabled: true gfx.direct3d.checkDX10: true gfx.direct3d.last_used_feature_level_idx: 0 gfx.direct3d.prefer_10_1: true keyword.URL: http://www.google.com/search?q= layers.offmainthreadcomposition.enabled: false media.gmp-eme-adobe.lastUpdate: 1436646711 media.gmp-eme-adobe.version: 11 media.gmp-gmpopenh264.lastUpdate: 1436646711 media.gmp-gmpopenh264.version: 1.4 media.gmp-manager.buildID: 20150630154324 media.gmp-manager.lastCheck: 1436646709 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1436389381 places.history.expiration.transient_current_max_pages: 104858 places.history.expiration.transient_optimal_database_size: 110199029 places.last_vacuum: 1295548145 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.npqtplugin: 1 print.print_printer: HP Photosmart 7200 Series print.printer_Adobe_PDF.print_bgcolor: false print.printer_Adobe_PDF.print_bgimages: false print.printer_Adobe_PDF.print_colorspace: print.printer_Adobe_PDF.print_command: print.printer_Adobe_PDF.print_downloadfonts: false print.printer_Adobe_PDF.print_duplex: 1515870810 print.printer_Adobe_PDF.print_edge_bottom: 0 print.printer_Adobe_PDF.print_edge_left: 0 print.printer_Adobe_PDF.print_edge_right: 0 print.printer_Adobe_PDF.print_edge_top: 0 print.printer_Adobe_PDF.print_evenpages: true print.printer_Adobe_PDF.print_footercenter: print.printer_Adobe_PDF.print_footerleft: &PT print.printer_Adobe_PDF.print_footerright: &D print.printer_Adobe_PDF.print_headercenter: print.printer_Adobe_PDF.print_headerleft: &T print.printer_Adobe_PDF.print_headerright: &U print.printer_Adobe_PDF.print_in_color: true print.printer_Adobe_PDF.print_margin_bottom: 0.5 print.printer_Adobe_PDF.print_margin_left: 0.5 print.printer_Adobe_PDF.print_margin_right: 0.5 print.printer_Adobe_PDF.print_margin_top: 0.5 print.printer_Adobe_PDF.print_oddpages: true print.printer_Adobe_PDF.print_orientation: 0 print.printer_Adobe_PDF.print_page_delay: 50 print.printer_Adobe_PDF.print_paper_data: 9 print.printer_Adobe_PDF.print_paper_height: 11,00 print.printer_Adobe_PDF.print_paper_name: print.printer_Adobe_PDF.print_paper_size_type: 0 print.printer_Adobe_PDF.print_paper_size_unit: 1 print.printer_Adobe_PDF.print_paper_width: 8,50 print.printer_Adobe_PDF.print_plex_name: print.printer_Adobe_PDF.print_resolution: 1515870810 print.printer_Adobe_PDF.print_resolution_name: print.printer_Adobe_PDF.print_reversed: false print.printer_Adobe_PDF.print_scaling: 1,00 print.printer_Adobe_PDF.print_shrink_to_fit: true print.printer_Adobe_PDF.print_to_file: false print.printer_Adobe_PDF.print_unwriteable_margin_bottom: 0 print.printer_Adobe_PDF.print_unwriteable_margin_left: 0 print.printer_Adobe_PDF.print_unwriteable_margin_right: 0 print.printer_Adobe_PDF.print_unwriteable_margin_top: 0 print.printer_HP_Photosmart_7200_Series.print_bgcolor: false print.printer_HP_Photosmart_7200_Series.print_bgimages: false print.printer_HP_Photosmart_7200_Series.print_command: print.printer_HP_Photosmart_7200_Series.print_downloadfonts: false print.printer_HP_Photosmart_7200_Series.print_edge_bottom: 0 print.printer_HP_Photosmart_7200_Series.print_edge_left: 0 print.printer_HP_Photosmart_7200_Series.print_edge_right: 0 print.printer_HP_Photosmart_7200_Series.print_edge_top: 0 print.printer_HP_Photosmart_7200_Series.print_evenpages: true print.printer_HP_Photosmart_7200_Series.print_footercenter: print.printer_HP_Photosmart_7200_Series.print_footerleft: &PT print.printer_HP_Photosmart_7200_Series.print_footerright: &D print.printer_HP_Photosmart_7200_Series.print_headercenter: print.printer_HP_Photosmart_7200_Series.print_headerleft: &T print.printer_HP_Photosmart_7200_Series.print_headerright: &U print.printer_HP_Photosmart_7200_Series.print_in_color: true print.printer_HP_Photosmart_7200_Series.print_margin_bottom: 0.5 print.printer_HP_Photosmart_7200_Series.print_margin_left: 0.5 print.printer_HP_Photosmart_7200_Series.print_margin_right: 0.5 print.printer_HP_Photosmart_7200_Series.print_margin_top: 0.5 print.printer_HP_Photosmart_7200_Series.print_oddpages: true print.printer_HP_Photosmart_7200_Series.print_orientation: 0 print.printer_HP_Photosmart_7200_Series.print_page_delay: 50 print.printer_HP_Photosmart_7200_Series.print_paper_data: 9 print.printer_HP_Photosmart_7200_Series.print_paper_height: 11,00 print.printer_HP_Photosmart_7200_Series.print_paper_size_type: 0 print.printer_HP_Photosmart_7200_Series.print_paper_size_unit: 1 print.printer_HP_Photosmart_7200_Series.print_paper_width: 8,50 print.printer_HP_Photosmart_7200_Series.print_reversed: false print.printer_HP_Photosmart_7200_Series.print_scaling: 1,00 print.printer_HP_Photosmart_7200_Series.print_shrink_to_fit: true print.printer_HP_Photosmart_7200_Series.print_to_file: false print.printer_HP_Photosmart_7200_Series.print_unwriteable_margin_bottom: 0 print.printer_HP_Photosmart_7200_Series.print_unwriteable_margin_left: 0 print.printer_HP_Photosmart_7200_Series.print_unwriteable_margin_right: 0 print.printer_HP_Photosmart_7200_Series.print_unwriteable_margin_top: 0 privacy.donottrackheader.enabled: true privacy.sanitize.migrateFx3Prefs: true security.dialog_enable_delay: 0 security.warn_viewing_mixed: false storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1434218414 webgl.disabled: true

Important Locked Preferences


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.8 Version in use: 4.10.8

NSS Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSSMIME Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSSSL Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSUTIL Expected minimum version: 3.19.2 Version in use: 3.19.2

Experimental Features


more options

thanks could you enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for all custom preferences (displayed in bold) starting with gfx. - right-click and reset such entries to their default value and restart firefox.

more options

This will may be helpful : Go to System Control Panel > Appearance and Personalization Under Fonts > Click on Adjust Clear Text . Choose appropriate text and click on Save changes .

Now open the browser and check whether the fonts are good looks or not . See the attachment below:

more options

Chandan_Baba: thanks for the help, but I don't use ClearType

philipp: everything is set to default, font is still fuzzy. Any further ideas?

more options

Chandan_Baba said

This will may be helpful : Go to System Control Panel > Appearance and Personalization Under Fonts > Click on Adjust Clear Text . Choose appropriate text and click on Save changes . Now open the browser and check whether the fonts are good looks or not . See the attachment below:

WOOW! This is more, than weird: though I don't use ClearType, when I open the window, where I can change setup and I enable it, the fonts look good. Then I disable it and fonts look still good. But when I close ClearType setup window, fonts look fuzzy again, very, very weird.

Have you ever met this issue?

more options

選擇的解決方法

I disabled ClearType and then went through setup process, now fonts are fine again! Thanks for both of you!

more options

The problem came up for me with Firefox 39 and it persisted with Firefox 40. I'm running Firefox on a Windows 7 Pro which is virtualized with Linux KVM.

For me disabling ClearType leaded to ugly fonts in other Windows-Applications. So I re-enabled it. When I disabled support for Woff2 in the Firefox-Config with

gfx.downloadable_fonts.woff2.enabled = false

everything turned fine.

more options

Same here, this is specifically a Firefox issue. It appeared when I updated to 40.0.3 however I was a couple of updates behind on this machine. Windows 7 PC.

I have tried all suggested options but nothing works. e's look like c's

Chrome looks fine, IE looks fine, and on my Mac it also looks fine.

It is very noticeable once inside the Freelancer.com website for example as I guess they use some type of different font. It used to be fine there however now it is difficult to read readily.

more options

Did you try the configuring the option

gfx.downloadable_fonts.woff2.enabled = false

With this option set (and refreshing the viewed site), freelancer.com looks ok for me, without it looks fuzzy, as stated by you.

What is your graphics hardware?

more options

miab said

Did you try the configuring the option gfx.downloadable_fonts.woff2.enabled = false With this option set (and refreshing the viewed site), freelancer.com looks ok for me, without it looks fuzzy, as stated by you. What is your graphics hardware?


Excellent. Thank you for taking the time to reply on this. Fixed it 100%

I have an HP laptop i7 with an AMD Radeon HD 6700 2Gb graphics card.

cheers

由 Krammig 於 修改

more options

miab said

The problem came up for me with Firefox 39 and it persisted with Firefox 40. I'm running Firefox on a Windows 7 Pro which is virtualized with Linux KVM. For me disabling ClearType leaded to ugly fonts in other Windows-Applications. So I re-enabled it. When I disabled support for Woff2 in the Firefox-Config with gfx.downloadable_fonts.woff2.enabled = false everything turned fine.

How would a mere mortal, like me, do this?? I'm afraid I'm going to need something step-by-step as I'm not a programmer.

more options

For editing the config have a look at About:config . Change the Value of the key gfx.downloadable_fonts.woff2.enabled to false

more options

Type about:config in the location (address) bar and press the Enter key to open the about:config page like you open a website by typing the URL in the location bar.

  • if you see a warning message then you can confirm that you want to access the about:config page.
  • use the Search bar at the top of the about:config page to locate preferences more easily
  • preferences that have been modified and do not have the default value show as bold (user set)
  • preferences that are user set (bold) can be reset to the default value via the right-click context menu
  • preferences can be modified via Modify (String or Integer) or Toggle (Boolean) in the right-click context menu and by double-clicking the line with the pref
  • preferences can be created via the right-click context menu: New -> String, Integer, Boolean