X
點擊此處開啟此網站的行動版。

技術支援討論區

Install of Firefox 39 on Mac results in blank windows

已張貼

Installing a fresh (never before had Firefox installed) copy of Firefox 39 on Mac OS X (verified on Mac OS X 10.7, 10.8, & 10.9) results in blank windows. After installing, I open up Firefox and see the Import wizard displayed blank (see uploaded image import.jpg). I click the red dot on that window to close it and then I get the Default behavior dialog box which displays correctly (see uploaded image default.jpg). I click to use Firefox as the default and then I get a Firefox window open up which is completely blank - no toolbar or address bar (see uploaded image windows.jpg). I then quit firefox and correctly get asked about closing 2 tabs (see uploaded image tabs.jpg). I then open firefox again and get the blank window. If I do an about, I get a blank about window (see uploaded image about.jpg). I've tried restarting and that does not resolve the issue. Repeating this as an upgrade rather than a fresh install results in some success (my Mac OS X 10.10 upgrade let me see the standard firefox window) while others show the blank windows (I tested Mca OS X 10.8 & 10.9).

Installing a fresh (never before had Firefox installed) copy of Firefox 39 on Mac OS X (verified on Mac OS X 10.7, 10.8, & 10.9) results in blank windows. After installing, I open up Firefox and see the Import wizard displayed blank (see uploaded image import.jpg). I click the red dot on that window to close it and then I get the Default behavior dialog box which displays correctly (see uploaded image default.jpg). I click to use Firefox as the default and then I get a Firefox window open up which is completely blank - no toolbar or address bar (see uploaded image windows.jpg). I then quit firefox and correctly get asked about closing 2 tabs (see uploaded image tabs.jpg). I then open firefox again and get the blank window. If I do an about, I get a blank about window (see uploaded image about.jpg). I've tried restarting and that does not resolve the issue. Repeating this as an upgrade rather than a fresh install results in some success (my Mac OS X 10.10 upgrade let me see the standard firefox window) while others show the blank windows (I tested Mca OS X 10.8 & 10.9).
附加的畫面擷圖

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/600.7.12 (KHTML, like Gecko) Version/7.1.7 Safari/537.85.16

更多資訊

guigs 1072 個解決方法 11697 個答案

I tested this on a 10.10.3 and this did not happen. However in order to delete the old installation library file, please make sure there these files are removed: http://kb.mozillazine.org/Uninstalling_Firefox#On_Mac_OS_X

As for the older versions of Mac, see if this happens if you download Firefox from another browser/network. This will make sure that the install stub has not become corrupt.

If I installed the stub and did not drag it to the Applications folder, I did see the button "Use as default browser" to be blank, but that was about it. The other place that the import wizard is called is from the Bookmarks Menu > Show All Bookmarks > Import data from another Browser..., does this also become blank?

Are you installing it with a user.js file?

I tested this on a 10.10.3 and this did not happen. However in order to delete the old installation library file, please make sure there these files are removed: [http://kb.mozillazine.org/Uninstalling_Firefox#On_Mac_OS_X] As for the older versions of Mac, see if this happens if you download Firefox from another browser/network. This will make sure that the install stub has not become corrupt. If I installed the stub and did not drag it to the Applications folder, I did see the button "Use as default browser" to be blank, but that was about it. The other place that the import wizard is called is from the Bookmarks Menu > Show All Bookmarks > Import data from another Browser..., does this also become blank? Are you installing it with a user.js file?

提出問題者

The machines I experienced an issue with were virtual (Parallels). I saw a posting somewhere yesterday that said there's a change with Firefox 39 that does not allow it to work on virtual machines properly. Any chance this change could be unmade for Firefox 39.0.1 or Firefox 40?

The machines I experienced an issue with were virtual (Parallels). I saw a posting somewhere yesterday that said there's a change with Firefox 39 that does not allow it to work on virtual machines properly. Any chance this change could be unmade for Firefox 39.0.1 or Firefox 40?