X
點擊此處開啟此網站的行動版。

技術支援討論區

Web elements width problem (Firefox 39.0)

已張貼

Hello everyone,

I have problems with width of some elements on a website.

The width of the textboxes are way too big and go beyond the edge of the website.

The first screenshot it's from one of my friends (which also uses Firefox 39.0) and the second one it's from me

So far I tried : Disabling all add-ons Starting Firefox on Safe Mode Creating a new profile Re-installing Firefox

Hello everyone, I have problems with width of some elements on a website. The width of the textboxes are way too big and go beyond the edge of the website. The first screenshot it's from one of my friends (which also uses Firefox 39.0) and the second one it's from me So far I tried : Disabling all add-ons Starting Firefox on Safe Mode Creating a new profile Re-installing Firefox
附加的畫面擷圖

被選擇的解決方法

The screen shots of the Inspector show that Firefox should use Lucida Grande for the edit controls if available. If you click the Fonts mini-tab (a couple over from the Rules mini-tab on that right side), does it show that your Firefox is in fact using Lucida Grande instead of Tahoma?

If so:

You wouldn't be the first user who ran into a problem with Lucida Grande: Firefox doesn't show text on certain websites.

Lucida Grande normally is not found on Windows systems unless you at some point installed Safari for Windows. I suggest deleting the Lucida Grande font from the WIndows Fonts folder (or you could drag it out to another folder temporarily) to see if that helps.

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.8.158

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0

更多資訊

guigs 1072 個解決方法 11697 個答案

有幫助的回覆

Clear/delete the Facebook cache from the about:permissions page. Select facebook.com and hit "Forget this Site"

Clear/delete the Facebook cache from the about:permissions page. Select facebook.com and hit "Forget this Site"

有幫助的回覆

The website it's https://myanimelist.net. I tried doing the same thing to it, but I still have that problem.

The website it's https://myanimelist.net. I tried doing the same thing to it, but I still have that problem.
cor-el
  • Top 10 Contributor
  • Moderator
17670 個解決方法 159854 個答案

You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))

If you have made changes to Advanced font size settings like increasing the minimum/default font size then try the Default font size setting "16" and the Minimum font size setting "none" in case the current setting is causing problems.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly.


Note that using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of the involved files. If you revisit a 'forgotten' website then data from this website will be saved once again.

You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems. *<b>View > Zoom > Reset</b> (Ctrl/Command+0 (zero)) ----- If you have made changes to Advanced font size settings like increasing the minimum/default font size then try the Default font size setting "16" and the Minimum font size setting "none" in case the current setting is causing problems. *Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none) Make sure that you allow pages to choose their own fonts. *Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly. ---- Note that using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of the involved files. If you revisit a 'forgotten' website then data from this website will be saved once again.
jscher2000
  • Top 10 Contributor
8837 個解決方法 72222 個答案

The font in your screen shot seems to be stretched out wider than the one in the first screen shot. Not sure why that would be, but checking whether you override the site's choice (Verdana) might help (cor-el gave the steps).

The font in your screen shot seems to be stretched out wider than the one in the first screen shot. Not sure why that would be, but checking whether you override the site's choice (Verdana) might help (cor-el gave the steps).

提出問題者

In the second photo I changed the zoom , so I could include all of it.

I've attached a photo with the zoom set at 100%. And the settings for font were set as cor-el wrote.

In the second photo I changed the zoom , so I could include all of it. I've attached a photo with the zoom set at 100%. And the settings for font were set as '''cor-el''' wrote.
cor-el
  • Top 10 Contributor
  • Moderator
17670 個解決方法 159854 個答案

What does the Inspector show for the input field?

What does the Inspector show for the input field? *https://developer.mozilla.org/Tools/Page_Inspector

提出問題者

First image is the one under 'Topic Title' and the second is the one under 'Your Message'

First image is the one under 'Topic Title' and the second is the one under 'Your Message'
FredMcD
  • Top 10 Contributor
4305 個解決方法 60415 個答案

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.'''

提出問題者

That option is already enabled , look 3 posts above at the attachments I've posted.

That option is already enabled , look 3 posts above at the attachments I've posted.
jscher2000
  • Top 10 Contributor
8837 個解決方法 72222 個答案

選擇的解決方法

The screen shots of the Inspector show that Firefox should use Lucida Grande for the edit controls if available. If you click the Fonts mini-tab (a couple over from the Rules mini-tab on that right side), does it show that your Firefox is in fact using Lucida Grande instead of Tahoma?

If so:

You wouldn't be the first user who ran into a problem with Lucida Grande: Firefox doesn't show text on certain websites.

Lucida Grande normally is not found on Windows systems unless you at some point installed Safari for Windows. I suggest deleting the Lucida Grande font from the WIndows Fonts folder (or you could drag it out to another folder temporarily) to see if that helps.

The screen shots of the Inspector show that Firefox should use Lucida Grande for the edit controls if available. If you click the Fonts mini-tab (a couple over from the Rules mini-tab on that right side), does it show that your Firefox is in fact using Lucida Grande instead of Tahoma? ''If so:'' You wouldn't be the first user who ran into a problem with Lucida Grande: [https://support.mozilla.org/questions/1054122 Firefox doesn't show text on certain websites.] Lucida Grande normally is not found on Windows systems unless you at some point installed Safari for Windows. I suggest deleting the Lucida Grande font from the WIndows Fonts folder (or you could drag it out to another folder temporarily) to see if that helps.

提出問題者

THANK YOU VERY MUCH , this solved the problem !

THANK YOU VERY MUCH , this solved the problem !