X
點擊此處開啟此網站的行動版。

技術支援討論區

As of yesterday, my Firefox new tab window only shows 10 "quicktabs" instead of 15, unless zoomed out to 80% of the webpage, which becomes unreadable.

已張貼

So the new tab page of Firefox, used to have 15 quicklink tiles. However at random last night, it decided to go to 10. I cannot find how to set it back to 15. This is quite annoying as I use these websites often, is there any way to fix or set how many are displayed? As currently they only appear when the zoom setting is set to 80%. Which I cannot read anything at.

So the new tab page of Firefox, used to have 15 quicklink tiles. However at random last night, it decided to go to 10. I cannot find how to set it back to 15. This is quite annoying as I use these websites often, is there any way to fix or set how many are displayed? As currently they only appear when the zoom setting is set to 80%. Which I cannot read anything at.
附加的畫面擷圖

額外的系統細節

已安裝的外掛程式

  • Battlelog Game Launcher (2.6.2)
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Next Generation Java Plug-in 10.60.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NPWLPG
  • Shockwave Flash 18.0 r0
  • 5.1.40416.0
  • Unity Player 4.5.1f3

應用程式

  • Firefox 39.0
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/39.0/WINNT/en-US/

擴充套件

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Dark YouTube Theme 1.3.1-signed (jid1-hDf2iQXGiUjzGQ@jetpack)
  • GlassMyFox 1.3.6.1-signed (GlassMyFox@ArisT2_Noia4dev)
  • Personas Plus 1.7.3.1-signed (personas@christopher.beard)
  • YouTube™ Flash® Player 1.3.1-signed (jid1-HAV2inXAnQPIeA@jetpack)
  • Avast Online Security 10.2.0.187 (wrc@avast.com) (Inactive)
  • Greasemonkey 3.2 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: NVIDIA GeForce GTX 750
  • adapterDescription2:
  • adapterDeviceID: 0x1381
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 4-8-2015
  • driverDate2:
  • driverVersion: 9.18.13.5012
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 750 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

修改過的偏好設定

其他

  • User JS: 否
  • 輔助功能: 否
Garlino 0 個解決方法 3 個答案

Yes, same problem for me and my colleagues. We used to have 5 x 3 Grid, since Firefox 39 the third row is not visible, unless zoomed out 1 step.

Yes, same problem for me and my colleagues. We used to have 5 x 3 Grid, since Firefox 39 the third row is not visible, unless zoomed out 1 step.
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 個解決方法 40236 個答案

Type about:config in the URL bar and hit Enter. Accept the warning message. Using the Search filed at the top, locate these two preferences.

browser.newtabpage.columns and browser.newtabpage.rows

Right-click each pref under Preference Name and select Modify. Then insert the Value you desire for each pref. You may need to restart Firefox using Exit and then opening it again. I use the New Tab Tools extension for setting those prefs and use a background image for the new tab. https://addons.mozilla.org/en-US/firefox/addon/new-tab-tools/

Type '''about:config''' in the URL bar and hit Enter. ''Accept the warning message.'' Using the Search filed at the top, locate these two preferences. '''browser.newtabpage.columns''' and '''browser.newtabpage.rows''' Right-click each pref under Preference Name and select '''''Modify'''''. Then insert the Value you desire for each pref. You may need to restart Firefox using Exit and then opening it again. ''I use the New Tab Tools extension for setting those prefs and use a background image for the new tab.'' https://addons.mozilla.org/en-US/firefox/addon/new-tab-tools/
Neph 0 個解決方法 19 個答案

I'm experiencing the same problem since updating to FF39. "browser.newtabpage.columns" and "browser.newtabpage.rows" are set to 5 and 3, still it's only showing me 4 x 2 tiles instead of 4 x 3 like yesterday with FF38.

I'm experiencing the same problem since updating to FF39. "browser.newtabpage.columns" and "browser.newtabpage.rows" are set to 5 and 3, still it's only showing me 4 x 2 tiles instead of 4 x 3 like yesterday with FF38.
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 個解決方法 40236 個答案

Try this. Hit { Ctrl + 0 } (that's the number zero) to reset the zoom factor for that page.

Try this. Hit '''{ Ctrl + 0 }''' (that's the number zero) to reset the zoom factor for that page.
Garlino 0 個解決方法 3 個答案

That doesn't solve the problem. The 3.row is not visible since Version 39, unless zoomed out.

With the add-on, the gamma values seem to be off, the previews look too bright for me.

That doesn't solve the problem. The 3.row is not visible since Version 39, unless zoomed out. With the add-on, the gamma values seem to be off, the previews look too bright for me.
Neph 0 個解決方法 19 個答案

the-edmeister said

Try this. Hit { Ctrl + 0 } (that's the number zero) to reset the zoom factor for that page.
My zoom is set to 100% by default. If I set it to 80%, it shows 12 tiles again but that also decreases the font size, which I don't want.

It looks like it's a bug/change with version 39.

''the-edmeister [[#answer-748773|said]]'' <blockquote> Try this. Hit '''{ Ctrl + 0 }''' (that's the number zero) to reset the zoom factor for that page. </blockquote>My zoom is set to 100% by default. If I set it to 80%, it shows 12 tiles again but that also decreases the font size, which I don't want. It looks like it's a bug/change with version 39.
penguino 0 個解決方法 49 個答案

the-edmeister said

Type about:config in the URL bar and hit Enter. Accept the warning message. Using the Search filed at the top, locate these two preferences. browser.newtabpage.columns and browser.newtabpage.rows Right-click each pref under Preference Name and select Modify. Then insert the Value you desire for each pref. You may need to restart Firefox using Exit and then opening it again. I use the New Tab Tools extension for setting those prefs and use a background image for the new tab. https://addons.mozilla.org/en-US/firefox/addon/new-tab-tools/

It doesn't work, there are correct numbers in "about"config" preferences. They're just not showing up unless zoomed out. No matter what number you put in browser.newtabpage.rows it shows just two rows without zooming.

''the-edmeister [[#answer-748762|said]]'' <blockquote> Type '''about:config''' in the URL bar and hit Enter. ''Accept the warning message.'' Using the Search filed at the top, locate these two preferences. '''browser.newtabpage.columns''' and '''browser.newtabpage.rows''' Right-click each pref under Preference Name and select '''''Modify'''''. Then insert the Value you desire for each pref. You may need to restart Firefox using Exit and then opening it again. ''I use the New Tab Tools extension for setting those prefs and use a background image for the new tab.'' https://addons.mozilla.org/en-US/firefox/addon/new-tab-tools/ </blockquote> It doesn't work, there are correct numbers in "about"config" preferences. They're just not showing up unless zoomed out. No matter what number you put in '''browser.newtabpage.rows''' it shows just two rows without zooming.

由 penguino 於 修改

提出問題者

the-edmeister said

Type about:config in the URL bar and hit Enter. Accept the warning message. Using the Search filed at the top, locate these two preferences. browser.newtabpage.columns and browser.newtabpage.rows Right-click each pref under Preference Name and select Modify. Then insert the Value you desire for each pref. You may need to restart Firefox using Exit and then opening it again. I use the New Tab Tools extension for setting those prefs and use a background image for the new tab. https://addons.mozilla.org/en-US/firefox/addon/new-tab-tools/


It actually appears that this only partly works. Both are set to 3(rows) and 5 (Columns) but still only shows up with 10 instead of 15. Will try that addon.

''the-edmeister [[#answer-748762|said]]'' <blockquote> Type '''about:config''' in the URL bar and hit Enter. ''Accept the warning message.'' Using the Search filed at the top, locate these two preferences. '''browser.newtabpage.columns''' and '''browser.newtabpage.rows''' Right-click each pref under Preference Name and select '''''Modify'''''. Then insert the Value you desire for each pref. You may need to restart Firefox using Exit and then opening it again. ''I use the New Tab Tools extension for setting those prefs and use a background image for the new tab.'' https://addons.mozilla.org/en-US/firefox/addon/new-tab-tools/ </blockquote> It actually appears that this only partly works. Both are set to 3(rows) and 5 (Columns) but still only shows up with 10 instead of 15. Will try that addon.
JamesPhilipCasey 0 個解決方法 2 個答案

I have experienced the same issue since 'upgrading' to FF39. It thus seems unanimous so far that the suggested about:config workaround is not going to solve this issue. Does anyone know how to get any feedback from Mozilla directly? It would seem straightforward for Mozilla to allow a zoom out feature that applies only to tab pages.

I have experienced the same issue since 'upgrading' to FF39. It thus seems unanimous so far that the suggested '''about:config''' workaround is not going to solve this issue. Does anyone know how to get any feedback from Mozilla directly? It would seem straightforward for Mozilla to allow a zoom out feature that applies only to tab pages.
Garlino 0 個解決方法 3 個答案

I tried the workaround described in this thread by Scribe. It works, but everything looks too small.

I tried the workaround described in [https://support.mozilla.org/de/questions/1070115 this thread] by Scribe. It works, but everything looks too small.

由 Garlino 於 修改

the-edmeister
  • Top 25 Contributor
  • Moderator
5406 個解決方法 40236 個答案

有幫助的回覆

I am running Windows 7, as the OP in this thread is running, and I see an issue when the Firefox browser window is not maximized. Maximized (without the Bookmarks Toolbar showing) I see 5 columns and 3 rows with default settings in about:config @ 1600x900 resolution. As soon as I minimize the window, even though it is taking up the full monitor (with the Windows Taskbar unlocked) I lose one row of tiles. With the Bookmarks Toolbar showing I lose two rows when Maximized and lose one column = 3 tiles appear on one row.

I can't say if that differs from Firefox 38 or not, as I rarely open my "default" Profile and my "working" Profiles all have the New Tab Tools extension installed.

IMHO something with the Bookmarks Toolbar is screwing up the tiles rows and columns, at least from what I am seeing. And now after showing and then hiding the BTB again I am stuck with one row or 4 tiles, even after restarting Firefox 39 - like it permanently is "broken" now.

"Someone" needs to file a Bug report, IMO. https://developer.mozilla.org/en/Bug_writing_guidelines

Personally, I am so thoroughly disgusted with the "path" Firefox is now on that I "bow out" from filing any Bug reports, especially if the manner in which I use Firefox isn't directly affected by what I see as a Bug. Too many years of Bug reports that I have filed not leading to my "perceived Bug" even being discussed seriously, much less fixed as I expected. And when the day comes that I can't find an extension to "fix" what I find wrong, I'll either learn to live with it or seek out an alternative browser to use - something I have been swearing to do since Firefox 4.0 was released over 4 years ago.

I am running Windows 7, as the OP in this thread is running, and I see an issue when the Firefox browser window is not maximized. Maximized (without the Bookmarks Toolbar showing) I see 5 columns and 3 rows with default settings in about:config @ 1600x900 resolution. As soon as I minimize the window, even though it is taking up the full monitor ''(with the Windows Taskbar unlocked)'' I lose one row of tiles. With the Bookmarks Toolbar showing I lose two rows when Maximized and lose one column = 3 tiles appear on one row. I can't say if that differs from Firefox 38 or not, as I rarely open my "default" Profile and my "working" Profiles all have the New Tab Tools extension installed. IMHO something with the Bookmarks Toolbar is screwing up the tiles rows and columns, at least from what I am seeing. And now after showing and then hiding the BTB again I am stuck with one row or 4 tiles, even after restarting Firefox 39 - like it permanently is "broken" now. "Someone" needs to file a Bug report, IMO. https://developer.mozilla.org/en/Bug_writing_guidelines Personally, I am so thoroughly disgusted with the "path" Firefox is now on that I "bow out" from filing any Bug reports, especially if the manner in which I use Firefox isn't directly affected by what I see as a Bug. Too many years of Bug reports that I have filed not leading to my "perceived Bug" even being discussed seriously, much less fixed as I expected. And when the day comes that I can't find an extension to "fix" what I find wrong, I'll either learn to live with it or seek out an alternative browser to use - ''something I have been swearing to do since Firefox 4.0 was released over 4 years ago.''
JamesPhilipCasey 0 個解決方法 2 個答案

Thanks go to Garlino and the-edmeister for their respective interventions. My Firefox is on Windows 8, so it is clear that the issue is not the operating system. I am going to try and file a 'bug report' as suggested by the-edmeister. If some others do this as well, it is possible Mozilla will notice and take it more seriously. No one wants to zoom in to 80% or more just to take advantage of the tiles available on tab pages.

Thanks go to '''Garlino''' and '''the-edmeister''' for their respective interventions. My Firefox is on Windows 8, so it is clear that the issue is not the operating system. I am going to try and file a 'bug report' as suggested by the-edmeister. If some others do this as well, it is possible Mozilla will notice and take it more seriously. No one wants to zoom in to 80% or more just to take advantage of the tiles available on tab pages.
lizhenry 2 個解決方法 49 個答案

Sounds like we should file a bug. JamesPhillipCasey what is the bug number? Thanks!

Sounds like we should file a bug. JamesPhillipCasey what is the bug number? Thanks!
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 個解決方法 40236 個答案

One person should file a Bug report and hyperlink that report in this forum; then others with this fault should post in that Bug report to confirm. Posting multiple Bug reports about the same issue isn't going to "impress" the triage team. On the contrary multiple identical / duplicate reports may tend to slow down the response because once the triage team "assigns" the report to the module owner, everyone associated with that module will get a message about that Bug => better off letting the developers spend their time fixing stuff instead of reading the duplicated Bug reports.


Quite honestly it is my considered opinion that the new tab page and those tiles isn't a "real feature" for Firefox users any longer. It's a way of generating revenue for Mozilla (which is can use to expand what they do) with some screened advertisement content inserted when the user doesn't have enough browsing history to fill all the tiles. My advice is to set a different new tab page or use an extension to enhance and 'fix' the new tab page.

'''One''' person should file a Bug report and hyperlink that report in this forum; then others with this fault should post in that Bug report to confirm. Posting multiple Bug reports about the same issue isn't going to "impress" the triage team. On the contrary multiple identical / duplicate reports may tend to slow down the response because once the triage team "assigns" the report to the module owner, everyone associated with that module will get a message about that Bug => better off letting the developers spend their time fixing stuff instead of reading the duplicated Bug reports. ------------ Quite honestly it is my considered opinion that the new tab page and those tiles isn't a "real feature" for Firefox users any longer. It's a way of generating revenue for Mozilla ''(which is can use to expand what they do)'' with some screened advertisement content inserted when the user doesn't have enough browsing history to fill all the tiles. My advice is to set a different new tab page or use an extension to enhance and 'fix' the new tab page.
lizhenry 2 個解決方法 49 個答案

This may cover the issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1180387.

I'll link to this support question from that bug and we can go from there.

This may cover the issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1180387. I'll link to this support question from that bug and we can go from there.
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 個解決方法 40236 個答案

Thank you posting that Bug report link.

Thank you posting that Bug report link.
Moltres Rider 0 個解決方法 10 個答案

有幫助的回覆

Same problem with me!!! zooming out DID NOT help as it ALWAYS reverts the zoom, closing Firefox or not, DOESN'T MATTER!!!

Same problem with me!!! zooming out DID NOT help as it ALWAYS reverts the zoom, closing Firefox or not, DOESN'T MATTER!!!