Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

I can't change my search settings after I go to options, I click search and it doesn't show it.

  • 14 回覆
  • 8 有這個問題
  • 5217 次檢視
  • 最近回覆由 petfam

more options

I'm trying to get back my original settings after cleaning out some malware. Before, I could open the browser and surf and if I had a question about a word or name, statement, etc., I could copy and right click and choose "look up word on google" along with 4-5 other choices. Now when I try it, the list gives me about 30 choices, none of which are "look up on google". I went to options and in the column on the left side I tried to click "search" to no avail. If I click the other tabs (General, content, applications, etc) they all give me options. But when I click search only the previous tabs choices show. The search tab is there but does nothing. :) Thanks for any help!

被選擇的解決方法

Got it jscher2000! Thanks. And thanks to cor-el.

After I performed your suggestions, there was still no search tab....BUT...I remembered I left "browser.search.showOneOffButtons" to false. I went and changed it back to true and now I have the search tab!!

Can I delete the "C:\Program Files (x86)\OldFirefox" safely now?

One more note, I agree my malware cleanup could have caused the problem. Even though I've used malwarebytes for years safely. But I remember downloading something about the time I started having problems that I think was the culprit: UMMY video downloader! Right after I downloaded it I saw they changed my search engine from Google to Bing and a few other things. Ok, just an FYI and a big thanks for the help! :)

從原來的回覆中察看解決方案 👍 0

All Replies (14)

more options

On the right-click context menu, Firefox should have one entry for

Search [default search engine] for [selected text]

but it won't list other search engine choices. If you had that before, it probably was a feature of an add-on.

Regarding the "Search" section of the Options/Preferences page, I think this can be blank or nonfunctional if you changed the search bar style back to the old style (switched the browser.search.showOneOffButtonspreference to false). In order to modify search settings with the old search bar you can paste the following internal address into the address bar and press Enter to load it:

chrome://browser/content/search/engineManager.xul

Well, actually, anyone can use that page if they like.

Does that work?

more options

Thanks for the speedy response and help!

The right click situation might have been from an add-on. I had not worried about my browser in so long I forgot the ones I had! LOL There were only a few but that's probably it, thanks!

As for the "Search" problem. I copied and pasted that address into the address bar in the upper left of the page, the center search bar, and the google search bar on my home page and none of them did anything. Well, the google one brought me to a different firefox support question. But I went to "open options" and clicked on the search tab on the left and still no search section. I don't think I changed the style back to the old style. But I HAVE refreshed Firefox about 5 times the past couple days after making changes to try and fix my problem. I MIGHT have changed that oneoffbutton preference to off...can't quite remember. But entering that address into the address bar seems to have done nothing (If I did it right!! LOL).

PS I saw that address says Chrome. Is that correct even though I am on Firefox? Thanks again, Dan

more options

If the address bar doesn't work, something definitely is broken.

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Thanks again! No change when in safe mode. When I click the options gear the option tabs appear on the left side. All tabs (General, search, contents, applications, privacy, security, sync, advanced) appear. I can see the content on every tab except for search. :( What does that tell you now? Thanks again.

more options

You can check if you have the XML files of the default search engines including Google in the browser\searchplugins folder in the Firefox program folder.

If not then you need to reinstall Firefox.


Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

You can use this button to go to the currently used Firefox profile folder:

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.

more options

Thank you!

I pulled up the profile folder and only found search.json (There were no other search files). I deleted search.json. Then I started Firefox again and the search tab will still not bring up it's info. All the other tabs still work. Then I went back to the profile folder and saw search.json was there again like you said. :( Did I do it right? LOL And if my next step is to reinstall firefox I'm thinking you have links to guide me thru that also? Thanks again!

more options

Do you see all installed search engines in "Options/Preferences > Search" and in the drop down that opens if you type a search query in the search bar?

more options

Thanks again! Sorry for the delay.

I'm not sure I understand the question. When I click options (The gear icon in my upper right bar), it opens a list of tabs on the left column. The second choice is "Search", and when I click it, nothing opens. Only the previous tabs info shows. Like if I click the top tab "General", it shows me the General list (Startup, downloads, tabs). Then if I click the next tab "Search" It still shows the General info. Nothing changes. But If I click the next tab "Content", then the content info shows (DRM, popups, fonts and colors, languages). Then if I click the "Search" tab again, the Content info still shows. The Search tab is there, but the search info does not show. Weird If I type something in the search bar, there IS a drop down that gives me suggestions, but I could not see any installed search engines. I'm sure I just didn't do something right. :)

由 petfam 於 修改

more options

Did you check that all search engines files are still present in the \browser\searchplugins folder in the Firefox program folder?

Are you using the default theme?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can toggle this pref to false with a middle-click on the about:config page to restore the previously used standalone window to manage the search engines.

  • browser.search.showOneOffButtons = false

Close and restart Firefox to make the change effective.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

I'm still not sure I am getting all of this. In a previous message I Said I went to the program folder and removed "search.json", and that was the only one I saw. Now it looks like it is back.

I am using the default theme which currently shows disabled in safe mode. I looked at extensions and all that is there is adblockplus which is currently disabled in safe mode.

Then I went to about:config and middle click didn't seem to do anything, but when I double clicked it then it changes to false. Then I closed firefox and reopened it. Now when I go to open options there is NO start tab at all. Thanks

more options

Hi petfam, it is normal for Firefox to rebuild search.json after you delete it. The idea was to force Firefox to scan for search plugins again.

I am attaching screen shots of the preferences. The first screen you land on is General, and it has the Startup, Download, and Tabs settings. When you click Search, you should see what I've shown in the second screen shot, but I understand yours just keeps showing the General items (or whatever items you last viewed instead of displaying the search items.

If you set the browser.search.showOneOffButtons preference to false, Firefox will show the "old" style search bar. This doesn't affect windows that are currently open, but you can confirm by pressing Ctrl+n to launch a new window. To set options for the old search bar, you need to use the old dialog for now, which was what I mentioned earlier in this post: https://support.mozilla.org/questions/1066877#answer-740383


I think it's possible your malware cleanup damaged some files somewhere. I suggest using the following procedure to rule out possible program file damage:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, missing, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 38.0.5 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder, either:

64-bit Windows Vista/7/8

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

Windows XP and 32-bit Vista/7

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Does a cleanly reinstalled Firefox start normally?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

選擇的解決方法

Got it jscher2000! Thanks. And thanks to cor-el.

After I performed your suggestions, there was still no search tab....BUT...I remembered I left "browser.search.showOneOffButtons" to false. I went and changed it back to true and now I have the search tab!!

Can I delete the "C:\Program Files (x86)\OldFirefox" safely now?

One more note, I agree my malware cleanup could have caused the problem. Even though I've used malwarebytes for years safely. But I remember downloading something about the time I started having problems that I think was the culprit: UMMY video downloader! Right after I downloaded it I saw they changed my search engine from Google to Bing and a few other things. Ok, just an FYI and a big thanks for the help! :)

由 petfam 於 修改

more options

The only parts of OldFirefox you might want to save as the two folders I mentioned toward the end of the procedure. The other stuff is duplicative/obsolete now.

more options

Ok! Thanks again. Have a good one!